summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2015-02-15 07:48:01 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-15 07:51:31 +0700
commit8dad317f61b563ddbeb8413da0014b284e26ee52 (patch)
treec46f7f1023653876560f1fd85c6336ef13f1e8a2 /libraries
parent8ac6f71a893c98918ee0874061aa01bfdf7c7b0a (diff)
downloadslackbuilds-8dad317f61b563ddbeb8413da0014b284e26ee52.tar.gz
slackbuilds-8dad317f61b563ddbeb8413da0014b284e26ee52.tar.xz
libraries/gtkdatabox: Added (GTK+ widget).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/gtkdatabox/README4
-rw-r--r--libraries/gtkdatabox/gtkdatabox.SlackBuild103
-rw-r--r--libraries/gtkdatabox/gtkdatabox.info10
-rw-r--r--libraries/gtkdatabox/slack-desc19
4 files changed, 136 insertions, 0 deletions
diff --git a/libraries/gtkdatabox/README b/libraries/gtkdatabox/README
new file mode 100644
index 0000000000..75b23a4108
--- /dev/null
+++ b/libraries/gtkdatabox/README
@@ -0,0 +1,4 @@
+GtkDatabox is a widget for live display of large amounts of fluctuating
+numerical data. Data presentation (e.g. on linear or logarithmic scales,
+as dots or lines, with markers/labels) as well as user interaction
+(e.g. measuring distances) is easy.
diff --git a/libraries/gtkdatabox/gtkdatabox.SlackBuild b/libraries/gtkdatabox/gtkdatabox.SlackBuild
new file mode 100644
index 0000000000..0462853b9d
--- /dev/null
+++ b/libraries/gtkdatabox/gtkdatabox.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/sh
+
+# Slackware build script for GtkDatabox
+
+# Copyright 2015 Kyle Guinn <elyk03@gmail.com>, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=gtkdatabox
+VERSION=${VERSION:-0.9.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$(uname -m)" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$(uname -m) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README TODO"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go-w,a+rX-st .
+
+# Examples need -lm for sin(). Add it.
+sed -i 's/\(@GTK_LIBS@\)/\1 -lm/' examples/Makefile.am
+autoreconf -vif
+
+CFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-libglade \
+ --enable-glade \
+ --build=$ARCH-slackware-linux
+
+make
+make check
+make install-strip DESTDIR=$PKG
+
+find $PKG/usr/lib${LIBDIRSUFFIX} -name '*.la' -delete
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/gtkdatabox/gtkdatabox.info b/libraries/gtkdatabox/gtkdatabox.info
new file mode 100644
index 0000000000..df742be081
--- /dev/null
+++ b/libraries/gtkdatabox/gtkdatabox.info
@@ -0,0 +1,10 @@
+PRGNAM="gtkdatabox"
+VERSION="0.9.2.0"
+HOMEPAGE="http://sourceforge.net/projects/gtkdatabox/"
+DOWNLOAD="http://downloads.sourceforge.net/gtkdatabox/gtkdatabox-0.9.2.0.tar.gz"
+MD5SUM="99c1fe9a918ee94e2b6f967cd22a6f5b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Kyle Guinn"
+EMAIL="elyk03@gmail.com"
diff --git a/libraries/gtkdatabox/slack-desc b/libraries/gtkdatabox/slack-desc
new file mode 100644
index 0000000000..c4b419d00d
--- /dev/null
+++ b/libraries/gtkdatabox/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gtkdatabox: GtkDatabox (GTK+ widget)
+gtkdatabox:
+gtkdatabox: GtkDatabox is a widget for live display of large amounts of
+gtkdatabox: fluctuating numerical data. Data presentation (e.g. on linear or
+gtkdatabox: logarithmic scales, as dots or lines, with markers/labels) as well as
+gtkdatabox: user interaction (e.g. measuring distances) is easy.
+gtkdatabox:
+gtkdatabox:
+gtkdatabox:
+gtkdatabox:
+gtkdatabox: