summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Marcel Saegebarth <marc@mos6581.de>2014-12-29 23:49:34 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-12-29 23:49:34 +0700
commit18f052e822c14bc962aae730c66f00c80d78a841 (patch)
treebdbe8027b9db112ae829b189b64ae98a1e4bb725 /multimedia
parenta6f7c2845fcf0bb0679b7d1578eef31e2df2fa2e (diff)
downloadslackbuilds-18f052e822c14bc962aae730c66f00c80d78a841.tar.gz
slackbuilds-18f052e822c14bc962aae730c66f00c80d78a841.tar.xz
multimedia/picard: Updated for version 1.3.1 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/picard/README14
-rw-r--r--multimedia/picard/doinst.sh1
-rw-r--r--multimedia/picard/picard.SlackBuild43
-rw-r--r--multimedia/picard/picard.info14
-rw-r--r--multimedia/picard/slack-desc14
5 files changed, 55 insertions, 31 deletions
diff --git a/multimedia/picard/README b/multimedia/picard/README
index 781ff9e830..6ab65bd24e 100644
--- a/multimedia/picard/README
+++ b/multimedia/picard/README
@@ -1,5 +1,9 @@
-Picard is the next generation MusicBrainz tagging application. This new
-tagging concept is album oriented, as opposed to track/file oriented like
-the ClassicTagger was. Picard is written in Python, which is a cross-platform
-language, and makes use of cross-platform libraries - this allows the same
-code to run both on Windows, Linux and Mac OS X.
+MusicBrainz Picard is a cross-platform (Linux/Mac OS X/Windows)
+application written in Python. It supports the majority of audio
+file formats, uses PUID audio fingerprints, performs CD lookups
+and disc ID submissions, and it has excellent Unicode support.
+This application is the official MusicBrainz tagging application.
+
+Note: You need to compile and install `chromaprint' with `ffmpeg'
+installed for getting the `fpcalc' utility to lookup the music
+files against `AcoustID' and `MusicBrainz'.
diff --git a/multimedia/picard/doinst.sh b/multimedia/picard/doinst.sh
index a8c38c8a58..76cc38a548 100644
--- a/multimedia/picard/doinst.sh
+++ b/multimedia/picard/doinst.sh
@@ -7,4 +7,3 @@ if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
fi
fi
-
diff --git a/multimedia/picard/picard.SlackBuild b/multimedia/picard/picard.SlackBuild
index 3cb42acd70..96513b7702 100644
--- a/multimedia/picard/picard.SlackBuild
+++ b/multimedia/picard/picard.SlackBuild
@@ -1,10 +1,31 @@
#!/bin/sh
-# Slackware build script for picard
-# Written by Jeremy Brent Hansen admin -at- bassmadrigal.com
+# Slackware build script for "picard".
+
+# Copyright 2014 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=picard
-VERSION=1.2
+VERSION=1.3.1
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -42,24 +63,24 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+cd $PRGNAM-release-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
-python setup.py config
+python setup.py build
python setup.py install --root $PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/multimedia/picard/picard.info b/multimedia/picard/picard.info
index 632ed40c2f..1500a427b5 100644
--- a/multimedia/picard/picard.info
+++ b/multimedia/picard/picard.info
@@ -1,10 +1,10 @@
PRGNAM="picard"
-VERSION="1.2"
-HOMEPAGE="http://musicbrainz.org/doc/Picard_Tagger"
-DOWNLOAD="http://ftp.musicbrainz.org/pub/musicbrainz/picard/picard-1.2.tar.gz"
-MD5SUM="d1086687b7f7b0d359a731b1a25e7b66"
+VERSION="1.3.1"
+HOMEPAGE="https://picard.musicbrainz.org/"
+DOWNLOAD="ftp://ftp.musicbrainz.org/pub/musicbrainz/picard/picard-1.3.1.tar.gz"
+MD5SUM="2c155a0c4a5589c18bac3016365d7fbd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="ffmpeg libofa mutagen"
-MAINTAINER="Michales Michaloudes"
-EMAIL="korgie@gmail.com"
+REQUIRES="mutagen chromaprint"
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"
diff --git a/multimedia/picard/slack-desc b/multimedia/picard/slack-desc
index 3495bc17b5..03e82fa195 100644
--- a/multimedia/picard/slack-desc
+++ b/multimedia/picard/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-picard: Picard Tagger (next generation MusicBrainz tagging application)
+picard: picard (Music Tagger)
picard:
-picard: Picard is the next generation MusicBrainz tagging application. This
-picard: new tagging concept is album oriented, as opposed to track/file
-picard: oriented like the ClassicTagger was. Picard is written in Python,
-picard: which is a cross-platform language, and makes use of cross-platform
-picard: libraries - this allows the same code to run both on Windows, Linux
-picard: and Mac OS X.
+picard: MusicBrainz Picard is a cross-platform (Linux/Mac OS X/Windows)
+picard: application written in Python. It supports the majority of audio
+picard: file formats, uses PUID audio fingerprints, performs CD lookups
+picard: and disc ID submissions, and it has excellent Unicode support.
+picard: This application is the official MusicBrainz tagging application.
picard:
picard: Homepage: http://musicbrainz.org/doc/Picard_Tagger
picard:
+picard: