summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Ruben Schuller <ruben@orgizm.net>2014-11-04 19:51:09 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-11-08 06:30:06 +0700
commit6be68324e4e4ebebb1b01eb031e0b838fe53829b (patch)
tree9c18e2a6aabeea6d02d8066f9df997928a5344b2 /multimedia
parent71fae387daffb400af3af6a76801eb4fd5296dbe (diff)
downloadslackbuilds-6be68324e4e4ebebb1b01eb031e0b838fe53829b.tar.gz
slackbuilds-6be68324e4e4ebebb1b01eb031e0b838fe53829b.tar.xz
multimedia/cantata: Updated for version 1.5.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/cantata/cantata.SlackBuild11
-rw-r--r--multimedia/cantata/cantata.info6
2 files changed, 9 insertions, 8 deletions
diff --git a/multimedia/cantata/cantata.SlackBuild b/multimedia/cantata/cantata.SlackBuild
index 26d8a77239..1d9ee2ba2a 100644
--- a/multimedia/cantata/cantata.SlackBuild
+++ b/multimedia/cantata/cantata.SlackBuild
@@ -24,8 +24,8 @@
PRGNAM=cantata
# this could be set to "svn" to automatically pull the newest source
-VERSION=${VERSION:-1.3.4}
-SRCFILE=${SRCFILE:-"uc?export=download&id=0Bzghs6gQWi60WTYtaXk3c1IzNVU"}
+VERSION=${VERSION:-1.5.1}
+SRCFILE=${SRCFILE:-"uc?export=download&id=0Bzghs6gQWi60UktwaTRMTjRIUW8"}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -100,10 +100,10 @@ rm -rf $PRGNAM-$VERSION
if [ "$VERSION" = "svn" ]; then
svn checkout http://cantata.googlecode.com/svn/trunk/ cantata-svn
else
- if [ -f "$PRGNAM-$VERSION.tar.bz2" ]; then
+ if [ -e $CWD/$PRGNAM-$VERSION.tar.bz2 ]; then
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
else
- tar xvf $CWD/${SRCFILE}
+ tar xvf $CWD/$SRCFILE
fi
fi
@@ -113,7 +113,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
mkdir -p build
cd build
@@ -125,6 +125,7 @@ cd build
-DCMAKE_BUILD_TYPE=Release \
$CMAKEFLAGS ..
sed -i "s|lib/cantata|lib${LIBDIRSUFFIX}/cantata|" ../replaygain/CMakeLists.txt
+ sed -i "s|lib/cantata|lib${LIBDIRSUFFIX}/cantata|" ../tags/CMakeLists.txt
make
make install DESTDIR=$PKG
cd ..
diff --git a/multimedia/cantata/cantata.info b/multimedia/cantata/cantata.info
index f3a7c7303e..02e376b029 100644
--- a/multimedia/cantata/cantata.info
+++ b/multimedia/cantata/cantata.info
@@ -1,8 +1,8 @@
PRGNAM="cantata"
-VERSION="1.3.4"
+VERSION="1.5.1"
HOMEPAGE="https://code.google.com/p/cantata/"
-DOWNLOAD="https://drive.google.com/uc?export=download&id=0Bzghs6gQWi60WTYtaXk3c1IzNVU"
-MD5SUM="5b21329a4b00716f7feb827805f215b5"
+DOWNLOAD="https://drive.google.com/uc?export=download&id=0Bzghs6gQWi60UktwaTRMTjRIUW8"
+MD5SUM="367dab0b94503d1c1d0f4cfb775effca"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="ffmpeg"