summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Ruben Schuller <ruben@orgizm.net>2014-03-31 08:51:54 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-03-31 09:02:01 +0700
commita31c9b6917db9188b1ff7c4a14cf533d1b1c8f25 (patch)
tree59fed1e6ac93cdf5a10820d3d6552c93fcb0a714 /multimedia
parentd5f724b885923669d17e7e8b0fb1281f70f671cc (diff)
downloadslackbuilds-a31c9b6917db9188b1ff7c4a14cf533d1b1c8f25.tar.gz
slackbuilds-a31c9b6917db9188b1ff7c4a14cf533d1b1c8f25.tar.xz
multimedia/cantata: Added (MPD client).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/cantata/README10
-rw-r--r--multimedia/cantata/cantata.SlackBuild134
-rw-r--r--multimedia/cantata/cantata.info10
-rw-r--r--multimedia/cantata/slack-desc19
4 files changed, 173 insertions, 0 deletions
diff --git a/multimedia/cantata/README b/multimedia/cantata/README
new file mode 100644
index 0000000000..b83412aa7d
--- /dev/null
+++ b/multimedia/cantata/README
@@ -0,0 +1,10 @@
+Cantata is a feature-rich graphical client for MPD.
+
+The tarball in the .info file is created from the SVN found at
+http://cantata.googlecode.com/svn/trunk/
+and is not officially hosted by the cantata developers. If you are
+uncomfortable with this, you can use VERSION=svn to pull the sources
+directly from the svn.
+
+Cantata can be build with some additional features.
+See the SlackBuild for information on how to enable them.
diff --git a/multimedia/cantata/cantata.SlackBuild b/multimedia/cantata/cantata.SlackBuild
new file mode 100644
index 0000000000..9677ada3ef
--- /dev/null
+++ b/multimedia/cantata/cantata.SlackBuild
@@ -0,0 +1,134 @@
+#!/bin/sh
+
+# Slackware build script for cantata
+
+# Copyright 2014 Ruben Schuller
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=cantata
+# this could be set to "svn" to automatically pull the newest source
+VERSION=${VERSION:-r4373}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Enable HTTP stream playback
+HTTPPLAYBACK=${HTTPPLAYBACK:-yes}
+
+# KDE related
+# Enable building for KDE4?
+WITHKDE=${WITHKDE:-no}
+
+# Build with KDE-Wallet support? Only used when build with kde support.
+WALLET=${WALLET:-no}
+
+# add extra options
+# (https://code.google.com/p/cantata/source/browse/trunk/INSTALL) here.
+EXTRAOPTIONS=""
+
+CMAKEFLAGS=""
+
+if [ "$WITHKDE" = "yes" ]; then
+ CMAKEFLAGS="-DENABLE_KDE=ON"
+
+ if [ "$WALLET" = "yes" ]; then
+ CMAKEFLAGS="$CMAKEFLAGS -DENABLE_KWALLET=ON"
+ fi
+else
+ CMAKEFLAGS="-DENABLE_KDE=OFF"
+ CMAKEFLAGS="$CMAKEFLAGS -DENABLE_PROXY_CONFIG=ON"
+fi
+
+if [ "$HTTPPLAYBACK" = "yes" ]; then
+ CMAKEFLAGS="$CMAKEFLAGS -DENABLE_HTTP_STREAM_PLAYBACK=ON"
+fi
+
+CMAKEFLAGS="$CMAKEFLAGS $EXTRAOPTIONS"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+
+if [ "$VERSION" = "svn" ]; then
+ svn checkout http://cantata.googlecode.com/svn/trunk/ cantata-svn
+else
+ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+fi
+
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release \
+ $CMAKEFLAGS ..
+ sed -i "s|lib/cantata|lib${LIBDIRSUFFIX}/cantata|" ../replaygain/CMakeLists.txt
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog INSTALL LICENSE README TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/cantata/cantata.info b/multimedia/cantata/cantata.info
new file mode 100644
index 0000000000..da6452e49e
--- /dev/null
+++ b/multimedia/cantata/cantata.info
@@ -0,0 +1,10 @@
+PRGNAM="cantata"
+VERSION="r4373"
+HOMEPAGE="https://code.google.com/p/cantata/"
+DOWNLOAD="http://slackdemand.orgizm.net/files/cantata/cantata-r4373.tar.gz"
+MD5SUM="66656faba49aa9c66f81d6d27fd3cd05"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="ffmpeg"
+MAINTAINER="Ruben Schuller"
+EMAIL="ruben@orgizm.net"
diff --git a/multimedia/cantata/slack-desc b/multimedia/cantata/slack-desc
new file mode 100644
index 0000000000..8dc0ac6095
--- /dev/null
+++ b/multimedia/cantata/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cantata: cantata (MPD client)
+cantata:
+cantata: Cantata is a feature-rich graphical client for MPD.
+cantata:
+cantata:
+cantata:
+cantata:
+cantata:
+cantata:
+cantata:
+cantata: