summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Philip Lacroix <philnx at posteo dot de>2015-03-08 00:05:03 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-03-08 00:05:03 +0700
commitaea9f8baadfaeec9851696909d2a008f476a6fd3 (patch)
treefc32d72f78cbe8ed25e8a7f14e978575f44c3795 /multimedia
parent9ca2501384f54a60a2a7bf64290e40b5ab36890f (diff)
downloadslackbuilds-aea9f8baadfaeec9851696909d2a008f476a6fd3.tar.gz
slackbuilds-aea9f8baadfaeec9851696909d2a008f476a6fd3.tar.xz
multimedia/ucview: Updated for version 20150221.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ucview/patches/patches.README65
-rw-r--r--multimedia/ucview/patches/ucview-0.33-default_image_path.patch18
-rw-r--r--multimedia/ucview/patches/ucview-0.33-default_video_path.patch11
-rw-r--r--multimedia/ucview/patches/ucview-0.33-deprecated_Gtk_setting.patch24
-rw-r--r--multimedia/ucview/patches/ucview-0.33-plugins_mkdir_parents.patch10
-rw-r--r--multimedia/ucview/slack-desc2
-rw-r--r--multimedia/ucview/ucview.SlackBuild48
-rw-r--r--multimedia/ucview/ucview.info8
8 files changed, 24 insertions, 162 deletions
diff --git a/multimedia/ucview/patches/patches.README b/multimedia/ucview/patches/patches.README
deleted file mode 100644
index a77aa855d3..0000000000
--- a/multimedia/ucview/patches/patches.README
+++ /dev/null
@@ -1,65 +0,0 @@
-
-## Notes about patches to UCView 0.33, as applied by this SlackBuild ##
-
-## 2015, Philip Lacroix
-
-
-#~ ucview-0.33-deprecated_Gtk_setting.patch ~#
-
-When switching video encoding from "Uncompressed AVI" to "OGG/Theora", the
-following warning message is triggered for each related spin button, that
-is, for "Target Bitrate", "Encoding Quality" and "Encoding Frame Rate":
-
-> Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page
-> size is deprecated
-
-The cause of this is a deprecated page size setting for 'GtkSpinButton' in
-the function 'gtk_adjustment_new', which should be set to zero. This patch
-sets the page size to zero.
-
-Affected file: 'settings_dialog.c'
-
-References:
-https://blueprints.launchpad.net/ubuntu/+spec/spinbutton-adjustment-warnings
-https://developer.gnome.org/gtk3/unstable/GtkAdjustment.html
-
-
-#~ ucview-0.33-plugins_mkdir_parents.patch ~#
-
-UCView is unable to create a directory for plugins if the parent directory
-'.ucview' is not already there, for example when the box in the 'Select device'
-window was not checked at least once before starting the program. This gives
-the following warning message:
-
-> WARNING **: Failed to create '/home/<user>/.ucview/plugins'
-
-This patch replaces the related occurrence of the function 'g_mkdir()' with
-'g_mkdir_with_parents()'.
-
-Affected file: 'plugin_loader.c'
-
-References:
-https://developer.gnome.org/glib/stable/glib-File-Utilities.html
-
-
-#~ ucview-0.33-default_video_path.patch ~#
-
-The path where captured videos will be stored is NULL by default, even if the
-related Gtk widget shows the user's home directory. Therefore, videos cannot
-be saved unless the path is set explicitly by the user.
-
-This patch allows the path to be set by default with the user's home directory.
-
-Affected file: 'callbacks.c'
-
-
-#~ ucview-0.33-default_image_path.patch ~#
-
-This problem is similar to the previous one, but is related to the path where
-still images should be stored. Images cannot be saved because the default path
-is NULL, unless it is set explicitly by the user.
-
-This patch allows the path to be set by default with the user's home directory.
-
-Affected file: 'ucview-window.c'
-
diff --git a/multimedia/ucview/patches/ucview-0.33-default_image_path.patch b/multimedia/ucview/patches/ucview-0.33-default_image_path.patch
deleted file mode 100644
index 09ab04d978..0000000000
--- a/multimedia/ucview/patches/ucview-0.33-default_image_path.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -r -U 2 a/ucview-0.33/src/ucview-window.c b/ucview-0.33/src/ucview-window.c
---- a/ucview-0.33/src/ucview-window.c 2009-12-08 18:24:08.000000000 +0100
-+++ b/ucview-0.33/src/ucview-window.c 2015-02-10 19:34:41.104729578 +0100
-@@ -714,4 +714,7 @@
- if( !filename ){
- path = gconf_client_get_string( window->client, UCVIEW_GCONF_DIR "/still_image_file_path", NULL );
-+ if( !path ){
-+ path = g_get_home_dir();
-+ }
- if( !g_file_test( path, ( G_FILE_TEST_IS_DIR ) ) ){
- g_set_error( error, UCVIEW_ERROR, 0, _("Path '%s' does not exist"), path );
-@@ -755,5 +758,5 @@
- sidebar_add_image( SIDEBAR( window->sidebar ), buffer, filename );
-
-- g_free( path );
-+/* g_free( path ); */
- g_free( filetype );
- g_free( filename );
diff --git a/multimedia/ucview/patches/ucview-0.33-default_video_path.patch b/multimedia/ucview/patches/ucview-0.33-default_video_path.patch
deleted file mode 100644
index 116474b071..0000000000
--- a/multimedia/ucview/patches/ucview-0.33-default_video_path.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -r -U 2 a/ucview-0.33/src/callbacks.c b/ucview-0.33/src/callbacks.c
---- a/ucview-0.33/src/callbacks.c 2010-03-18 10:28:46.000000000 +0100
-+++ b/ucview-0.33/src/callbacks.c 2015-02-10 19:29:27.329625095 +0100
-@@ -229,4 +229,7 @@
-
- path = gconf_client_get_string( window->client, UCVIEW_GCONF_DIR "/video_file_path", NULL );
-+ if( !path ){
-+ path = g_get_home_dir();
-+ }
- if( !g_file_test( path, ( G_FILE_TEST_IS_DIR ) ) )
- {
diff --git a/multimedia/ucview/patches/ucview-0.33-deprecated_Gtk_setting.patch b/multimedia/ucview/patches/ucview-0.33-deprecated_Gtk_setting.patch
deleted file mode 100644
index 7923c23953..0000000000
--- a/multimedia/ucview/patches/ucview-0.33-deprecated_Gtk_setting.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -r -U 2 a/ucview-0.33/src/settings_dialog.c b/ucview-0.33/src/settings_dialog.c
---- a/ucview-0.33/src/settings_dialog.c 2009-11-11 18:14:47.000000000 +0100
-+++ b/ucview-0.33/src/settings_dialog.c 2015-02-09 20:41:25.559495493 +0100
-@@ -562,5 +562,5 @@
- default_value = gconf_client_get_int( dlg->client, UCVIEW_GCONF_DIR "/video_theora_bitrate", NULL );
-
-- adj = GTK_ADJUSTMENT( gtk_adjustment_new( default_value, 100.0, 10000.0, 50.0, 250.0, 250.0 ) );
-+ adj = GTK_ADJUSTMENT( gtk_adjustment_new( default_value, 100.0, 10000.0, 50.0, 250.0, 0.0 ) );
- if( ( default_value < 100 ) || ( default_value > 10000 ) )
- {
-@@ -598,5 +598,5 @@
- default_value = gconf_client_get_int( dlg->client, UCVIEW_GCONF_DIR "/video_theora_quality", NULL );
-
-- adj = GTK_ADJUSTMENT( gtk_adjustment_new( default_value, 0.0, 63.0, 1.0, 5.0, 5.0 ) );
-+ adj = GTK_ADJUSTMENT( gtk_adjustment_new( default_value, 0.0, 63.0, 1.0, 5.0, 0.0 ) );
- if( ( default_value < 0 ) || ( default_value > 63 ) )
- {
-@@ -632,5 +632,5 @@
- default_value = gconf_client_get_float( dlg->client, UCVIEW_GCONF_DIR "/video_frame_rate", NULL );
-
-- adj = GTK_ADJUSTMENT( gtk_adjustment_new( default_value, 0.0, 120.0, 1.0, 5.0, 5.0 ) );
-+ adj = GTK_ADJUSTMENT( gtk_adjustment_new( default_value, 0.0, 120.0, 1.0, 5.0, 0.0 ) );
- if( ( default_value <= 0.0 ) || ( default_value > 120.0 ) )
- {
diff --git a/multimedia/ucview/patches/ucview-0.33-plugins_mkdir_parents.patch b/multimedia/ucview/patches/ucview-0.33-plugins_mkdir_parents.patch
deleted file mode 100644
index 98b53184e7..0000000000
--- a/multimedia/ucview/patches/ucview-0.33-plugins_mkdir_parents.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -r -U 2 a/ucview-0.33/src/plugin_loader.c b/ucview-0.33/src/plugin_loader.c
---- a/ucview-0.33/src/plugin_loader.c 2009-11-11 16:05:09.000000000 +0100
-+++ b/ucview-0.33/src/plugin_loader.c 2015-02-09 20:19:38.283750154 +0100
-@@ -241,5 +241,5 @@
- else
- {
-- if( g_mkdir( path, 0755 ) )
-+ if( g_mkdir_with_parents( path, 0755 ) )
- {
- g_warning( "Failed to create '%s'\n", path );
diff --git a/multimedia/ucview/slack-desc b/multimedia/ucview/slack-desc
index b903783ecc..9fed585bc8 100644
--- a/multimedia/ucview/slack-desc
+++ b/multimedia/ucview/slack-desc
@@ -15,5 +15,5 @@ ucview:
ucview: UCView is a video capture and display program based on the unicap
ucview: video imaging library.
ucview:
-ucview: Homepage: http://unicap-imaging.org
+ucview: Homepage: https://github.com/unicap
ucview:
diff --git a/multimedia/ucview/ucview.SlackBuild b/multimedia/ucview/ucview.SlackBuild
index 3d953744d7..2df5c27f43 100644
--- a/multimedia/ucview/ucview.SlackBuild
+++ b/multimedia/ucview/ucview.SlackBuild
@@ -23,7 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ucview
-VERSION=${VERSION:-0.33}
+VERSION=${VERSION:-20150221}
+SRCVERSION=${SRCVERSION:-29bd93aeef0573c58c9aee665dc43fdfd1f77a1f}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,9 +60,17 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$SRCVERSION
+
+# The upstream tarball will be named differently, depending on the
+# file being downloaded manually (web browser) or with wget.
+if [ -e $CWD/$SRCVERSION.tar.gz ]; then
+ tar xvzf $CWD/$SRCVERSION.tar.gz
+else
+ tar xvzf $CWD/$PRGNAM-$SRCVERSION.tar.gz
+fi
+
+cd $PRGNAM-$SRCVERSION/trunk/$PRGNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,35 +78,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-PTC=$CWD/patches
-
-## Fixing a few bugs. For more information than those provided below please
-## see the related file: 'patches/patches.README'.
-
-# 1) Fix bug caused by a deprecated page size setting of 'GtkSpinButton' in
-# function 'gtk_adjustment_new'. The bug triggers error messages when video
-# encoding is switched to OGG/Theora (i.e. one message for each related spin
-# button).
-patch src/settings_dialog.c < $PTC/ucview-0.33-deprecated_Gtk_setting.patch
-
-# 2) Fix bug caused by UCView not being able to create a directory for plugins
-# when the parent directory '.ucview' is not already there (e.g. when the box
-# in the 'Select device' window was not checked at least once).
-patch src/plugin_loader.c < $PTC/ucview-0.33-plugins_mkdir_parents.patch
-
-# 3) Fix bug caused by the path for captured video files being set by default
-# to NULL, thus not allowing to save anything unless it is set explicitly.
-patch src/callbacks.c < $PTC/ucview-0.33-default_video_path.patch
-
-# 4) Something similar to 3) happens to the path for image files as well.
-patch src/ucview-window.c < $PTC/ucview-0.33-default_image_path.patch
-
PRGMAN=$PKG/usr/man/man1
PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+# Remove reference to non existent 'm4' directory.
+sed -i -e "s~^ACLOCAL_AMFLAGS.*$~~" Makefile.am
+
+autoreconf --force --install
+intltoolize --force
+
CFLAGS="$SLKCFLAGS" \
-# Compiler fails without this library:
-LIBS="-lgmodule-2.0" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
diff --git a/multimedia/ucview/ucview.info b/multimedia/ucview/ucview.info
index 9d9c8e1a81..910e108814 100644
--- a/multimedia/ucview/ucview.info
+++ b/multimedia/ucview/ucview.info
@@ -1,8 +1,8 @@
PRGNAM="ucview"
-VERSION="0.33"
-HOMEPAGE="http://unicap-imaging.org/"
-DOWNLOAD="http://unicap-imaging.org/downloads/ucview-0.33.tar.gz"
-MD5SUM="da609cf706e70254abea06cc1fb495e2"
+VERSION="20150221"
+HOMEPAGE="https://github.com/unicap"
+DOWNLOAD="https://github.com/unicap/ucview/archive/29bd93aeef0573c58c9aee665dc43fdfd1f77a1f.tar.gz"
+MD5SUM="fa690066c543ba9beb8c294466eed4b4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libunicapgtk"