summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Tak Ooishi <rootisfun@gadgetinventor.com>2014-05-23 09:14:55 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-05-23 09:19:52 +0700
commitdcdc96075b5b196892f8cd573fa7c79928a625c4 (patch)
tree6a086fede444f0f57eb1e05f68e305e28f8540a8 /multimedia
parent90d956fac1e9de673917a084dcdbc5801ede6098 (diff)
downloadslackbuilds-dcdc96075b5b196892f8cd573fa7c79928a625c4.tar.gz
slackbuilds-dcdc96075b5b196892f8cd573fa7c79928a625c4.tar.xz
multimedia/kdenlive: Updated for version 0.9.8 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/kdenlive/README14
-rw-r--r--multimedia/kdenlive/doinst.sh1
-rw-r--r--multimedia/kdenlive/kdenlive.SlackBuild78
-rw-r--r--multimedia/kdenlive/kdenlive.info10
-rw-r--r--multimedia/kdenlive/slack-desc4
5 files changed, 74 insertions, 33 deletions
diff --git a/multimedia/kdenlive/README b/multimedia/kdenlive/README
index b8b68bc157..b261b246e5 100644
--- a/multimedia/kdenlive/README
+++ b/multimedia/kdenlive/README
@@ -1,8 +1,10 @@
-Kdenlive is an intuitive and powerful multi-track video editor including
-most recent video technologies.
+Kdenlive is an intuitive and powerful non-linear multi-track video editor which
+supports DV, AVCHD and HDV editing, using many of the latest video technologies.
-If you do not have the KDE desktop installed, you will need at least
-these two packages:
+Currently under development and using the MLT video framework, Kdenlive provides dual
+video monitors, a multi-track timeline and clip list. Features include customizable
+layout support, basic effects and transitions, in-program access to online resources
+from Freesound, Archive.org, and Open Clip Art. Kdenlive also features integrated
+basic DVD authoring capability.
-kdelibs
-kdebase
+If you do not have KDE desktop installed, you will need at least: kdelibs, kdebase
diff --git a/multimedia/kdenlive/doinst.sh b/multimedia/kdenlive/doinst.sh
index 81b301c3a3..9aeb8dcfc4 100644
--- a/multimedia/kdenlive/doinst.sh
+++ b/multimedia/kdenlive/doinst.sh
@@ -17,4 +17,3 @@ if [ -e usr/share/icons/oxygen/icon-theme.cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/oxygen >/dev/null 2>&1
fi
fi
-
diff --git a/multimedia/kdenlive/kdenlive.SlackBuild b/multimedia/kdenlive/kdenlive.SlackBuild
index 7fa4ede450..5e1102256c 100644
--- a/multimedia/kdenlive/kdenlive.SlackBuild
+++ b/multimedia/kdenlive/kdenlive.SlackBuild
@@ -2,6 +2,45 @@
# Slackware build script for kdenlive
+# Copyright 2014 Tak Ooishi, Alberta, Canada <rootisfun (at) gadgetinventor com>
+# Original SBo script by stormtracknole <stormtracknole (at) gmail com> 8/5/2009
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# NOTES
+# -----
+# This package can be successfully built on Slackware 13.37/14.0 with the
+# addition of qjson (available on SlackBuilds.org) as an additional
+# dependency.
+
+# CHANGELOG
+# ---------
+# 2014 MAY 22
+# SBo maintainer change: Tak Ooishi <rootisfun (at) gadgetinventor com>
+# * Add license to build script as per SBo requirement
+# * Updated to version 0.9.8 released on 2014 MAY 14
+# * Upstream tarball filename format changed again
+# * Workaround for CMakeList.txt error at build time
+# * Updated slack-desc and README
+# * INSTALL no longer in upstream tarball
+# * Add ChangeLog to installed documentation
+# * Minor changes for consistency with SBo cmake-template
# +---------------------------------------+
# stormtracknole stormtracknole@gmail.com
# 8/5/2009
@@ -22,7 +61,7 @@
# +---------------------------------------+
PRGNAM=kdenlive
-VERSION=${VERSION:-0.9.6}
+VERSION=${VERSION:-0.9.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,33 +98,34 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION-1.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
- .
-
-make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Workaround for CMakeList.txt error at build time on some versions of Slackware
+sed -i.bak -e '69d' src/CMakeLists.txt
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ .
+ make
+ make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING INSTALL README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING README ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/multimedia/kdenlive/kdenlive.info b/multimedia/kdenlive/kdenlive.info
index 8215c275e5..fe096509ff 100644
--- a/multimedia/kdenlive/kdenlive.info
+++ b/multimedia/kdenlive/kdenlive.info
@@ -1,10 +1,10 @@
PRGNAM="kdenlive"
-VERSION="0.9.6"
+VERSION="0.9.8"
HOMEPAGE="http://www.kdenlive.org/"
-DOWNLOAD="http://download.kde.org/stable/kdenlive/0.9.6/src/kdenlive-0.9.6.tar.bz2"
-MD5SUM="3bd3a511b860490acc367e7c9d7ffa43"
+DOWNLOAD="http://download.kde.org/stable/kdenlive/0.9.8/src/kdenlive-0.9.8-1.tar.bz2"
+MD5SUM="6c28868598eecd878b9d041bb3900615"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="amrnb dvdauthor dvgrab faac faad2 gsm lame mlt recordmydesktop schroedinger x264 xvidcore"
-MAINTAINER="stormtracknole"
-EMAIL="stormtracknole@gmail.com"
+MAINTAINER="Tak Ooishi"
+EMAIL="rootisfun@gadgetinventor.com"
diff --git a/multimedia/kdenlive/slack-desc b/multimedia/kdenlive/slack-desc
index 7542bebf74..2a377b0c1a 100644
--- a/multimedia/kdenlive/slack-desc
+++ b/multimedia/kdenlive/slack-desc
@@ -11,8 +11,8 @@ kdenlive:
kdenlive: Using the MLT video framework. It is currently under development
kdenlive: Kdenlive provides dual video monitors, a multi-track timeline and
kdenlive: clip list. Other features include customizable layout support, basic
-kdenlive: effects and transition.
-kdenlive:
+kdenlive: effects and transition, direct import from online resources such as
+kdenlive: Freesound, Archive.org, and Open Clip Art. Integrated DVD authoring.
kdenlive:
kdenlive: http://kdenlive.sourceforge.net
kdenlive: