summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Thomas Szteliga <ts@websafe.pl>2015-08-11 13:25:01 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-08-11 23:25:30 +0700
commit1223c4f3e7b57977a47c350868293d93ae3c3fba (patch)
tree052d1dbc153ae444c88c84e7421e66bc8d5edffd /network
parentedc246d09fc9a14b324cab5a99b630a08fa9b5ee (diff)
downloadslackbuilds-1223c4f3e7b57977a47c350868293d93ae3c3fba.tar.gz
slackbuilds-1223c4f3e7b57977a47c350868293d93ae3c3fba.tar.xz
network/aggregate: Added (optimise a list of route prefixes).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/aggregate/Makefile.in.patch19
-rw-r--r--network/aggregate/README11
-rw-r--r--network/aggregate/aggregate.SlackBuild103
-rw-r--r--network/aggregate/aggregate.info10
-rw-r--r--network/aggregate/slack-desc19
5 files changed, 162 insertions, 0 deletions
diff --git a/network/aggregate/Makefile.in.patch b/network/aggregate/Makefile.in.patch
new file mode 100644
index 0000000000..13ca370931
--- /dev/null
+++ b/network/aggregate/Makefile.in.patch
@@ -0,0 +1,19 @@
+--- Makefile.in 2002-03-06 17:59:37.000000000 +0100
++++ Makefile.in.patched 2015-08-10 16:10:50.439007299 +0200
+@@ -41,10 +41,12 @@
+ rm -f *.o
+
+ install: $(PROGS)
+- $(INSTALL) -m 0755 aggregate $(prefix)/bin/
+- $(INSTALL) -m 0644 aggregate.1 $(prefix)/man/man1/
+- $(INSTALL) -m 0755 aggregate-ios $(prefix)/bin/
+- $(INSTALL) -m 0644 aggregate-ios.1 $(prefix)/man/man1/
++ $(INSTALL) -m 0755 -d $(DESTDIR)$(prefix)/bin/
++ $(INSTALL) -m 0755 -d $(DESTDIR)$(prefix)/man/man1/
++ $(INSTALL) -m 0755 aggregate $(DESTDIR)$(prefix)/bin/
++ $(INSTALL) -m 0644 aggregate.1 $(DESTDIR)$(prefix)/man/man1/
++ $(INSTALL) -m 0755 aggregate-ios $(DESTDIR)$(prefix)/bin/
++ $(INSTALL) -m 0644 aggregate-ios.1 $(DESTDIR)$(prefix)/man/man1/
+
+ .c.o:
+ $(CC) -c $(CPPFLAGS) $(DEFS) $(CFLAGS) $<
diff --git a/network/aggregate/README b/network/aggregate/README
new file mode 100644
index 0000000000..dab400845a
--- /dev/null
+++ b/network/aggregate/README
@@ -0,0 +1,11 @@
+aggregate (optimise a list of route prefixes)
+
+Takes a list of prefixes in conventional format on stdin, and
+performs two optimisations to attempt to reduce the length of the
+prefix list. The first optimisation is to remove any supplied
+prefixes which are superfluous because they are already included in
+another supplied prefix. For example, 203.97.2.0/24 would be removed
+if 203.97.0.0/17 was also supplied. The second optimisation
+identifies adjacent prefixes that can be combined under a single,
+shorter-length prefix. For example, 203.97.2.0/24 and 203.97.3.0/24
+can be combined into the single prefix 203.97.2.0/23.
diff --git a/network/aggregate/aggregate.SlackBuild b/network/aggregate/aggregate.SlackBuild
new file mode 100644
index 0000000000..f678428557
--- /dev/null
+++ b/network/aggregate/aggregate.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/sh
+
+# Slackware build script for aggregate
+
+# Copyright (c) 2014-2015 Thomas Szteliga <ts@websafe.pl>
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+PRGNAM=aggregate
+VERSION=${VERSION:-1.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch Makefile.in $CWD/Makefile.in.patch
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a HISTORY LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+chmod -x $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/aggregate/aggregate.info b/network/aggregate/aggregate.info
new file mode 100644
index 0000000000..3748638cc3
--- /dev/null
+++ b/network/aggregate/aggregate.info
@@ -0,0 +1,10 @@
+PRGNAM="aggregate"
+VERSION="1.6"
+HOMEPAGE="http://ftp.isc.org/isc/aggregate/"
+DOWNLOAD="http://ftp.isc.org/isc/aggregate/aggregate-1.6.tar.gz"
+MD5SUM="6fcc515388bf2c5b0c8f9f733bfee7e1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Thomas Szteliga"
+EMAIL="ts@websafe.pl"
diff --git a/network/aggregate/slack-desc b/network/aggregate/slack-desc
new file mode 100644
index 0000000000..6d9a3acb26
--- /dev/null
+++ b/network/aggregate/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+aggregate: aggregate (optimise a list of route prefixes)
+aggregate:
+aggregate: Takes a list of prefixes in conventional format on stdin, and
+aggregate: performs two optimisations to attempt to reduce the length of the
+aggregate: prefix list. The first optimisation is to remove any supplied
+aggregate: prefixes which are superfluous because they are already included in
+aggregate: another supplied prefix. For example, 203.97.2.0/24 would be removed
+aggregate: if 203.97.0.0/17 was also supplied. The second optimisation
+aggregate: identifies adjacent prefixes that can be combined under a single,
+aggregate: shorter-length prefix. For example, 203.97.2.0/24 and 203.97.3.0/24
+aggregate: can be combined into the single prefix 203.97.2.0/23.