summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2015-05-16 00:28:33 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-05-17 23:45:36 +0700
commit1719eeb1ee47bf6346a0b8d73f81c4c46796a3de (patch)
treed9bcc6b4ffde00ff49483e82623b69231130bf4b /network
parent7f1d5edd719ff4f3a006a3a3e69fd483e94ad5e3 (diff)
downloadslackbuilds-1719eeb1ee47bf6346a0b8d73f81c4c46796a3de.tar.gz
slackbuilds-1719eeb1ee47bf6346a0b8d73f81c4c46796a3de.tar.xz
network/deis: Updated for version 1.6.1.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'network')
-rw-r--r--network/deis/deis.SlackBuild4
-rw-r--r--network/deis/deis.info8
-rw-r--r--network/deis/setup.patch25
3 files changed, 5 insertions, 32 deletions
diff --git a/network/deis/deis.SlackBuild b/network/deis/deis.SlackBuild
index a8059c53a2..c2b904f62b 100644
--- a/network/deis/deis.SlackBuild
+++ b/network/deis/deis.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=deis
-VERSION=${VERSION:-1.6.0}
+VERSION=${VERSION:-1.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,8 +69,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/setup.patch
-
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/network/deis/deis.info b/network/deis/deis.info
index e2de8f070f..4c7fb80ab3 100644
--- a/network/deis/deis.info
+++ b/network/deis/deis.info
@@ -1,10 +1,10 @@
PRGNAM="deis"
-VERSION="1.6.0"
+VERSION="1.6.1"
HOMEPAGE="http://deis.io/"
-DOWNLOAD="https://pypi.python.org/packages/source/d/deis/deis-1.6.0.tar.gz"
-MD5SUM="587cbc1ab9ea7d6c1436b0309e634f72"
+DOWNLOAD="https://pypi.python.org/packages/source/d/deis/deis-1.6.1.tar.gz"
+MD5SUM="dda95188c7bb4562c97eeeefc4eed8f9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="docopt python-dateutil python-requests termcolor PyYAML python-tabulate python-urllib3"
+REQUIRES="docopt python-dateutil python-requests termcolor PyYAML python-tabulate python-urllib3 ndg_httpsclient"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"
diff --git a/network/deis/setup.patch b/network/deis/setup.patch
deleted file mode 100644
index 51329d6938..0000000000
--- a/network/deis/setup.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- deis-1.6.0/setup.orig.py 2015-05-09 03:43:01.776728194 +0300
-+++ deis-1.6.0/setup.py 2015-05-09 03:44:20.037749797 +0300
-@@ -2,6 +2,7 @@
-
- """Install the Deis command-line client."""
-
-+import os
-
- try:
- from setuptools import setup
-@@ -27,9 +28,11 @@
- KWARGS = {'scripts': ['deis']}
-
-
--with open('requirements.txt') as f:
-- required = f.read().splitlines()
-- required = [r for r in required if r.strip() and not r.startswith('#')]
-+required = ""
-+if os.path.isfile('requirements.txt'):
-+ with open('requirements.txt') as f:
-+ required = f.read().splitlines()
-+ required = [r for r in required if r.strip() and not r.startswith('#')]
-
-
- setup(name='deis',