summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Corrado Franco <conraid (at) linux (dot) it>2015-11-17 23:49:43 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-11-17 23:49:43 +0700
commit56bc008b7648329cc27b238266bfa8c9c38d4ed3 (patch)
treeb1714598325789d9a2146afce88579cda5fc2ae8 /network
parent68739fe0fab2b3b6ad2542251cb3c50ebfd821c0 (diff)
downloadslackbuilds-56bc008b7648329cc27b238266bfa8c9c38d4ed3.tar.gz
slackbuilds-56bc008b7648329cc27b238266bfa8c9c38d4ed3.tar.xz
network/scapy: Updated for version 2.3.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/scapy/scapy.SlackBuild49
-rw-r--r--network/scapy/scapy.info10
2 files changed, 30 insertions, 29 deletions
diff --git a/network/scapy/scapy.SlackBuild b/network/scapy/scapy.SlackBuild
index 15c5867390..9ee7548593 100644
--- a/network/scapy/scapy.SlackBuild
+++ b/network/scapy/scapy.SlackBuild
@@ -2,28 +2,29 @@
#
# Slackware build script for scapy (http://www.secdev.org/projects/scapy/)
#
-# Copyright 2008 Corrado Franco (http://www.conraid.net)
+# Copyright 2008-2015 Corrado Franco (http://conraid.net)
# All rights reserved.
#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version, with the following exception:
+# the text of the GPL license may be omitted.
+
+# This program is distributed in the hope that it will be useful, but
+# without any warranty; without even the implied warranty of
+# merchantability or fitness for a particular purpose. Compiling,
+# interpreting, executing or merely reading the text of the program
+# may result in lapses of consciousness and/or very being, up to and
+# including the end of all existence and the Universe as we know it.
+# See the GNU General Public License for more details.
+
+# You may have received a copy of the GNU General Public License along
+# with this program (most likely, a file named COPYING). If not, see
+# <http://www.gnu.org/licenses/>.
PRGNAM=${PRGNAM:-scapy}
-VERSION=${VERSION:-2.0.1}
+VERSION=${VERSION:-2.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,26 +47,26 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+unzip $CWD/$PRGNAM-$VERSION.zip
cd $PRGNAM-$VERSION
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Patch setup.py for man path
-sed -i "s%share/man/man1%man/man1%g" setup.py
+sed -i "s%share/man/man1%man/man1%g" setup.py
+python setup.py build
python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-${BUILD}${TAG}.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/scapy/scapy.info b/network/scapy/scapy.info
index 6227f7345b..2650146761 100644
--- a/network/scapy/scapy.info
+++ b/network/scapy/scapy.info
@@ -1,10 +1,10 @@
PRGNAM="scapy"
-VERSION="2.0.1"
-HOMEPAGE="http://www.secdev.org/projects/scapy"
-DOWNLOAD="http://www.secdev.org/projects/scapy/files/scapy-2.0.1.tar.gz"
-MD5SUM="eaf09bce872c835135a8c66327f920cb"
+VERSION="2.3.1"
+HOMEPAGE="http://www.secdev.org/projects/scapy/"
+DOWNLOAD="http://www.secdev.org/projects/scapy/files/scapy-2.3.1.zip"
+MD5SUM="46f4ef88b676daebd3053bbd2ee16425"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Corrado Franco"
-EMAIL="conraid@gmail.com"
+EMAIL="conraid (at) linux (dot) it"