summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2015-01-08 15:05:39 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-01-08 15:05:39 +0700
commit5aff91909fbd42d91f861862c413f7e05f27be47 (patch)
tree726744f59e9e48e0454c9fc760daaf1190532d7b /network
parent59d5b6f6a05d8229475c4f4b95fc6a187b204b94 (diff)
downloadslackbuilds-5aff91909fbd42d91f861862c413f7e05f27be47.tar.gz
slackbuilds-5aff91909fbd42d91f861862c413f7e05f27be47.tar.xz
network/etherpoke: Added (scriptable network session monitor).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/etherpoke/README5
-rw-r--r--network/etherpoke/doinst.sh3
-rw-r--r--network/etherpoke/etherpoke.SlackBuild89
-rw-r--r--network/etherpoke/etherpoke.info10
-rw-r--r--network/etherpoke/slack-desc19
5 files changed, 126 insertions, 0 deletions
diff --git a/network/etherpoke/README b/network/etherpoke/README
new file mode 100644
index 0000000000..48cf5cdc43
--- /dev/null
+++ b/network/etherpoke/README
@@ -0,0 +1,5 @@
+etherpoke is a scriptable network session monitor.
+
+etherpoke defines two events: SESSION_BEGIN, SESSION_END
+to which a hook (system command) can be assigned. The event
+hook can be any program installed in the system.
diff --git a/network/etherpoke/doinst.sh b/network/etherpoke/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/network/etherpoke/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/network/etherpoke/etherpoke.SlackBuild b/network/etherpoke/etherpoke.SlackBuild
new file mode 100644
index 0000000000..4832ad4d83
--- /dev/null
+++ b/network/etherpoke/etherpoke.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for etherpoke
+
+# Copyright 2015 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=etherpoke
+VERSION=${VERSION:-2.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p $PKG/usr/bin
+sed -i "s#/usr/local/bin#$PKG/usr/bin#" src/Makefile
+
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README Changelog AUTHORS COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/etherpoke/etherpoke.info b/network/etherpoke/etherpoke.info
new file mode 100644
index 0000000000..ce84d9a56f
--- /dev/null
+++ b/network/etherpoke/etherpoke.info
@@ -0,0 +1,10 @@
+PRGNAM="etherpoke"
+VERSION="2.1.1"
+HOMEPAGE="http://codeward.org/etherpoke/"
+DOWNLOAD="http://codeward.org/etherpoke/files/etherpoke-2.1.1.tar.gz"
+MD5SUM="4b9d83305192c8ccea15cba1efe52b67"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libconfig"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/network/etherpoke/slack-desc b/network/etherpoke/slack-desc
new file mode 100644
index 0000000000..899c5282a6
--- /dev/null
+++ b/network/etherpoke/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+etherpoke: etherpoke (scriptable network session monitor)
+etherpoke:
+etherpoke: etherpoke defines two events: SESSION_BEGIN, SESSION_END to which a
+etherpoke: hook (system command) can be assigned. The event hook can be any
+etherpoke: program installed in the system.
+etherpoke:
+etherpoke: Homepage: http://codeward.org/etherpoke/
+etherpoke:
+etherpoke:
+etherpoke:
+etherpoke: