summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Leonard Schmidt <lems@gmx.net>2015-03-22 10:16:31 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-03-22 10:16:31 +0700
commit5b5f54c9926efe66f056b7b5a5aa998667ebe0bc (patch)
tree7b6547bb337e20a858d05fdc059b8c30593e3599 /network
parent027b527cb346da95e68a85c1cd46b5f6bc5c8d1a (diff)
downloadslackbuilds-5b5f54c9926efe66f056b7b5a5aa998667ebe0bc.tar.gz
slackbuilds-5b5f54c9926efe66f056b7b5a5aa998667ebe0bc.tar.xz
network/darkhttpd: Added (simple and lightweight HTTP server).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/darkhttpd/README33
-rw-r--r--network/darkhttpd/darkhttpd.SlackBuild91
-rw-r--r--network/darkhttpd/darkhttpd.info10
-rw-r--r--network/darkhttpd/slack-desc19
4 files changed, 153 insertions, 0 deletions
diff --git a/network/darkhttpd/README b/network/darkhttpd/README
new file mode 100644
index 0000000000..4b210b0faa
--- /dev/null
+++ b/network/darkhttpd/README
@@ -0,0 +1,33 @@
+darkhttpd is a simple and secure static HTTP server.
+
+Features:
+
+* Single binary, no other files.
+* Standalone, doesn't need inetd or ucspi-tcp.
+* No messing around with config files -- all you have to specify is
+ the www root.
+* Written in C -- efficient and portable.
+* Small memory footprint.
+* Event loop, single-threaded -- no fork() or pthreads.
+* Generates directory listings.
+* Supports HTTP GET and HEAD requests.
+* Supports Range / partial content. (Try streaming music files or resuming
+ a download.)
+* Supports If-Modified-Since.
+* Supports Keep-Alive connections.
+* Can serve 301 redirects based on Host header.
+* Uses sendfile() on FreeBSD, Solaris and Linux.
+* BSD license.
+
+Security:
+
+* Can log accesses, including Referer and User-Agent.
+* Can chroot.
+* Can drop privileges.
+* Impervious to /../ sniffing.
+* Times out idle connections.
+* Drops overly long requests.
+
+Limitations:
+
+* Only serves static content -- no CGI.
diff --git a/network/darkhttpd/darkhttpd.SlackBuild b/network/darkhttpd/darkhttpd.SlackBuild
new file mode 100644
index 0000000000..e542ef3bb0
--- /dev/null
+++ b/network/darkhttpd/darkhttpd.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for darkhttpd
+
+# Copyright 2015 Leonard Schmidt <lems@gmx.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=darkhttpd
+VERSION=${VERSION:-1.10}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS=""
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xjvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+make
+
+mkdir -p $PKG/usr/bin
+install -m755 darkhttpd $PKG/usr/bin/
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Install license (from Arch Linux' PKGBUILD)
+head -n 18 darkhttpd.c > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/darkhttpd/darkhttpd.info b/network/darkhttpd/darkhttpd.info
new file mode 100644
index 0000000000..1dad7ffae3
--- /dev/null
+++ b/network/darkhttpd/darkhttpd.info
@@ -0,0 +1,10 @@
+PRGNAM="darkhttpd"
+VERSION="1.10"
+HOMEPAGE="https://unix4lyfe.org/darkhttpd/"
+DOWNLOAD="https://unix4lyfe.org/darkhttpd/darkhttpd-1.10.tar.bz2"
+MD5SUM="652968ca104e57235519cadd2d6fdda2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Leonard Schmidt"
+EMAIL="lems@gmx.net"
diff --git a/network/darkhttpd/slack-desc b/network/darkhttpd/slack-desc
new file mode 100644
index 0000000000..28b418b02a
--- /dev/null
+++ b/network/darkhttpd/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+darkhttpd: darkhttpd (simple and lightweight HTTP server)
+darkhttpd:
+darkhttpd: darkhttpd is a small and secure static web server.
+darkhttpd: It can generate directory listings, supports HTTP GET and HEADER
+darkhttpd: requests, can log accesses, including Referer and User-Agent;
+darkhttpd: it can chroot and drop privileges. darkhttpd only serves static
+darkhttpd: content, no CGI.
+darkhttpd:
+darkhttpd: Homepage: http://www.eterna.com.au/darkhttpd/
+darkhttpd:
+darkhttpd: