summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Philip Lacroix <philnx at posteo dot de>2015-02-12 00:14:18 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-12 00:14:18 +0700
commit7ded051ce66a78257002d9ea15aabd3b6fff9129 (patch)
tree0b761b9129ff687d09834514964b77d6dc8b7cf2 /network
parent88db70f0e397972e127e312f2afc66252aa9ba21 (diff)
downloadslackbuilds-7ded051ce66a78257002d9ea15aabd3b6fff9129.tar.gz
slackbuilds-7ded051ce66a78257002d9ea15aabd3b6fff9129.tar.xz
network/bottle: Added (Python web framework).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/bottle/README5
-rw-r--r--network/bottle/bottle.SlackBuild78
-rw-r--r--network/bottle/bottle.info10
-rw-r--r--network/bottle/slack-desc19
4 files changed, 112 insertions, 0 deletions
diff --git a/network/bottle/README b/network/bottle/README
new file mode 100644
index 0000000000..9506e8bf4e
--- /dev/null
+++ b/network/bottle/README
@@ -0,0 +1,5 @@
+Bottle is a fast and simple micro-framework for small web applications. It
+offers request dispatching (Routes) with url parameter support, templates,
+a built-in HTTP Server and adapters for many third party WSGI/HTTP-server and
+template engines - all in a single file and with no dependencies other than
+the Python Standard Library.
diff --git a/network/bottle/bottle.SlackBuild b/network/bottle/bottle.SlackBuild
new file mode 100644
index 0000000000..0597abd297
--- /dev/null
+++ b/network/bottle/bottle.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# Slackware build script for Bottle
+
+# Copyright 2015 Philip Lacroix <philnx at posteo dot de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=bottle
+VERSION=${VERSION:-0.12.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
+ -o -perm 400 \) -exec chmod 644 {} \;
+
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PRGDOC
+cp -a README.rst PKG-INFO $PRGDOC/
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/bottle/bottle.info b/network/bottle/bottle.info
new file mode 100644
index 0000000000..0fd2be3a0d
--- /dev/null
+++ b/network/bottle/bottle.info
@@ -0,0 +1,10 @@
+PRGNAM="bottle"
+VERSION="0.12.8"
+HOMEPAGE="http://bottlepy.org/docs/dev/"
+DOWNLOAD="https://pypi.python.org/packages/source/b/bottle/bottle-0.12.8.tar.gz"
+MD5SUM="13132c0a8f607bf860810a6ee9064c5b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Philip Lacroix"
+EMAIL="philnx at posteo dot de"
diff --git a/network/bottle/slack-desc b/network/bottle/slack-desc
new file mode 100644
index 0000000000..cca52162cb
--- /dev/null
+++ b/network/bottle/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+bottle: Bottle (Python web framework)
+bottle:
+bottle: Bottle is a fast, simple and lightweight WSGI micro web-framework
+bottle: for Python. It is distributed as a single file module and has no
+bottle: dependencies other than the Python Standard Library.
+bottle:
+bottle: Homepage: http://bottlepy.org
+bottle:
+bottle:
+bottle:
+bottle: