summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Zhu Qun-Ying <zhu.qunying@gmail.com>2015-08-11 12:00:32 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-08-11 23:25:26 +0700
commit9b755adec9858478b89e1497d1d00ee4b3bb7d54 (patch)
tree5a61ea8671847dc742c48ead52904b706c67da11 /network
parent3788ab1d6d0a02a6accf9f403aab5d5e93a8b6aa (diff)
downloadslackbuilds-9b755adec9858478b89e1497d1d00ee4b3bb7d54.tar.gz
slackbuilds-9b755adec9858478b89e1497d1d00ee4b3bb7d54.tar.xz
network/guacamole-server: Added (Guacamole server).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/guacamole-server/README11
-rw-r--r--network/guacamole-server/doinst.sh25
-rw-r--r--network/guacamole-server/guacamole-server.SlackBuild107
-rw-r--r--network/guacamole-server/guacamole-server.info10
-rw-r--r--network/guacamole-server/slack-desc19
-rw-r--r--network/guacamole-server/uuid.patch75
6 files changed, 247 insertions, 0 deletions
diff --git a/network/guacamole-server/README b/network/guacamole-server/README
new file mode 100644
index 0000000000..e6a77bad72
--- /dev/null
+++ b/network/guacamole-server/README
@@ -0,0 +1,11 @@
+guacamole-server - Guacamole server
+
+guacamole-server contains all the native, server-side
+components required by Guacamole to connect to remote
+desktops. It provides a common C library, libguac, which all
+other native components depend on, as well as separate
+libraries for each supported protocol, and guacd, the heart
+of Guacamole.
+
+The dependency for the libraries of freerdp, libtelnet, libssh2 are
+optional, as Slackware by default has libvncserver installed.
diff --git a/network/guacamole-server/doinst.sh b/network/guacamole-server/doinst.sh
new file mode 100644
index 0000000000..79f3952787
--- /dev/null
+++ b/network/guacamole-server/doinst.sh
@@ -0,0 +1,25 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+preserve_perms() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ if [ -e $OLD ]; then
+ cp -a $OLD ${NEW}.incoming
+ cat $NEW > ${NEW}.incoming
+ mv ${NEW}.incoming $NEW
+ fi
+ config $NEW
+}
+
+preserve_perms etc/rc.d/rc.guacd.new
diff --git a/network/guacamole-server/guacamole-server.SlackBuild b/network/guacamole-server/guacamole-server.SlackBuild
new file mode 100644
index 0000000000..e7dd955cb8
--- /dev/null
+++ b/network/guacamole-server/guacamole-server.SlackBuild
@@ -0,0 +1,107 @@
+#!/bin/sh
+
+# Slackware build script for guacamole-server
+
+# Copyright 2015 Zhu Qun-Ying
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=guacamole-server
+VERSION=${VERSION:-0.9.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# use system uuid library from util-linux instead of OSSP uuid
+patch -p1 < $CWD/uuid.patch
+autoreconf -fi
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --with-init-dir=/etc/rc.d \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-static=no \
+ --build=$ARCH-slackware-linux
+
+# Compile the application and install it into the $PKG directory
+make
+make install-strip DESTDIR=$PKG
+
+# Compress man pages
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README LICENSE ChangeLog AUTHORS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+mv $PKG/etc/rc.d/guacd $PKG/etc/rc.d/rc.guacd.new
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/guacamole-server/guacamole-server.info b/network/guacamole-server/guacamole-server.info
new file mode 100644
index 0000000000..ff6d7e47f1
--- /dev/null
+++ b/network/guacamole-server/guacamole-server.info
@@ -0,0 +1,10 @@
+PRGNAM="guacamole-server"
+VERSION="0.9.7"
+HOMEPAGE="http://guac-dev.org"
+DOWNLOAD="http://sourceforge.net/projects/guacamole/files/current/source/guacamole-server-0.9.7.tar.gz"
+MD5SUM="a09b3fd53e1ecc365a311a380f8c6314"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Zhu Qun-Ying"
+EMAIL="zhu.qunying@gmail.com"
diff --git a/network/guacamole-server/slack-desc b/network/guacamole-server/slack-desc
new file mode 100644
index 0000000000..6ebd2f9835
--- /dev/null
+++ b/network/guacamole-server/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler----------------------------------------------|
+guacamole-server: guacamole-server (Guacamole server)
+guacamole-server:
+guacamole-server: guacamole-server contains all the native, server-side
+guacamole-server: components required by Guacamole to connect to remote
+guacamole-server: desktops. It provides a common C library, libguac, which all
+guacamole-server: other native components depend on, as well as separate
+guacamole-server: libraries for each supported protocol, and guacd, the heart
+guacamole-server: of Guacamole.
+guacamole-server:
+guacamole-server: http://guac-dev.org
+guacamole-server:
diff --git a/network/guacamole-server/uuid.patch b/network/guacamole-server/uuid.patch
new file mode 100644
index 0000000000..cd82c2e6b0
--- /dev/null
+++ b/network/guacamole-server/uuid.patch
@@ -0,0 +1,75 @@
+--- guacamole-server-0.9.7/configure.ac 2015-06-08 17:35:23.000000000 -0700
++++ guacamole-server-0.9.7-new/configure.ac 2015-06-18 15:03:22.424072017 -0700
+@@ -64,19 +64,25 @@
+
+ # OSSP UUID
+ AC_CHECK_LIB([ossp-uuid], [uuid_make], [UUID_LIBS=-lossp-uuid],
+- AC_CHECK_LIB([uuid], [uuid_make], [UUID_LIBS=-luuid],
++ AC_CHECK_LIB([uuid], [uuid_generate], [UUID_LIBS=-luuid],
+ AC_MSG_ERROR("The OSSP UUID library is required")))
+
+ # Check for and validate OSSP uuid.h header
+-AC_CHECK_HEADERS([ossp/uuid.h])
+-AC_CHECK_DECL([uuid_make],,
+- AC_MSG_ERROR("No OSSP uuid.h found in include path"),
++AC_CHECK_HEADERS([ossp/uuid.h], [uuid/uuid.h])
++AC_CHECK_DECL([uuid_make],, ,
+ [#ifdef HAVE_OSSP_UUID_H
+ #include <ossp/uuid.h>
+ #else
+ #include <uuid.h>
+ #endif
+ ])
++AC_CHECK_DECL([uuid_generate],, ,
++ [#ifdef HAVE_OSSP_UUID_H
++ #include <ossp/uuid.h>
++ #else
++ #include <uuid/uuid.h>
++ #endif
++ ])
+
+ # cunit
+ AC_CHECK_LIB([cunit], [CU_run_test], [CUNIT_LIBS=-lcunit])
+--- guacamole-server-0.9.7/src/libguac/client.c 2015-05-29 15:29:19.000000000 -0700
++++ guacamole-server-0.9.7-new/src/libguac/client.c 2015-06-18 14:58:43.163055905 -0700
+@@ -36,7 +36,7 @@
+ #ifdef HAVE_OSSP_UUID_H
+ #include <ossp/uuid.h>
+ #else
+-#include <uuid.h>
++#include <uuid/uuid.h>
+ #endif
+
+ #include <stdarg.h>
+@@ -134,8 +134,8 @@
+
+ char* buffer;
+ char* identifier;
++#ifdef HAVE_OSSP_UUID_H
+ size_t identifier_length;
+-
+ uuid_t* uuid;
+
+ /* Attempt to create UUID object */
+@@ -175,6 +175,21 @@
+ }
+
+ uuid_destroy(uuid);
++#else
++ uuid_t uuid;
++#define UUID_LEN_STR 36
++
++ buffer = malloc (UUID_LEN_STR + 2);
++ if (buffer == NULL) {
++ guac_error = GUAC_STATUS_NO_MEMORY;
++ guac_error_message = "Could not allocate memory for connection ID";
++ return NULL;
++ }
++ identifier = buffer + 1;
++
++ uuid_generate (uuid);
++ uuid_unparse (uuid, identifier);
++#endif
+
+ buffer[0] = '$';
+ buffer[UUID_LEN_STR + 1] = '\0';