summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author pyllyukko <pyllyukko@maimed.org>2014-04-09 16:31:49 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-04-09 16:31:49 +0700
commitb8ac3f55a3b450c05532b721eb16d197dd70671a (patch)
treed5e259dad04c6337f3ae36968a1660f058642d18 /network
parent72722216e664a7bb98916a80719e30b95c5f59c1 (diff)
downloadslackbuilds-b8ac3f55a3b450c05532b721eb16d197dd70671a.tar.gz
slackbuilds-b8ac3f55a3b450c05532b721eb16d197dd70671a.tar.xz
network/modsecurity-apache: Updated for version 2.7.7.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/modsecurity-apache/README2
-rw-r--r--network/modsecurity-apache/modsecurity-apache.SlackBuild36
-rw-r--r--network/modsecurity-apache/modsecurity-apache.info12
3 files changed, 19 insertions, 31 deletions
diff --git a/network/modsecurity-apache/README b/network/modsecurity-apache/README
index 6734518ee4..15d7b1d166 100644
--- a/network/modsecurity-apache/README
+++ b/network/modsecurity-apache/README
@@ -10,7 +10,9 @@ appropriate sections of Apache's main configuration file (x86
architecture):
LoadModule security2_module lib/httpd/modules/mod_security2.so
+<IfModule security2_module>
Include /etc/httpd/extra/modsecurity-recommended.conf
+</IfModule>
Also refer to the file /etc/httpd/crs/INSTALL for information on how to get the
Core Rule Set (CRS) up and running.
diff --git a/network/modsecurity-apache/modsecurity-apache.SlackBuild b/network/modsecurity-apache/modsecurity-apache.SlackBuild
index 5a99ba2cc0..5bd982887b 100644
--- a/network/modsecurity-apache/modsecurity-apache.SlackBuild
+++ b/network/modsecurity-apache/modsecurity-apache.SlackBuild
@@ -5,11 +5,11 @@
# Written by pyllyukko
PRGNAM=modsecurity-apache
-VERSION=${VERSION:-2.6.8}
+VERSION=${VERSION:-2.7.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CRS_VERSION="2.2.6"
+CRS_VERSION="2.2.9"
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -65,25 +65,13 @@ cd $TMP
rm -rf ${PRGNAM}_${VERSION}
tar xvf $CWD/${PRGNAM}_${VERSION}.tar.gz
cd ${PRGNAM}_${VERSION}
-tar xvf $CWD/modsecurity-crs_${CRS_VERSION}.tar.gz
+tar xvf $CWD/${CRS_VERSION}.tar.gz
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix location of http module.
-# It's messy, actually, as the Makefile has a hardcoded libdir and also copies
-# the lib to the httpd/modules directory without using the DESTDIR, really
-# INSTALLing the library even when we only want to create a package :(
-sed \
- -e "/^pkglibdir/s|/lib|/lib${LIBDIRSUFFIX}|" \
- -e "s|\$(APXS_MODULES)|\$(DESTDIR)\$(APXS_MODULES)|" \
- -i apache2/Makefile.in
-# oh, and since it wanted to install locally, we need to manually create the
-# directory in the package...
-mkdir -p $PKG/$(apxs -q LIBEXECDIR)
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -95,21 +83,21 @@ make
make install-strip DESTDIR=$PKG
# It leaves two copies of the library, we'll only need one
-rm $PKG/usr/lib${LIBDIRSUFFIX}/*.so
+rm $PKG/usr/lib/*.so
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES LICENSE NOTICE README.TXT README_WINDOWS.TXT authors.txt doc/Reference_Manual.html \
+cp -a CHANGES LICENSE NOTICE README.TXT README_WINDOWS.TXT authors.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/etc/httpd/extra
cat modsecurity.conf-recommended > $PKG/etc/httpd/extra/modsecurity-recommended.conf.new
+cat unicode.mapping > $PKG/etc/httpd/extra/unicode.mapping
# The Core Rule Set
mkdir -p ${PKG}/etc/httpd/crs
-cp -Rv modsecurity-crs_${CRS_VERSION}/* ${PKG}/etc/httpd/crs
-cat modsecurity-crs_${CRS_VERSION}/modsecurity_crs_10_setup.conf.example > \
+cp -Rv owasp-modsecurity-crs-${CRS_VERSION}/* ${PKG}/etc/httpd/crs
+cat owasp-modsecurity-crs-${CRS_VERSION}/modsecurity_crs_10_setup.conf.example > \
${PKG}/etc/httpd/crs/modsecurity_crs_10_setup.conf.new
mkdir -p $PKG/install
diff --git a/network/modsecurity-apache/modsecurity-apache.info b/network/modsecurity-apache/modsecurity-apache.info
index f50c6b09fa..38ca69d038 100644
--- a/network/modsecurity-apache/modsecurity-apache.info
+++ b/network/modsecurity-apache/modsecurity-apache.info
@@ -1,12 +1,10 @@
PRGNAM="modsecurity-apache"
-VERSION="2.6.8"
+VERSION="2.7.7"
HOMEPAGE="http://www.modsecurity.org"
-DOWNLOAD="http://www.modsecurity.org/download/modsecurity-apache_2.6.8.tar.gz \
- http://www.modsecurity.org/download/modsecurity-apache_2.6.8.tar.gz.asc \
- http://ponce.cc/slackware/sources/repo/modsecurity-crs_2.2.6.tar.gz"
-MD5SUM="430449ab9ee906c464aa70b79f9c2230 \
- 7b9f9a2b462d6d5e5786ce4f74da3820 \
- c5f2c552c7718897d6a93d3de2a442f1"
+DOWNLOAD="https://www.modsecurity.org/tarball/2.7.7/modsecurity-apache_2.7.7.tar.gz \
+ https://github.com/SpiderLabs/owasp-modsecurity-crs/archive/2.2.9.tar.gz"
+MD5SUM="5383c59ecc6990c870386627f67e7216 \
+ ba5b6d514f5586d33a54b26a5f64eb5c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""