summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2014-08-07 22:04:40 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-08-07 22:04:40 +0700
commit385559d6ff94289f9c40ebf00bcc533cea92954a (patch)
tree95276dbb6f3b977220a8dfc531b2c68f31534557 /office
parent978445bce2b7479734633c5104e14052e9ed37c6 (diff)
downloadslackbuilds-385559d6ff94289f9c40ebf00bcc533cea92954a.tar.gz
slackbuilds-385559d6ff94289f9c40ebf00bcc533cea92954a.tar.xz
office/htmldoc: Updated for version 1.8.28.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/htmldoc/doinst.sh3
-rw-r--r--office/htmldoc/htmldoc.SlackBuild37
-rw-r--r--office/htmldoc/htmldoc.info6
-rw-r--r--office/htmldoc/insecure_sscanf_patch.diff36
4 files changed, 24 insertions, 58 deletions
diff --git a/office/htmldoc/doinst.sh b/office/htmldoc/doinst.sh
index 2a77b3fa85..69d003d68b 100644
--- a/office/htmldoc/doinst.sh
+++ b/office/htmldoc/doinst.sh
@@ -1,7 +1,7 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications
fi
-
+
if [ -x /usr/bin/update-mime-database ]; then
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
fi
@@ -11,4 +11,3 @@ if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
fi
fi
-
diff --git a/office/htmldoc/htmldoc.SlackBuild b/office/htmldoc/htmldoc.SlackBuild
index 404215de69..8378dbc8f4 100644
--- a/office/htmldoc/htmldoc.SlackBuild
+++ b/office/htmldoc/htmldoc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for htmldoc
-# Copyright 2009-2013 LukenShiro, Italy
+# Copyright 2009-2014 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +26,8 @@
# workaround, and for a patch to fix CVE-2009-3050.
PRGNAM=htmldoc
-VERSION=1.8.27
-BUILD=${BUILD:-5}
+VERSION=${VERSION:-1.8.28}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -43,7 +43,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCFILES="CHANGES.txt README.txt COMPILE.txt COPYING.txt htmldoc.eula htmldoc.readme"
+DOCFILES="CHANGES.txt README.txt COMPILE.txt COPYING.txt htmldoc.readme"
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
@@ -69,17 +69,22 @@ tar xvf $CWD/$PRGNAM-$VERSION-source.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# workaround to avoid /usr/share/doc/htmldoc's use for help function
-sed -i 's|^#define DOCUMENTATION "$prefix/share/doc/htmldoc"|\
- #define DOCUMENTATION "$prefix/doc/htmldoc-1.8.27"|g' ./configure
+sed -r -i 's|^#define DOCUMENTATION "$prefix/share/doc/htmldoc"|\
+ #define DOCUMENTATION "$prefix/doc/htmldoc-$VERSION"|g' ./configure
+
+# to avoid an invalid implicit declaration of function (for 'CUPS_SRAND' and 'CUPS_RAND')
+sed -r -i 's|CUPS_SRAND|srand|g' htmldoc/http.c
+sed -r -i 's|CUPS_RAND|rand|g' htmldoc/http.c
# --mandir seems to be ignored; --docdir doesn't exist
# internal jpeg/png/zlib libs disabled (using system ones)
+# it does not build correctly with gnutls (disabled)
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -89,20 +94,18 @@ CXXFLAGS="$SLKCFLAGS" \
--with-gui \
--disable-localjpeg \
--disable-localzlib \
- --disable-localpng
+ --disable-localpng \
+ --disable-gnutls \
+ --build=$ARCH-slackware-linux
# workaround to avoid /usr/share/doc/htmldoc's use for doc installation
-sed -i 's|\$(datadir)/doc/htmldoc|\$(prefix)/doc/htmldoc-1.8.27|g' \
+sed -r -i 's|\$(datadir)/doc/htmldoc|\$(prefix)/doc/htmldoc-$VERSION|g' \
doc/Makefile
-# Apply patch to fix several insecure calls to sscanf().
-# It's intended to resolve CVE-2009-3050 vulnerability.
-patch -p0 < $CWD/insecure_sscanf_patch.diff
-
-make all || exit 1
+make all
# DESTDIR= is not supported
-make prefix=$PKG/usr install || exit 1
+make prefix=$PKG/usr install
# Copy some files who are not automatically installed (main binary, .desktop, icons, etc..)
mkdir -p $PKG/usr/bin
diff --git a/office/htmldoc/htmldoc.info b/office/htmldoc/htmldoc.info
index f703d1bc22..5fcaf8dace 100644
--- a/office/htmldoc/htmldoc.info
+++ b/office/htmldoc/htmldoc.info
@@ -1,8 +1,8 @@
PRGNAM="htmldoc"
-VERSION="1.8.27"
+VERSION="1.8.28"
HOMEPAGE="http://www.msweet.org/projects.php?Z1"
-DOWNLOAD="http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/htmldoc/1.8.27/htmldoc-1.8.27-source.tar.bz2"
-MD5SUM="35589e7b8fe9c54e11be87cd5aec4dcc"
+DOWNLOAD="http://www.msweet.org/files/project1/htmldoc-1.8.28-source.tar.bz2"
+MD5SUM="8e4e3f49ee9b2c5af01eb81a518ce7e7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="fltk"
diff --git a/office/htmldoc/insecure_sscanf_patch.diff b/office/htmldoc/insecure_sscanf_patch.diff
deleted file mode 100644
index 2047c7f7d2..0000000000
--- a/office/htmldoc/insecure_sscanf_patch.diff
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -ru htmldoc/htmllib.cxx htmldoc/htmllib.cxx
---- htmldoc/htmllib.cxx 2006-06-07 19:43:52.000000000 +0200
-+++ htmldoc/htmllib.cxx 2009-08-01 19:52:46.301099436 +0200
-@@ -2139,7 +2139,7 @@
- * assigned charset...
- */
-
-- if (sscanf(line, "%*s%*s%*s%*s%f%*s%*s%s", &width, glyph) != 2)
-+ if (sscanf(line, "%*s%*s%*s%*s%f%*s%*s%63s", &width, glyph) != 2)
- continue;
-
- for (ch = 0; ch < 256; ch ++)
-diff -ru htmldoc/ps-pdf.cxx htmldoc/ps-pdf.cxx
---- htmldoc/ps-pdf.cxx 2006-08-01 18:58:50.000000000 +0200
-+++ htmldoc/ps-pdf.cxx 2009-08-01 19:53:14.300610480 +0200
-@@ -12512,7 +12512,7 @@
- * assigned charset...
- */
-
-- if (sscanf(line, "%*s%*s%*s%*s%d%*s%*s%s", &width, glyph) != 2)
-+ if (sscanf(line, "%*s%*s%*s%*s%d%*s%*s%63s", &width, glyph) != 2)
- continue;
-
- for (ch = 0; ch < 256; ch ++)
-diff -ru htmldoc/util.cxx htmldoc/util.cxx
---- htmldoc/util.cxx 2005-04-24 21:20:32.000000000 +0200
-+++ htmldoc/util.cxx 2009-08-01 19:52:14.469652088 +0200
-@@ -484,7 +484,7 @@
- PageWidth = 595;
- PageLength = 792;
- }
-- else if (sscanf(size, "%fx%f%s", &width, &length, units) >= 2)
-+ else if (sscanf(size, "%fx%f%254s", &width, &length, units) >= 2)
- {
- /*
- * Custom size...