summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-01-12 22:16:06 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-01-29 23:21:00 -0600
commit77daf7c3bfe1509421ff6da779918fa0e8b28462 (patch)
treed973bbe6fd0fad5d916298995d971c8dd2287773 /office
parenta34ec8da244d89a3e1618a24b9117c345ac21acc (diff)
downloadslackbuilds-77daf7c3bfe1509421ff6da779918fa0e8b28462.tar.gz
slackbuilds-77daf7c3bfe1509421ff6da779918fa0e8b28462.tar.xz
office/marave: Added (A text editor).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/marave/README3
-rw-r--r--office/marave/doinst.sh3
-rw-r--r--office/marave/marave.SlackBuild93
-rw-r--r--office/marave/marave.desktop10
-rw-r--r--office/marave/marave.info10
-rw-r--r--office/marave/slack-desc19
6 files changed, 138 insertions, 0 deletions
diff --git a/office/marave/README b/office/marave/README
new file mode 100644
index 0000000000..403c7145a4
--- /dev/null
+++ b/office/marave/README
@@ -0,0 +1,3 @@
+Marave is a text editor whose goal is to help you focus on writing.
+it's inspired by ommwriter, Darkroom and many other "simple" text
+editors, with a few twists.
diff --git a/office/marave/doinst.sh b/office/marave/doinst.sh
new file mode 100644
index 0000000000..473345de20
--- /dev/null
+++ b/office/marave/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/office/marave/marave.SlackBuild b/office/marave/marave.SlackBuild
new file mode 100644
index 0000000000..f191ae4a51
--- /dev/null
+++ b/office/marave/marave.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for marave
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=marave
+VERSION=${VERSION:-0.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/share/applications
+install -D -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+
+mkdir -p $PKG/usr/share/pixmaps/
+install -D -m644 marave/icons/marave.svg $PKG/usr/share/pixmaps/marave.svg
+
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/marave/marave.desktop b/office/marave/marave.desktop
new file mode 100644
index 0000000000..39babeda51
--- /dev/null
+++ b/office/marave/marave.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Text Editor (marave)
+Name[he]= marave
+Comment=Text Editor
+Exec=marave-editor
+Icon=marave
+Terminal=false
+Type=Application
+Categories=Accessories;TextEditor
+GenericName=Editor
diff --git a/office/marave/marave.info b/office/marave/marave.info
new file mode 100644
index 0000000000..d6c1a0c7b0
--- /dev/null
+++ b/office/marave/marave.info
@@ -0,0 +1,10 @@
+PRGNAM="marave"
+VERSION="0.7"
+HOMEPAGE="https://code.google.com/p/marave/"
+DOWNLOAD="https://marave.googlecode.com/files/marave-0.7.tar.gz"
+MD5SUM="1bb038efb7a9847697bdbf671feb7f6e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools pyenchant"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/office/marave/slack-desc b/office/marave/slack-desc
new file mode 100644
index 0000000000..62cc7fa20c
--- /dev/null
+++ b/office/marave/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+marave: marave (A text editor that helps you focus on writing)
+marave:
+marave: Marave doesn't just have minimalism and simplicity, it has minimalism
+marave: and simplicity combined with beauty and a palpable design ethic.
+marave: Marave has soul.
+marave:
+marave:
+marave:
+marave:
+marave: Homepage: https://code.google.com/p/marave/
+marave: