summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Mario Preksavec <mario at slackware dot hr>2015-02-05 04:57:40 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-05 06:47:42 +0700
commit00a0ee8f79b5a1a49ca49f7f385d4aceced9f1ee (patch)
tree2f7fea5631ce84ea8ce7a4e1e21062b501ae5ecf /python
parent72cb56d2b72dbaeb403bebf0c45eb655eec59fcc (diff)
downloadslackbuilds-00a0ee8f79b5a1a49ca49f7f385d4aceced9f1ee.tar.gz
slackbuilds-00a0ee8f79b5a1a49ca49f7f385d4aceced9f1ee.tar.xz
python/python-django: Added (Web framework).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-django/README4
-rw-r--r--python/python-django/python-django.SlackBuild84
-rw-r--r--python/python-django/python-django.info10
-rw-r--r--python/python-django/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/python-django/README b/python/python-django/README
new file mode 100644
index 0000000000..a4d5bb41a9
--- /dev/null
+++ b/python/python-django/README
@@ -0,0 +1,4 @@
+python-django (The Web framework for perfectionists with deadlines)
+
+Django is a high-level Python Web framework that encourages rapid development
+and clean, pragmatic design.
diff --git a/python/python-django/python-django.SlackBuild b/python/python-django/python-django.SlackBuild
new file mode 100644
index 0000000000..574c598909
--- /dev/null
+++ b/python/python-django/python-django.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for python-django
+
+# Copyright 2015 Mario Preksavec, Zagreb, HR
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-django
+SRCNAM=django
+VERSION=${VERSION:-1.7.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$VERSION.tar.gz || tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG --prefix=/usr
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CONTRIBUTING.rst INSTALL LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-django/python-django.info b/python/python-django/python-django.info
new file mode 100644
index 0000000000..188269d82f
--- /dev/null
+++ b/python/python-django/python-django.info
@@ -0,0 +1,10 @@
+PRGNAM="python-django"
+VERSION="1.7.4"
+HOMEPAGE="https://github.com/django/"
+DOWNLOAD="https://github.com/django/django/archive/1.7.4.tar.gz"
+MD5SUM="a5fd57536f447305765c4f40359d191f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Mario Preksavec"
+EMAIL="mario at slackware dot hr"
diff --git a/python/python-django/slack-desc b/python/python-django/slack-desc
new file mode 100644
index 0000000000..e7b12ea9ae
--- /dev/null
+++ b/python/python-django/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-django: python-django (The Web framework for perfectionists with deadlines)
+python-django:
+python-django: Django is a high-level Python Web framework that encourages rapid
+python-django: development and clean, pragmatic design.
+python-django:
+python-django: Homepage: https://github.com/django/
+python-django:
+python-django:
+python-django:
+python-django:
+python-django: