summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2014-10-31 22:55:34 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-10-31 22:55:34 +0700
commit06432230742db1d6809134f50f1d68267c667468 (patch)
tree0ebd2d9ac23d1475aabeefcbb1cae7bd5d8baf08 /python
parentf95d76e7f9921ab9a57844ece17be9495b095302 (diff)
downloadslackbuilds-06432230742db1d6809134f50f1d68267c667468.tar.gz
slackbuilds-06432230742db1d6809134f50f1d68267c667468.tar.xz
python/pytables: Fix compilation with Cython-0.21.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pytables/pytables.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/pytables/pytables.SlackBuild b/python/pytables/pytables.SlackBuild
index 3c41e89844..f9443f4938 100644
--- a/python/pytables/pytables.SlackBuild
+++ b/python/pytables/pytables.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=pytables
VERSION=${VERSION:-3.1.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -73,6 +73,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix compilation with Cython 0.21
+# https://github.com/PyTables/PyTables/issues/386
+sed -i "s|Cython.Compiler.Main import|Cython.Compiler import|g" setup.py
+
python setup.py build install --prefix=/usr --root=$PKG
# Copy examples, contrib, and bench files