summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Mario Preksavec <mario at slackware dot hr>2015-02-06 20:27:55 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-06 20:27:55 +0700
commit171e85069717f372bfd9ba8ad6215f31bcc19bf2 (patch)
tree3ef0a33ba5189027c96cff3b2da42a4104dafff8 /python
parent41c520539d587c1fd7568a8dafaeb273e018c029 (diff)
downloadslackbuilds-171e85069717f372bfd9ba8ad6215f31bcc19bf2.tar.gz
slackbuilds-171e85069717f372bfd9ba8ad6215f31bcc19bf2.tar.xz
python/python-whisper: Added (Fixed size database).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-whisper/README5
-rw-r--r--python/python-whisper/man1/rrd2whisper.127
-rw-r--r--python/python-whisper/man1/whisper-create.131
-rw-r--r--python/python-whisper/man1/whisper-dump.123
-rw-r--r--python/python-whisper/man1/whisper-fetch.139
-rw-r--r--python/python-whisper/man1/whisper-info.123
-rw-r--r--python/python-whisper/man1/whisper-merge.123
-rw-r--r--python/python-whisper/man1/whisper-resize.135
-rw-r--r--python/python-whisper/man1/whisper-set-aggregation-method.123
-rw-r--r--python/python-whisper/man1/whisper-update.123
-rw-r--r--python/python-whisper/python-whisper.SlackBuild91
-rw-r--r--python/python-whisper/python-whisper.info10
-rw-r--r--python/python-whisper/slack-desc19
13 files changed, 372 insertions, 0 deletions
diff --git a/python/python-whisper/README b/python/python-whisper/README
new file mode 100644
index 0000000000..d0ba335097
--- /dev/null
+++ b/python/python-whisper/README
@@ -0,0 +1,5 @@
+python-whisper (Engine for fast, reliable fixed-sized databases)
+
+Whisper is a fixed size database, similar in design to the Round Robin
+database tool (RRDtool). Whisper is used by the Graphite scalable real time
+graphing system to store time-series data for later display.
diff --git a/python/python-whisper/man1/rrd2whisper.1 b/python/python-whisper/man1/rrd2whisper.1
new file mode 100644
index 0000000000..96474879df
--- /dev/null
+++ b/python/python-whisper/man1/rrd2whisper.1
@@ -0,0 +1,27 @@
+.TH RRD2WHISPER 1
+.SH NAME
+rrd2whisper \- convert an RRD database to a whisper database
+.SH SYNOPSYS
+.nf
+.fam C
+\fbwrrd2whisper\fP rrd_path
+.fam T
+.fi
+.SH DESCRIPTION
+This command converts an RRD database to a whisper fixed-size database.
+.PP
+The options are described below.
+.SH OPTIONS
+.TP
+.B
+\-\-xFilesFactor
+The fraction of data points in a propagation interval that must have known values for a propagation to occur.
+.TP
+.B
+\-h, \-\-help
+Show the embedded help.
+.SH AUTHOR
+\fBwhisper\fP is a fixed size database, created by Chris Davis.
+.PP
+This manual page was written by Elliot Murphy <elliot@ubuntu.com>, for the Debian
+project (but may be used by others).
diff --git a/python/python-whisper/man1/whisper-create.1 b/python/python-whisper/man1/whisper-create.1
new file mode 100644
index 0000000000..3380ebfec6
--- /dev/null
+++ b/python/python-whisper/man1/whisper-create.1
@@ -0,0 +1,31 @@
+.TH WHISPER-CREATE 1
+.SH NAME
+whisper-create \- create a whisper database
+.SH SYNOPSYS
+.nf
+.fam C
+\fbwhisper-create\fP path secondsPerPoint:pointsToStore [secondsPerPoint:pointsToStore]*
+.fam T
+.fi
+.SH DESCRIPTION
+This command creates a new whisper fixed-size database. For each database you specify one or more pairs of numbers describing how data points should be archived in this database. The first part of the pair is the precision, the second part of the pair is how many data points should be stored. You cannot configure two archives with the same precision inside a single database. Higher precision archives must evenly divide all lower precision archives' precision.
+.PP
+The options are described below.
+.SH OPTIONS
+.TP
+.B
+\-\-overwrite
+Overwrite an existing database.
+.TP
+.B
+\-\-xFilesFactor
+The fraction of data points in a propagation interval that must have known values for a propagation to occur.
+.TP
+.B
+\-h, \-\-help
+Show the embedded help.
+.SH AUTHOR
+\fBwhisper\fP is a fixed size database, created by Chris Davis.
+.PP
+This manual page was written by Elliot Murphy <elliot@ubuntu.com>, for the Debian
+project (but may be used by others).
diff --git a/python/python-whisper/man1/whisper-dump.1 b/python/python-whisper/man1/whisper-dump.1
new file mode 100644
index 0000000000..2b42b2ec81
--- /dev/null
+++ b/python/python-whisper/man1/whisper-dump.1
@@ -0,0 +1,23 @@
+.TH WHISPER-DUMP 1
+.SH NAME
+whisper-dump \- dump whisper database files
+.SH SYNOPSYS
+.nf
+.fam C
+\fbwhisper-dump\fP path
+.fam T
+.fi
+.SH DESCRIPTION
+This command dumps an whisper database file.
+.PP
+The options are described below.
+.SH OPTIONS
+.TP
+.B
+\-h, \-\-help
+Show the embedded help.
+.SH AUTHOR
+\fBwhisper\fP is a fixed size database, created by Chris Davis.
+.PP
+This manual page was written by Jonas Genannt <jonas.genannt@capi2name.de>, for
+the Debian project (but may be used by others).
diff --git a/python/python-whisper/man1/whisper-fetch.1 b/python/python-whisper/man1/whisper-fetch.1
new file mode 100644
index 0000000000..bb2c4e8c7d
--- /dev/null
+++ b/python/python-whisper/man1/whisper-fetch.1
@@ -0,0 +1,39 @@
+.TH WHISPER-FETCH 1
+.SH NAME
+whisper-fetch \- extract records from a whisper database
+.SH SYNOPSYS
+.nf
+.fam C
+\fbwhisper-fetch\fP [options] path
+.fam T
+.fi
+.SH DESCRIPTION
+This command retrieves records from a whisper fixed-size database.
+.PP
+The options are described below.
+.SH OPTIONS
+.TP
+.B
+\-\-from
+Unix epoch time of the beginning of your requested interval (default: 24 hours ago).
+.TP
+.B
+\-\-until
+Unix epoch time of the end of your requested interval (default: now).
+.TP
+.B
+\-\-json
+Output results in JSON form.
+.TP
+.B
+\-\-pretty
+Show human-readable timestamps instead of unix times.
+.TP
+.B
+\-h, \-\-help
+Show the embedded help.
+.SH AUTHOR
+\fBwhisper\fP is a fixed size database, created by Chris Davis.
+.PP
+This manual page was written by Elliot Murphy <elliot@ubuntu.com>, for the Debian
+project (but may be used by others).
diff --git a/python/python-whisper/man1/whisper-info.1 b/python/python-whisper/man1/whisper-info.1
new file mode 100644
index 0000000000..67920f9a76
--- /dev/null
+++ b/python/python-whisper/man1/whisper-info.1
@@ -0,0 +1,23 @@
+.TH WHISPER-INFO 1
+.SH NAME
+whisper-info \- show information about a whisper database
+.SH SYNOPSYS
+.nf
+.fam C
+\fbwhisper-info\fP path [field]
+.fam T
+.fi
+.SH DESCRIPTION
+This command displays information about a whisper fixed-size database.
+.PP
+The options are described below.
+.SH OPTIONS
+.TP
+.B
+\-h, \-\-help
+Show the embedded help.
+.SH AUTHOR
+\fBwhisper\fP is a fixed size database, created by Chris Davis.
+.PP
+This manual page was written by Elliot Murphy <elliot@ubuntu.com>, for the Debian
+project (but may be used by others).
diff --git a/python/python-whisper/man1/whisper-merge.1 b/python/python-whisper/man1/whisper-merge.1
new file mode 100644
index 0000000000..14d4ee958c
--- /dev/null
+++ b/python/python-whisper/man1/whisper-merge.1
@@ -0,0 +1,23 @@
+.TH WHISPER-MERGE 1
+.SH NAME
+whisper-merge \- merge two whisper database files
+.SH SYNOPSYS
+.nf
+.fam C
+\fbwhisper-merge\fP from_path to_path
+.fam T
+.fi
+.SH DESCRIPTION
+This command merges two whisper database files.
+.PP
+The options are described below.
+.SH OPTIONS
+.TP
+.B
+\-h, \-\-help
+Show the embedded help.
+.SH AUTHOR
+\fBwhisper\fP is a fixed size database, created by Chris Davis.
+.PP
+This manual page was written by Jonas Genannt <jonas.genannt@capi2name.de>, for
+the Debian project (but may be used by others).
diff --git a/python/python-whisper/man1/whisper-resize.1 b/python/python-whisper/man1/whisper-resize.1
new file mode 100644
index 0000000000..4f3cb622c8
--- /dev/null
+++ b/python/python-whisper/man1/whisper-resize.1
@@ -0,0 +1,35 @@
+.TH WHISPER-RESIZE 1
+.SH NAME
+whisper-resize \- resize a whisper database
+.SH SYNOPSYS
+.nf
+.fam C
+\fbwhisper-resize\fP path secondsPerPoint:pointsToStore [secondsPerPoint:pointsToStore]*
+.fam T
+.fi
+.SH DESCRIPTION
+This command resizes a whisper fixed-size database.
+.PP
+The options are described below.
+.SH OPTIONS
+.TP
+.B
+\-\-force
+Force a destructive change to an existing database.
+.TP
+.B
+\-\-newfile
+Create a new database file without removing the existing one.
+.TP
+.B
+\-\-xFilesFactor
+The fraction of data points in a propagation interval that must have known values for a propagation to occur.
+.TP
+.B
+\-h, \-\-help
+Show the embedded help.
+.SH AUTHOR
+\fBwhisper\fP is a fixed size database, created by Chris Davis.
+.PP
+This manual page was written by Elliot Murphy <elliot@ubuntu.com>, for the Debian
+project (but may be used by others).
diff --git a/python/python-whisper/man1/whisper-set-aggregation-method.1 b/python/python-whisper/man1/whisper-set-aggregation-method.1
new file mode 100644
index 0000000000..414d1169e6
--- /dev/null
+++ b/python/python-whisper/man1/whisper-set-aggregation-method.1
@@ -0,0 +1,23 @@
+.TH WHISPER-SET-AGGREGATION-METHOD 1
+.SH NAME
+whisper-set-aggregation-method \- set aggregationType field
+.SH SYNOPSYS
+.nf
+.fam C
+\fbwhisper-set-aggregation-method\fP path <average|sum|last|max|min>
+.fam T
+.fi
+.SH DESCRIPTION
+This command sets the aggregationType field in an whisper database.
+.PP
+The options are described below.
+.SH OPTIONS
+.TP
+.B
+\-h, \-\-help
+Show the embedded help.
+.SH AUTHOR
+\fBwhisper\fP is a fixed size database, created by Chris Davis.
+.PP
+This manual page was written by Jonas Genannt <jonas.genannt@capi2name.de>, for the Debian
+project (but may be used by others).
diff --git a/python/python-whisper/man1/whisper-update.1 b/python/python-whisper/man1/whisper-update.1
new file mode 100644
index 0000000000..5edf004a3d
--- /dev/null
+++ b/python/python-whisper/man1/whisper-update.1
@@ -0,0 +1,23 @@
+.TH WHISPER-UPDATE 1
+.SH NAME
+whisper-update \- update a whisper database
+.SH SYNOPSYS
+.nf
+.fam C
+\fbwhisper-update\fP [options] path timestamp:value [timestamp:value]*
+.fam T
+.fi
+.SH DESCRIPTION
+This command adds an entry to a whisper fixed-size database.
+.PP
+The options are described below.
+.SH OPTIONS
+.TP
+.B
+\-h, \-\-help
+Show the embedded help.
+.SH AUTHOR
+\fBwhisper\fP is a fixed size database, created by Chris Davis.
+.PP
+This manual page was written by Elliot Murphy <elliot@ubuntu.com>, for the Debian
+project (but may be used by others).
diff --git a/python/python-whisper/python-whisper.SlackBuild b/python/python-whisper/python-whisper.SlackBuild
new file mode 100644
index 0000000000..8dd67c8da6
--- /dev/null
+++ b/python/python-whisper/python-whisper.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for python-whisper
+
+# Copyright 2015 Mario Preksavec, Zagreb, HR
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-whisper
+SRCNAM=whisper
+SRCVER=0.9.13-pre1
+VERSION=${VERSION:-0.9.13pre1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$SRCVER
+tar xvf $CWD/$SRCVER.tar.gz
+cd $SRCNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Strip .py suffix on files in bin dir
+for i in $PKG/usr/bin/*.py ; do mv $i ${i/.py/} ; done
+
+# Manpages thanks to Debian folks!
+mkdir -p $PKG/usr/man
+cp -a $CWD/man1 $PKG/usr/man
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-whisper/python-whisper.info b/python/python-whisper/python-whisper.info
new file mode 100644
index 0000000000..7653c591e3
--- /dev/null
+++ b/python/python-whisper/python-whisper.info
@@ -0,0 +1,10 @@
+PRGNAM="python-whisper"
+VERSION="0.9.13pre1"
+HOMEPAGE="https://github.com/graphite-project/"
+DOWNLOAD="https://github.com/graphite-project/whisper/archive/0.9.13-pre1.tar.gz"
+MD5SUM="0e648f7e361dfcf908ec49f73d52dc32"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Mario Preksavec"
+EMAIL="mario at slackware dot hr"
diff --git a/python/python-whisper/slack-desc b/python/python-whisper/slack-desc
new file mode 100644
index 0000000000..0dd3368279
--- /dev/null
+++ b/python/python-whisper/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-whisper: python-whisper (Engine for fast, reliable fixed-sized databases)
+python-whisper:
+python-whisper: Whisper is a fixed size database, similar in design to the Round
+python-whisper: Robin database tool (RRDtool). Whisper is used by the Graphite
+python-whisper: scalable real time graphing system to store time-series data for
+python-whisper: later display.
+python-whisper:
+python-whisper: Homepage: https://github.com/graphite-project/
+python-whisper:
+python-whisper:
+python-whisper: