summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Philip Lacroix <slackph at posteo dot de>2015-09-11 01:44:13 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-09-11 01:44:13 +0700
commit27dfaae64fe816c35d7e7d88e25c36e3361a24f5 (patch)
tree606ac1f3b7063c2c29239f62f059a6c972bcaf25 /python
parent6010e4cdde3712800abc2181926102f0af08e709 (diff)
downloadslackbuilds-27dfaae64fe816c35d7e7d88e25c36e3361a24f5.tar.gz
slackbuilds-27dfaae64fe816c35d7e7d88e25c36e3361a24f5.tar.xz
python/py3sensors: Update EMAIL.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/py3sensors/README2
-rw-r--r--python/py3sensors/py3sensors.SlackBuild19
-rw-r--r--python/py3sensors/py3sensors.info2
-rw-r--r--python/py3sensors/slack-desc4
4 files changed, 14 insertions, 13 deletions
diff --git a/python/py3sensors/README b/python/py3sensors/README
index a842715450..18b2c919c1 100644
--- a/python/py3sensors/README
+++ b/python/py3sensors/README
@@ -1,2 +1,2 @@
-Py3sensors provides Python bindings to the libsensors library, which is
+py3sensors provides Python bindings to the libsensors library, which is
included in the lm_sensors project.
diff --git a/python/py3sensors/py3sensors.SlackBuild b/python/py3sensors/py3sensors.SlackBuild
index cbba493394..0afbd01b28 100644
--- a/python/py3sensors/py3sensors.SlackBuild
+++ b/python/py3sensors/py3sensors.SlackBuild
@@ -1,8 +1,8 @@
#!/bin/sh
-# Slackware build script for Py3sensors
+# Slackware build script for py3sensors
-# Copyright 2015 Philip Lacroix <philnx at posteo dot de>
+# Copyright 2015 Philip Lacroix <slackph at posteo dot de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -48,8 +48,8 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
-# The upstream tarball will be named differently, depending on the file being
-# downloaded manually (web browser) or with wget.
+# The upstream tarball will be named differently, depending on
+# the file being downloaded manually (web browser) or with wget.
if [ -e $CWD/$VERSION.zip ]; then
unzip $CWD/$VERSION.zip
else
@@ -64,9 +64,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
-PRGUSR=$PKG/usr
-PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-
python setup.py install --root=$PKG
# Python 3 support.
@@ -74,9 +71,13 @@ if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGUSR=$PKG/usr
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+# Install documentation.
mkdir -p $PRGDOC
mv README.rst $PRGDOC/
cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
diff --git a/python/py3sensors/py3sensors.info b/python/py3sensors/py3sensors.info
index fd1ced1050..520283127e 100644
--- a/python/py3sensors/py3sensors.info
+++ b/python/py3sensors/py3sensors.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Philip Lacroix"
-EMAIL="philnx at posteo dot de"
+EMAIL="slackph at posteo dot de"
diff --git a/python/py3sensors/slack-desc b/python/py3sensors/slack-desc
index e0e6f21fd5..49bd6ad60c 100644
--- a/python/py3sensors/slack-desc
+++ b/python/py3sensors/slack-desc
@@ -6,9 +6,9 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-py3sensors: Py3sensors (Python bindings to libsensors.so)
+py3sensors: py3sensors (Python bindings to libsensors.so)
py3sensors:
-py3sensors: Py3sensors provides Python bindings to the libsensors library, which
+py3sensors: py3sensors provides Python bindings to the libsensors library, which
py3sensors: is included in the lm_sensors project.
py3sensors:
py3sensors: Homepage: https://bitbucket.org/gleb_zhulik/py3sensors