summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundyatlinuxleo.com>2014-12-24 15:37:49 -0600
committer Robby Workman <rworkman@slackbuilds.org>2014-12-25 02:10:29 -0600
commit381b9c04e650c1d2f4d2d1cd5ea0ded77ebfb9ad (patch)
tree066208804340fda93eb4192fd156c487d5b73b7e /python
parenteedf36be340806875087b07e04f824f1d9391db7 (diff)
downloadslackbuilds-381b9c04e650c1d2f4d2d1cd5ea0ded77ebfb9ad.tar.gz
slackbuilds-381b9c04e650c1d2f4d2d1cd5ea0ded77ebfb9ad.tar.xz
python/dfvfs: Added (Digital Forensics Virtual File System)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/dfvfs/README61
-rw-r--r--python/dfvfs/dfvfs.SlackBuild84
-rw-r--r--python/dfvfs/dfvfs.info10
-rw-r--r--python/dfvfs/slack-desc19
4 files changed, 174 insertions, 0 deletions
diff --git a/python/dfvfs/README b/python/dfvfs/README
new file mode 100644
index 0000000000..ff996037fb
--- /dev/null
+++ b/python/dfvfs/README
@@ -0,0 +1,61 @@
+dfvfs (Digital Forensics Virtual File System - python module)
+
+This package provides read-only access to file-system objects from various
+storage media types and file formats. The goal of dfVFS is to provide a generic
+interface for accessing file-system objects, for which it uses several
+back-ends that provide the actual implementation of the various storage media
+types, volume systems and file systems.
+
+Supported:
+
+ EWF (EWF-E01, EWF-Ex01, EWF-S01)
+ QCOW version 1, 2
+ Storage Media device
+ (split) Storage Media RAW
+ VHD
+ VMDK
+
+Note that at the moment differential images are not supported.
+Volume systems
+
+Supported:
+
+ APM
+ BitLocker (BDE)
+ GPT
+ MBR
+ VSS
+
+Planned:
+
+ FileVault2 (CoreStorage)
+ LDM
+ LUKS
+ Linux LVM version 1, 2
+ Software Raid
+
+File systems
+
+Supported file systems:
+
+ ext version 2, 3, 4
+ FAT
+ HFS, HFS+, HFSX
+ NTFS version 3
+ UFS version 1, 2
+
+TODO add more detail here regarding FAT and other supported FS
+Compressed stream file types
+
+Supported:
+
+ bzip2
+ gzip
+ zlib (both zlib-DEFLATE and raw-DEFLATE)
+
+Archive file types
+
+Supported:
+
+ tar
+ zip
diff --git a/python/dfvfs/dfvfs.SlackBuild b/python/dfvfs/dfvfs.SlackBuild
new file mode 100644
index 0000000000..121a93ce69
--- /dev/null
+++ b/python/dfvfs/dfvfs.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for dfvfs
+# Copyright 2014 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Initial Build - December 2014 version 20141220
+
+PRGNAM=dfvfs
+VERSION=20141220
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ACKNOWLEDGEMENTS AUTHORS LICENSE README PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION/.
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/dfvfs/dfvfs.info b/python/dfvfs/dfvfs.info
new file mode 100644
index 0000000000..c1e823bb83
--- /dev/null
+++ b/python/dfvfs/dfvfs.info
@@ -0,0 +1,10 @@
+PRGNAM="dfvfs"
+VERSION="20141220"
+HOMEPAGE="https://github.com/log2timeline/dfvfs"
+DOWNLOAD="https://github.com/log2timeline/dfvfs/releases/download/20141220/dfvfs-20141220.tar.gz"
+MD5SUM="4aac69174983c55e2806daf7e241f123"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="construct protobuf libbde libewf libqcow libsmdev libsmraw libvhdi libvmdk libvshadow pytsk"
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/dfvfs/slack-desc b/python/dfvfs/slack-desc
new file mode 100644
index 0000000000..d0daa7724f
--- /dev/null
+++ b/python/dfvfs/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+dfvfs: dfvfs (Digital Forensics Virtual File System)
+dfvfs:
+dfvfs: dfVFS, or Digital Forensics Virtual File System, provides read-only
+dfvfs: access to file-system objects from various storage media types and
+dfvfs: file formats.
+dfvfs:
+dfvfs: Homepage: https://github.com/log2timeline/dfvfs
+dfvfs:
+dfvfs:
+dfvfs:
+dfvfs: