summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2015-01-20 22:29:16 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-01-20 22:29:16 +0700
commit3ff7e8bdae8aa57327e241d39edd94c1642c3500 (patch)
treeeed41f1cd69769623faa8335b606bb43987d6e27 /python
parent6c469fcfd070994fce08dc5bd5e8156454d8ad32 (diff)
downloadslackbuilds-3ff7e8bdae8aa57327e241d39edd94c1642c3500.tar.gz
slackbuilds-3ff7e8bdae8aa57327e241d39edd94c1642c3500.tar.xz
python/requests-futures: Added (Asynchronous Python HTTP).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/requests-futures/README4
-rw-r--r--python/requests-futures/requests-futures.SlackBuild85
-rw-r--r--python/requests-futures/requests-futures.info10
-rw-r--r--python/requests-futures/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/requests-futures/README b/python/requests-futures/README
new file mode 100644
index 0000000000..477e944515
--- /dev/null
+++ b/python/requests-futures/README
@@ -0,0 +1,4 @@
+Asynchronous Python HTTP for Humans.
+Small add-on for the python requests http library. Makes use of
+python 3.2's concurrent.futures or the backport for prior versions
+of python.
diff --git a/python/requests-futures/requests-futures.SlackBuild b/python/requests-futures/requests-futures.SlackBuild
new file mode 100644
index 0000000000..18c5921b4d
--- /dev/null
+++ b/python/requests-futures/requests-futures.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for requests-futures
+
+# Copyright 2015 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=requests-futures
+VERSION=${VERSION:-0.9.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/requests-futures/requests-futures.info b/python/requests-futures/requests-futures.info
new file mode 100644
index 0000000000..a8a11b9a44
--- /dev/null
+++ b/python/requests-futures/requests-futures.info
@@ -0,0 +1,10 @@
+PRGNAM="requests-futures"
+VERSION="0.9.5"
+HOMEPAGE="https://github.com/ross/requests-futures"
+DOWNLOAD="https://pypi.python.org/packages/source/r/requests-futures/requests-futures-0.9.5.tar.gz"
+MD5SUM="e20dc6f063c70888a7f8225e349b6682"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="futures python-requests"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/requests-futures/slack-desc b/python/requests-futures/slack-desc
new file mode 100644
index 0000000000..5ddb6ccc92
--- /dev/null
+++ b/python/requests-futures/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+requests-futures: requests-futures (Asynchronous Python HTTP)
+requests-futures:
+requests-futures: Small add-on for the python requests http library. Makes use of
+requests-futures: of python 3.2's concurrent.futures or the backport for prior
+requests-futures: versions of python.
+requests-futures:
+requests-futures: Homepage: https://github.com/ross/requests-futures
+requests-futures:
+requests-futures:
+requests-futures:
+requests-futures: