summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2015-03-01 22:20:28 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-03-08 06:35:07 +0700
commit488a866d870abcaa6cf1aa1b165136a20361fabc (patch)
tree5a2c423bde2329e93b138d25ee5211c6a2bde274 /python
parente7f9c311f6a69fd909fab4c2c641fd3b3e8f05e7 (diff)
downloadslackbuilds-488a866d870abcaa6cf1aa1b165136a20361fabc.tar.gz
slackbuilds-488a866d870abcaa6cf1aa1b165136a20361fabc.tar.xz
python/python3: Updated for version 3.4.3.
Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
Diffstat (limited to 'python')
-rw-r--r--python/python3/patches/python3.no-static-library.diff14
-rw-r--r--python/python3/patches/python3.x86_64.diff50
-rw-r--r--python/python3/python3.SlackBuild22
-rw-r--r--python/python3/python3.info6
4 files changed, 48 insertions, 44 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index 442373021c..fa3a36b9d5 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
---- Python-3.4.2.orig/Makefile.pre.in 2014-10-08 11:18:14.000000000 +0300
-+++ Python-3.4.2/Makefile.pre.in 2014-10-09 21:12:08.504150485 +0300
-@@ -537,7 +537,7 @@
+diff -uar Python-3.4.3.orig/Makefile.pre.in Python-3.4.3/Makefile.pre.in
+--- Python-3.4.3.orig/Makefile.pre.in 2015-02-25 13:27:45.000000000 +0200
++++ Python-3.4.3/Makefile.pre.in 2015-02-25 21:29:01.322056319 +0200
+@@ -538,7 +538,7 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
# Build the interpreter
@@ -10,7 +10,7 @@ diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -572,18 +572,6 @@
+@@ -573,18 +573,6 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -29,7 +29,7 @@ diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -673,7 +661,7 @@
+@@ -674,7 +662,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1324,18 +1312,6 @@
+@@ -1325,18 +1313,6 @@
else true; \
fi; \
done
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 0f144044e3..6d03183149 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.4.2.orig/Lib/distutils/command/install.py Python-3.4.2/Lib/distutils/command/install.py
---- Python-3.4.2.orig/Lib/distutils/command/install.py 2014-10-08 11:18:12.000000000 +0300
-+++ Python-3.4.2/Lib/distutils/command/install.py 2014-10-09 21:15:42.705228065 +0300
+diff -uar Python-3.4.3.orig/Lib/distutils/command/install.py Python-3.4.3/Lib/distutils/command/install.py
+--- Python-3.4.3.orig/Lib/distutils/command/install.py 2015-02-25 13:27:44.000000000 +0200
++++ Python-3.4.3/Lib/distutils/command/install.py 2015-02-25 21:32:54.352351233 +0200
@@ -29,15 +29,15 @@
INSTALL_SCHEMES = {
@@ -21,9 +21,9 @@ diff -uar Python-3.4.2.orig/Lib/distutils/command/install.py Python-3.4.2/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.4.2.orig/Lib/distutils/sysconfig.py Python-3.4.2/Lib/distutils/sysconfig.py
---- Python-3.4.2.orig/Lib/distutils/sysconfig.py 2014-10-08 11:18:12.000000000 +0300
-+++ Python-3.4.2/Lib/distutils/sysconfig.py 2014-10-09 21:15:42.705228065 +0300
+diff -uar Python-3.4.3.orig/Lib/distutils/sysconfig.py Python-3.4.3/Lib/distutils/sysconfig.py
+--- Python-3.4.3.orig/Lib/distutils/sysconfig.py 2015-02-25 13:27:44.000000000 +0200
++++ Python-3.4.3/Lib/distutils/sysconfig.py 2015-02-25 21:32:54.352351233 +0200
@@ -142,7 +142,7 @@
if os.name == "posix":
@@ -33,9 +33,9 @@ diff -uar Python-3.4.2.orig/Lib/distutils/sysconfig.py Python-3.4.2/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.4.2.orig/Lib/site.py Python-3.4.2/Lib/site.py
---- Python-3.4.2.orig/Lib/site.py 2014-10-08 11:18:12.000000000 +0300
-+++ Python-3.4.2/Lib/site.py 2014-10-09 21:15:42.706228092 +0300
+diff -uar Python-3.4.3.orig/Lib/site.py Python-3.4.3/Lib/site.py
+--- Python-3.4.3.orig/Lib/site.py 2015-02-25 13:27:44.000000000 +0200
++++ Python-3.4.3/Lib/site.py 2015-02-25 21:32:54.353351252 +0200
@@ -304,13 +304,13 @@
seen.add(prefix)
@@ -52,9 +52,9 @@ diff -uar Python-3.4.2.orig/Lib/site.py Python-3.4.2/Lib/site.py
if sys.platform == "darwin":
# for framework builds *only* we add the standard Apple
# locations.
-diff -uar Python-3.4.2.orig/Lib/sysconfig.py Python-3.4.2/Lib/sysconfig.py
---- Python-3.4.2.orig/Lib/sysconfig.py 2014-10-08 11:18:12.000000000 +0300
-+++ Python-3.4.2/Lib/sysconfig.py 2014-10-09 21:15:42.706228092 +0300
+diff -uar Python-3.4.3.orig/Lib/sysconfig.py Python-3.4.3/Lib/sysconfig.py
+--- Python-3.4.3.orig/Lib/sysconfig.py 2015-02-25 13:27:44.000000000 +0200
++++ Python-3.4.3/Lib/sysconfig.py 2015-02-25 21:32:54.353351252 +0200
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@@ -100,9 +100,9 @@ diff -uar Python-3.4.2.orig/Lib/sysconfig.py Python-3.4.2/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
---- Python-3.4.2.orig/Makefile.pre.in 2014-10-08 11:18:14.000000000 +0300
-+++ Python-3.4.2/Makefile.pre.in 2014-10-09 21:15:42.707228121 +0300
+diff -uar Python-3.4.3.orig/Makefile.pre.in Python-3.4.3/Makefile.pre.in
+--- Python-3.4.3.orig/Makefile.pre.in 2015-02-25 13:27:45.000000000 +0200
++++ Python-3.4.3/Makefile.pre.in 2015-02-25 21:32:54.354351276 +0200
@@ -120,7 +120,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
@@ -112,9 +112,9 @@ diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.4.2.orig/Modules/getpath.c Python-3.4.2/Modules/getpath.c
---- Python-3.4.2.orig/Modules/getpath.c 2014-10-08 11:18:15.000000000 +0300
-+++ Python-3.4.2/Modules/getpath.c 2014-10-09 21:15:42.707228121 +0300
+diff -uar Python-3.4.3.orig/Modules/getpath.c Python-3.4.3/Modules/getpath.c
+--- Python-3.4.3.orig/Modules/getpath.c 2015-02-25 13:27:46.000000000 +0200
++++ Python-3.4.3/Modules/getpath.c 2015-02-25 21:32:54.354351276 +0200
@@ -118,8 +118,8 @@
#endif
@@ -153,10 +153,10 @@ diff -uar Python-3.4.2.orig/Modules/getpath.c Python-3.4.2/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.4.2.orig/configure Python-3.4.2/configure
---- Python-3.4.2.orig/configure 2014-10-08 11:18:16.000000000 +0300
-+++ Python-3.4.2/configure 2014-10-09 21:15:42.711228262 +0300
-@@ -13948,7 +13948,7 @@
+diff -uar Python-3.4.3.orig/configure Python-3.4.3/configure
+--- Python-3.4.3.orig/configure 2015-02-25 13:27:46.000000000 +0200
++++ Python-3.4.3/configure 2015-02-25 21:32:54.358351377 +0200
+@@ -14022,7 +14022,7 @@
$as_echo "$LDVERSION" >&6; }
@@ -165,9 +165,9 @@ diff -uar Python-3.4.2.orig/configure Python-3.4.2/configure
# Check whether right shifting a negative integer extends the sign bit
-diff -uar Python-3.4.2.orig/setup.py Python-3.4.2/setup.py
---- Python-3.4.2.orig/setup.py 2014-10-08 11:18:16.000000000 +0300
-+++ Python-3.4.2/setup.py 2014-10-09 21:15:42.712228293 +0300
+diff -uar Python-3.4.3.orig/setup.py Python-3.4.3/setup.py
+--- Python-3.4.3.orig/setup.py 2015-02-25 13:27:46.000000000 +0200
++++ Python-3.4.3/setup.py 2015-02-25 21:32:54.358351377 +0200
@@ -451,7 +451,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
diff --git a/python/python3/python3.SlackBuild b/python/python3/python3.SlackBuild
index b2b689ac7b..6b67d7609b 100644
--- a/python/python3/python3.SlackBuild
+++ b/python/python3/python3.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python3
-VERSION=${VERSION:-3.4.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.4.3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -80,9 +80,12 @@ fi
# Fix python3 path in cgi.py.
sed -i '1s|^#.*/usr/local/bin/python|#!/usr/bin/python3|' Lib/cgi.py
-# Isolate ensurepip from site-packages, otherwise pip won't be installed if
-# there's Python3 on this system with pip already in site-packages.
-sed -i 's/-m ensurepip/-Sm ensurepip/' Makefile.pre.in
+# If this system already has Python3 with pip in site-packages, ignore it and
+# install pip anyway.
+sed -i 's|\("install",\)|\1 "--ignore-installed",|' Lib/ensurepip/__init__.py
+
+# Fix the SO for --extension-suffix in python3-config.
+sed -i 's|@SO@|@EXT_SUFFIX@|' Misc/python-config.sh.in
chown -R root:root .
find -L . \
@@ -91,9 +94,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix the SO for --extension-suffix in python3-config.
-sed -i 's|@SO@|@EXT_SUFFIX@|' Misc/python-config.sh.in
-
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
@@ -109,6 +109,10 @@ sed -i 's|@SO@|@EXT_SUFFIX@|' Misc/python-config.sh.in
make
make install DESTDIR=$PKG
+# Restore original ensurepip behaviour.
+sed -i 's|\("install",\) "--ignore-installed",|\1|' \
+ $PKG/usr/lib${LIBDIRSUFFIX}/python${PYVER}/ensurepip/__init__.py
+
# Remove to avoid overwriting a copy from Python2.
rm -f $PKG/usr/bin/2to3
@@ -133,7 +137,7 @@ if [ -e "$CWD/python-$VERSION-docs-html.tar.bz2" ]; then
chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION/html
fi
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
diff --git a/python/python3/python3.info b/python/python3/python3.info
index 8c55727427..a6c38301e9 100644
--- a/python/python3/python3.info
+++ b/python/python3/python3.info
@@ -1,8 +1,8 @@
PRGNAM="python3"
-VERSION="3.4.2"
+VERSION="3.4.3"
HOMEPAGE="https://www.python.org/"
-DOWNLOAD="https://www.python.org/ftp/python/3.4.2/Python-3.4.2.tar.xz"
-MD5SUM="36fc7327c02c6f12fa24fc9ba78039e3"
+DOWNLOAD="https://www.python.org/ftp/python/3.4.3/Python-3.4.3.tar.xz"
+MD5SUM="7d092d1bba6e17f0d9bd21b49e441dd5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""