summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Edinaldo P. Silva <edps.mundognu@gmail.com>2015-10-25 08:30:14 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-10-25 10:04:51 +0700
commit4e55e3d68b2a887eb38fe01af48b5e85133808a4 (patch)
tree18b9449932398f3747defac46fffe2dcf066dc73 /python
parentad9e87a9db2eafb5eb4b93fc1d4340967d21a8fa (diff)
downloadslackbuilds-4e55e3d68b2a887eb38fe01af48b5e85133808a4.tar.gz
slackbuilds-4e55e3d68b2a887eb38fe01af48b5e85133808a4.tar.xz
python/ps_mem: Added (list processes by memory usage).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/ps_mem/README4
-rw-r--r--python/ps_mem/ps_mem.SlackBuild93
-rw-r--r--python/ps_mem/ps_mem.info10
-rw-r--r--python/ps_mem/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/python/ps_mem/README b/python/ps_mem/README
new file mode 100644
index 0000000000..af331eb14a
--- /dev/null
+++ b/python/ps_mem/README
@@ -0,0 +1,4 @@
+ps_mem (list processes by memory usage)
+
+ps_mem is a utility to accurately report the in core memory usage
+for a program.
diff --git a/python/ps_mem/ps_mem.SlackBuild b/python/ps_mem/ps_mem.SlackBuild
new file mode 100644
index 0000000000..f77f629b1e
--- /dev/null
+++ b/python/ps_mem/ps_mem.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+#
+# Slackware build script for ps_mem.
+#
+# Copyright 2015 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ps_mem
+VERSION=${VERSION:-3.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+SRCVER="v3.6"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCVER.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG --optimize=1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/man/man1
+cp -a ps_mem.1 $PKG/usr/man/man1/
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/ps_mem/ps_mem.info b/python/ps_mem/ps_mem.info
new file mode 100644
index 0000000000..f4ab149407
--- /dev/null
+++ b/python/ps_mem/ps_mem.info
@@ -0,0 +1,10 @@
+PRGNAM="ps_mem"
+VERSION="3.6"
+HOMEPAGE="https://github.com/pixelb/ps_mem/"
+DOWNLOAD="https://github.com/pixelb/ps_mem/archive/v3.6.tar.gz"
+MD5SUM="d178522f404dd7db8de598d75600c0e0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Edinaldo P. Silva"
+EMAIL="edps.mundognu@gmail.com"
diff --git a/python/ps_mem/slack-desc b/python/ps_mem/slack-desc
new file mode 100644
index 0000000000..564f5b10c3
--- /dev/null
+++ b/python/ps_mem/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ps_mem: ps_mem (list processes by memory usage)
+ps_mem:
+ps_mem: ps_mem is a utility to accurately report the in core memory usage
+ps_mem: for a program.
+ps_mem:
+ps_mem: Homepage: https://github.com/pixelb/ps_mem
+ps_mem:
+ps_mem:
+ps_mem:
+ps_mem:
+ps_mem: