summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Marcel Saegebarth <marc@mos6581.de>2015-09-26 07:26:44 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-09-26 07:26:44 +0700
commit4eb0d1fc1c42ed4a58f02aac2ae3fa3110bf6b7f (patch)
treedf2682590874ab1ce572c37bffcfe725d9ba518f /python
parent092e27b0c00ba7016e82a9b398472b15eeccc969 (diff)
downloadslackbuilds-4eb0d1fc1c42ed4a58f02aac2ae3fa3110bf6b7f.tar.gz
slackbuilds-4eb0d1fc1c42ed4a58f02aac2ae3fa3110bf6b7f.tar.xz
python/google-api-python-client: Updated for version 1.5.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/google-api-python-client/README8
-rw-r--r--python/google-api-python-client/google-api-python-client.SlackBuild54
-rw-r--r--python/google-api-python-client/google-api-python-client.info14
-rw-r--r--python/google-api-python-client/slack-desc14
4 files changed, 41 insertions, 49 deletions
diff --git a/python/google-api-python-client/README b/python/google-api-python-client/README
index 136d714257..97d8bc1b42 100644
--- a/python/google-api-python-client/README
+++ b/python/google-api-python-client/README
@@ -1,7 +1 @@
-google-api-python-client (Google APIs Client for Python)
-
-Written by Google, this is a small, flexible, and powerful Python
-client library for accessing Google APIs. The library supports these
-Python environments: Google App Engine and Supported APIs
-This project is also the home of oauth2client, a Python client
-library for OAuth 2.0.
+This is the Python client library for Google's discovery based APIs.
diff --git a/python/google-api-python-client/google-api-python-client.SlackBuild b/python/google-api-python-client/google-api-python-client.SlackBuild
index f65016f139..08e12beb4a 100644
--- a/python/google-api-python-client/google-api-python-client.SlackBuild
+++ b/python/google-api-python-client/google-api-python-client.SlackBuild
@@ -1,29 +1,32 @@
#!/bin/sh
-# Slackware build script for google-api-python-client
+# Slackware build script for "google-api-python-client"
-# Copyright 2011 Vincent Batts, Vienna, VA. USA
+# Copyright 2011-2015 Vincent Batts, Vienna, VA. USA
+# Copyright 2015 Marcel Saegebarth <marc@mos6581.de>
# All rights reserved.
#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=google-api-python-client
-VERSION=${VERSION:-1.0beta2}
+VERSION=${VERSION:-1.4.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,24 +63,19 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/v$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README samples/ docs/ \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG LICENSE README.md samples/ docs/ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc/$PRGNAM-$VERSION -type d -exec chmod 0755 {} \;
diff --git a/python/google-api-python-client/google-api-python-client.info b/python/google-api-python-client/google-api-python-client.info
index d9905db469..21b5201f9a 100644
--- a/python/google-api-python-client/google-api-python-client.info
+++ b/python/google-api-python-client/google-api-python-client.info
@@ -1,10 +1,10 @@
PRGNAM="google-api-python-client"
-VERSION="1.0beta2"
-HOMEPAGE="https://google-api-python-client.googlecode.com/"
-DOWNLOAD="http://google-api-python-client.googlecode.com/files/google-api-python-client-1.0beta2.tar.gz"
-MD5SUM="0998bcec19f69c7130a36d0c1a91b100"
+VERSION="1.4.2"
+HOMEPAGE="https://github.com/google/google-api-python-client/"
+DOWNLOAD="https://github.com/google/google-api-python-client/archive/v1.4.2.tar.gz"
+MD5SUM="93a9cb70135fb941197bcd6d4136fb67"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Vincent Batts"
-EMAIL="vbatts@hashbangbash.com"
+REQUIRES="httplib2 python-uri-templates python-oauth2client"
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"
diff --git a/python/google-api-python-client/slack-desc b/python/google-api-python-client/slack-desc
index 6bb13abc3a..af8ba8e1e6 100644
--- a/python/google-api-python-client/slack-desc
+++ b/python/google-api-python-client/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
google-api-python-client: google-api-python-client (Google APIs Client for Python)
google-api-python-client:
-google-api-python-client: Written by Google, this is a small, flexible, and powerful Python
-google-api-python-client: client library for accessing Google APIs. The library supports these
-google-api-python-client: Python environments:
-google-api-python-client: Google App Engine
-google-api-python-client: Supported APIs
-google-api-python-client: This project is also the home of oauth2client, a Python client
-google-api-python-client: library for OAuth 2.0.
+google-api-python-client: This is the Python client library for Google's discovery based APIs.
+google-api-python-client:
+google-api-python-client: Homepage: https://github.com/google/google-api-python-client/
+google-api-python-client:
+google-api-python-client:
+google-api-python-client:
+google-api-python-client:
google-api-python-client:
google-api-python-client: