summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundy@gmail.com>2014-11-27 11:03:18 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-11-27 11:03:18 +0700
commit5f175602a78a9694e68f874a443bc09c24264751 (patch)
tree5d86ccedede143875c5046861f0b3e61a0a81190 /python
parent852fa7230ab83f183fc400dd82cb36daac80e99d (diff)
downloadslackbuilds-5f175602a78a9694e68f874a443bc09c24264751.tar.gz
slackbuilds-5f175602a78a9694e68f874a443bc09c24264751.tar.xz
python/hachoir-metadata: Added (Metadata Extractor).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/hachoir-metadata/README13
-rw-r--r--python/hachoir-metadata/hachoir-metadata.SlackBuild86
-rw-r--r--python/hachoir-metadata/hachoir-metadata.info10
-rw-r--r--python/hachoir-metadata/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/python/hachoir-metadata/README b/python/hachoir-metadata/README
new file mode 100644
index 0000000000..1f8052c7f7
--- /dev/null
+++ b/python/hachoir-metadata/README
@@ -0,0 +1,13 @@
+hachoir-metadata is tool to extract metadata from multimedia files (sound,
+video, archives, etc.).
+
+It supports most common file formats:
+
+ - Archives: bzip2, gzip, zip, tar
+ - Audio: MPEG audio ("MP3"), WAV, Sun/NeXT audio, Ogg/Vorbis (OGG),
+ MIDI, AIFF, AIFC, Real audio (RA)
+ - Image: BMP, CUR, EMF, ICO, GIF, JPEG, PCX, PNG, TGA, TIFF, WMF, XCF
+ - Misc: Torrent
+ - Program: EXE
+ - Video: ASF format (WMV video), AVI, Matroska (MKV), Quicktime (MOV),
+ Ogg/Theora, Real media (RM)
diff --git a/python/hachoir-metadata/hachoir-metadata.SlackBuild b/python/hachoir-metadata/hachoir-metadata.SlackBuild
new file mode 100644
index 0000000000..a7c3bea983
--- /dev/null
+++ b/python/hachoir-metadata/hachoir-metadata.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for hachoir-metadata
+# Copyright 2014 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Initial Build - November 2014 version 1.3.3
+
+PRGNAM=hachoir-metadata
+VERSION=${VERSION:-1.3.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog INSTALL README $PKG/usr/doc/$PRGNAM-$VERSION/.
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/hachoir-metadata/hachoir-metadata.info b/python/hachoir-metadata/hachoir-metadata.info
new file mode 100644
index 0000000000..b64acc274f
--- /dev/null
+++ b/python/hachoir-metadata/hachoir-metadata.info
@@ -0,0 +1,10 @@
+PRGNAM="hachoir-metadata"
+VERSION="1.3.3"
+HOMEPAGE="https://pypi.python.org/pypi/hachoir-metadata/1.3.3"
+DOWNLOAD="https://pypi.python.org/packages/source/h/hachoir-metadata/hachoir-metadata-1.3.3.tar.gz"
+MD5SUM="26e04a2395205d31469fc2d6935055a9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="hachoir-core hachoir-parser"
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/hachoir-metadata/slack-desc b/python/hachoir-metadata/slack-desc
new file mode 100644
index 0000000000..a76715cd83
--- /dev/null
+++ b/python/hachoir-metadata/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hachoir-metadata: hachoir-metadata (metadata extractor)
+hachoir-metadata:
+hachoir-metadata: hachoir-metadata is tool to extract metadata from multimedia
+hachoir-metadata: files (sound, video, archives, etc.)
+hachoir-metadata:
+hachoir-metadata: Homepage:
+hachoir-metadata: https://bitbucket.org/haypo/hachoir/wiki/hachoir-metadata
+hachoir-metadata:
+hachoir-metadata:
+hachoir-metadata:
+hachoir-metadata: