summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-03-12 12:38:40 -0500
committer Erik Hanson <erik@slackbuilds.org>2014-03-12 12:38:40 -0500
commit5fd4e5fe31fe003c9660cee2fc5add53e97d4e81 (patch)
treea7cd1f11aa24f89654b43d936635e53f16023ace /python
parent173e57986e8ca3967a80889663ea03d86b78a786 (diff)
downloadslackbuilds-5fd4e5fe31fe003c9660cee2fc5add53e97d4e81.tar.gz
slackbuilds-5fd4e5fe31fe003c9660cee2fc5add53e97d4e81.tar.xz
python/sge-pygame: Added (Game Engine)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/sge-pygame/README5
-rw-r--r--python/sge-pygame/sge-pygame.SlackBuild86
-rw-r--r--python/sge-pygame/sge-pygame.info10
-rw-r--r--python/sge-pygame/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/sge-pygame/README b/python/sge-pygame/README
new file mode 100644
index 0000000000..8e6508cee4
--- /dev/null
+++ b/python/sge-pygame/README
@@ -0,0 +1,5 @@
+The Stellar Game Engine (abbreviated "SGE", pronounced as "Sage")
+is a free 2-D game engine. The purpose of the SGE is to make game
+development easier, which allows more rapid development by
+experienced game developers and also helps less experienced game
+developers learn how to develop games.
diff --git a/python/sge-pygame/sge-pygame.SlackBuild b/python/sge-pygame/sge-pygame.SlackBuild
new file mode 100644
index 0000000000..2fef2988cb
--- /dev/null
+++ b/python/sge-pygame/sge-pygame.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for sge-pygame
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=sge-pygame
+VERSION=${VERSION:-0.7.0}
+SRCVERSION=${VERSION}-py2.7
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVERSION
+tar xvf $CWD/$PRGNAM-$SRCVERSION.tar.gz
+cd $PRGNAM-$SRCVERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README WHATSNEW* doc/*.html $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/sge-pygame/sge-pygame.info b/python/sge-pygame/sge-pygame.info
new file mode 100644
index 0000000000..0fbc797bb9
--- /dev/null
+++ b/python/sge-pygame/sge-pygame.info
@@ -0,0 +1,10 @@
+PRGNAM="sge-pygame"
+VERSION="0.7.0"
+HOMEPAGE="http://stellarengine.nongnu.org"
+DOWNLOAD="https://pypi.python.org/packages/source/s/sge-pygame/sge-pygame-0.7.0-py2.7.tar.gz"
+MD5SUM="c5d0e99c465a6cb7ed85b0295f7691dc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pygame"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/sge-pygame/slack-desc b/python/sge-pygame/slack-desc
new file mode 100644
index 0000000000..c7104e1c2c
--- /dev/null
+++ b/python/sge-pygame/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+sge-pygame: sge-pygame (Game Engine)
+sge-pygame:
+sge-pygame: The Stellar Game Engine (abbreviated "SGE",
+sge-pygame: pronounced as "Sage") is a free 2-D game engine.
+sge-pygame:
+sge-pygame: Homepage: http://stellarengine.nongnu.org
+sge-pygame:
+sge-pygame:
+sge-pygame:
+sge-pygame:
+sge-pygame: