summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Per DalĂŠn <per.dalen@gmail.com>2015-05-08 22:47:52 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-05-08 22:47:52 +0700
commit609df9395b95fb8c0308790771ed124637a67216 (patch)
treefb5e8d871eac3f325380913682e424bf68c94cfd /python
parent5b0ab2fa6793f1b09d4a57565961455ac3b89531 (diff)
downloadslackbuilds-609df9395b95fb8c0308790771ed124637a67216.tar.gz
slackbuilds-609df9395b95fb8c0308790771ed124637a67216.tar.xz
python/PyXB: Added (Python W3C XML Schema Bindings).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/PyXB/PyXB.SlackBuild86
-rw-r--r--python/PyXB/PyXB.info10
-rw-r--r--python/PyXB/README5
-rw-r--r--python/PyXB/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/PyXB/PyXB.SlackBuild b/python/PyXB/PyXB.SlackBuild
new file mode 100644
index 0000000000..1f7c67aaac
--- /dev/null
+++ b/python/PyXB/PyXB.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for PyXB
+
+# Copyright 2015 Per Dalén <per.dalen[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=PyXB
+VERSION=${VERSION:-1.2.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd pyxb-$PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.txt NOTICE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/PyXB/PyXB.info b/python/PyXB/PyXB.info
new file mode 100644
index 0000000000..3e4c874c4f
--- /dev/null
+++ b/python/PyXB/PyXB.info
@@ -0,0 +1,10 @@
+PRGNAM="PyXB"
+VERSION="1.2.4"
+HOMEPAGE="http://pyxb.sourceforge.net/"
+DOWNLOAD="https://github.com/pabigot/pyxb/archive/PyXB-1.2.4.tar.gz"
+MD5SUM="1ccdfe7043eb6c6c6be98b2727b77ed5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Per Dalén"
+EMAIL="per.dalen@gmail.com"
diff --git a/python/PyXB/README b/python/PyXB/README
new file mode 100644
index 0000000000..869e756d7d
--- /dev/null
+++ b/python/PyXB/README
@@ -0,0 +1,5 @@
+PyXB ("pixbee") is a pure Python package that generates Python source code
+for classes that correspond to data structures defined by XMLSchema.
+The generated classes support bi-directional conversion between XML documents
+and Python objects. In concept it is similar to JAXB for Java and CodeSynthesis
+XSD for C++.
diff --git a/python/PyXB/slack-desc b/python/PyXB/slack-desc
new file mode 100644
index 0000000000..5934b4d75a
--- /dev/null
+++ b/python/PyXB/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+PyXB: PyXB (Python W3C XML Schema Bindings)
+PyXB:
+PyXB: The source releases includes pre-built bundles for common XML
+PyXB: namespaces, assorted web service namespaces, and SAML. A bundle with
+PyXB: over 75 namespaces related to Geographic Information Systems is also
+PyXB: available.
+PyXB:
+PyXB:
+PyXB: http://pyxb.sourceforge.net/
+PyXB:
+PyXB: