summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Philip Lacroix <Philip Lacroix>2015-02-07 06:32:26 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-07 06:32:26 +0700
commit610988b2e954ad55a8ff4be76cd3675c812a9a02 (patch)
tree62d730b523f43bd820e70a6b754ed80a05771f7a /python
parentdb5864b564e0fc5ba7d393f3d5faad4e6ba17a8d (diff)
downloadslackbuilds-610988b2e954ad55a8ff4be76cd3675c812a9a02.tar.gz
slackbuilds-610988b2e954ad55a8ff4be76cd3675c812a9a02.tar.xz
python/py3sensors: Added (Python bindings to libsensors).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/py3sensors/README2
-rw-r--r--python/py3sensors/py3sensors.SlackBuild88
-rw-r--r--python/py3sensors/py3sensors.info10
-rw-r--r--python/py3sensors/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/py3sensors/README b/python/py3sensors/README
new file mode 100644
index 0000000000..a842715450
--- /dev/null
+++ b/python/py3sensors/README
@@ -0,0 +1,2 @@
+Py3sensors provides Python bindings to the libsensors library, which is
+included in the lm_sensors project.
diff --git a/python/py3sensors/py3sensors.SlackBuild b/python/py3sensors/py3sensors.SlackBuild
new file mode 100644
index 0000000000..cbba493394
--- /dev/null
+++ b/python/py3sensors/py3sensors.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for Py3sensors
+
+# Copyright 2015 Philip Lacroix <philnx at posteo dot de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=py3sensors
+SRCNAM=gleb_zhulik-$PRGNAM
+VERSION=${VERSION:-0cf96f4e2cfe}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+
+# The upstream tarball will be named differently, depending on the file being
+# downloaded manually (web browser) or with wget.
+if [ -e $CWD/$VERSION.zip ]; then
+ unzip $CWD/$VERSION.zip
+else
+ unzip $CWD/$SRCNAM-$VERSION.zip
+fi
+
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
+ -o -perm 400 \) -exec chmod 644 {} \;
+
+PRGUSR=$PKG/usr
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PRGDOC
+mv README.rst $PRGDOC/
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/py3sensors/py3sensors.info b/python/py3sensors/py3sensors.info
new file mode 100644
index 0000000000..fd1ced1050
--- /dev/null
+++ b/python/py3sensors/py3sensors.info
@@ -0,0 +1,10 @@
+PRGNAM="py3sensors"
+VERSION="0cf96f4e2cfe"
+HOMEPAGE="https://bitbucket.org/gleb_zhulik/py3sensors"
+DOWNLOAD="https://bitbucket.org/gleb_zhulik/py3sensors/get/0cf96f4e2cfe.zip"
+MD5SUM="23566f0fbfe8cb988b9b225cb0105a6c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Philip Lacroix"
+EMAIL="philnx at posteo dot de"
diff --git a/python/py3sensors/slack-desc b/python/py3sensors/slack-desc
new file mode 100644
index 0000000000..e0e6f21fd5
--- /dev/null
+++ b/python/py3sensors/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+py3sensors: Py3sensors (Python bindings to libsensors.so)
+py3sensors:
+py3sensors: Py3sensors provides Python bindings to the libsensors library, which
+py3sensors: is included in the lm_sensors project.
+py3sensors:
+py3sensors: Homepage: https://bitbucket.org/gleb_zhulik/py3sensors
+py3sensors:
+py3sensors:
+py3sensors:
+py3sensors:
+py3sensors: