summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2015-11-13 18:16:44 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-11-13 18:16:44 +0700
commit6ca46fdae407b66cafe700afaca0c3c332abed7b (patch)
tree6701249d715dcc39c64942eded2441521424075e /python
parentbd8dc9f8a73d531cffaa3bd25b036982d0dc308d (diff)
downloadslackbuilds-6ca46fdae407b66cafe700afaca0c3c332abed7b.tar.gz
slackbuilds-6ca46fdae407b66cafe700afaca0c3c332abed7b.tar.xz
python/python-clamd: Added (python interface to Clamav).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-clamd/README7
-rw-r--r--python/python-clamd/clamd-socket-file-name.patch14
-rw-r--r--python/python-clamd/python-clamd.SlackBuild89
-rw-r--r--python/python-clamd/python-clamd.info10
-rw-r--r--python/python-clamd/slack-desc19
5 files changed, 139 insertions, 0 deletions
diff --git a/python/python-clamd/README b/python/python-clamd/README
new file mode 100644
index 0000000000..0f572300f1
--- /dev/null
+++ b/python/python-clamd/README
@@ -0,0 +1,7 @@
+clamd is a portable Python module to use the ClamAV anti-virus engine on
+Windows, Linux, MacOSX and other platforms. It requires a running
+instance of the clamd daemon.
+
+*NOTE*
+Make sure that the Clamav daemon is running and that freshclam
+has been ran to use this python module.
diff --git a/python/python-clamd/clamd-socket-file-name.patch b/python/python-clamd/clamd-socket-file-name.patch
new file mode 100644
index 0000000000..76611cd036
--- /dev/null
+++ b/python/python-clamd/clamd-socket-file-name.patch
@@ -0,0 +1,14 @@
+
+Fixes the clamd socket file name
+
+--- clamd-1.0.2.orig/src/clamd/__init__.py 2015-11-12 20:33:36.923228615 -0700
++++ clamd-1.0.2/src/clamd/__init__.py 2015-11-12 20:34:37.925224478 -0700
+@@ -274,7 +274,7 @@
+ """
+ Class for using clamd with an unix socket
+ """
+- def __init__(self, path="/var/run/clamav/clamd.ctl", timeout=None):
++ def __init__(self, path="/var/run/clamav/clamd.socket", timeout=None):
+ """
+ class initialisation
+
diff --git a/python/python-clamd/python-clamd.SlackBuild b/python/python-clamd/python-clamd.SlackBuild
new file mode 100644
index 0000000000..be47efae6c
--- /dev/null
+++ b/python/python-clamd/python-clamd.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for python-clamd
+
+# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-clamd
+SRCNAM=clamd
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fixes the clamd socket file name for Slackware
+patch -p1 --verbose < $CWD/clamd-socket-file-name.patch
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-clamd/python-clamd.info b/python/python-clamd/python-clamd.info
new file mode 100644
index 0000000000..27fc41fb06
--- /dev/null
+++ b/python/python-clamd/python-clamd.info
@@ -0,0 +1,10 @@
+PRGNAM="python-clamd"
+VERSION="1.0.2"
+HOMEPAGE="https://github.com/graingert/python-clamd"
+DOWNLOAD="https://pypi.python.org/packages/source/c/clamd/clamd-1.0.2.tar.gz"
+MD5SUM="637f1d44a60a511544b6bd0bcb817f8a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="clamav"
+MAINTAINER="Brenton Earl"
+EMAIL="brent@exitstatusone.com"
diff --git a/python/python-clamd/slack-desc b/python/python-clamd/slack-desc
new file mode 100644
index 0000000000..9fbc535e9e
--- /dev/null
+++ b/python/python-clamd/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-clamd: python-clamd (python interface to Clamav)
+python-clamd:
+python-clamd: clamd is a portable Python module to use the ClamAV
+python-clamd: anti-virus engine on Windows, Linux, MacOSX and other
+python-clamd: platforms. It requires a running instance of the
+python-clamd: clamd daemon.
+python-clamd:
+python-clamd:
+python-clamd: Web Site: https://github.com/graingert/python-clamd
+python-clamd:
+python-clamd: