summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundy@gmail.com>2014-11-27 11:00:12 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-11-27 11:00:12 +0700
commit852fa7230ab83f183fc400dd82cb36daac80e99d (patch)
tree7066f2168cc2a454cd7978044d16547545c5d8f1 /python
parente08fc1352e465305498b1473aadca79890e231aa (diff)
downloadslackbuilds-852fa7230ab83f183fc400dd82cb36daac80e99d.tar.gz
slackbuilds-852fa7230ab83f183fc400dd82cb36daac80e99d.tar.xz
python/hachoir-parser: Added (File Parser).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/hachoir-parser/README4
-rw-r--r--python/hachoir-parser/hachoir-parser.SlackBuild85
-rw-r--r--python/hachoir-parser/hachoir-parser.info10
-rw-r--r--python/hachoir-parser/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/hachoir-parser/README b/python/hachoir-parser/README
new file mode 100644
index 0000000000..492abf2503
--- /dev/null
+++ b/python/hachoir-parser/README
@@ -0,0 +1,4 @@
+hachoir-parser
+
+hachoir-parser is a package of most common file format parsers written for
+Hachoir framework.
diff --git a/python/hachoir-parser/hachoir-parser.SlackBuild b/python/hachoir-parser/hachoir-parser.SlackBuild
new file mode 100644
index 0000000000..d626efa488
--- /dev/null
+++ b/python/hachoir-parser/hachoir-parser.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for hachoir-parser
+# Copyright 2014 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Initial Build - November 2014 version 1.3.4
+
+PRGNAM=hachoir-parser
+VERSION=${VERSION:-1.3.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/hachoir-parser/hachoir-parser.info b/python/hachoir-parser/hachoir-parser.info
new file mode 100644
index 0000000000..1fad7c3acc
--- /dev/null
+++ b/python/hachoir-parser/hachoir-parser.info
@@ -0,0 +1,10 @@
+PRGNAM="hachoir-parser"
+VERSION="1.3.4"
+HOMEPAGE="https://pypi.python.org/pypi/hachoir-parser"
+DOWNLOAD="https://pypi.python.org/packages/source/h/hachoir-parser/hachoir-parser-1.3.4.tar.gz"
+MD5SUM="e578b779c4b30d94ca4e775747877755"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/hachoir-parser/slack-desc b/python/hachoir-parser/slack-desc
new file mode 100644
index 0000000000..432f1a0ab9
--- /dev/null
+++ b/python/hachoir-parser/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hachoir-parser: hachoir-parser (file format parser)
+hachoir-parser:
+hachoir-parser: hachoir-parser is a package of most common file format parsers
+hachoir-parser: written for the Hachoir framework.
+hachoir-parser:
+hachoir-parser:
+hachoir-parser: Homepage: https://pypi.python.org/pypi/hachoir-parser
+hachoir-parser:
+hachoir-parser:
+hachoir-parser:
+hachoir-parser: