summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2014-11-14 02:16:25 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-11-14 02:16:25 +0700
commit8b137bdcfeca52b1eda54f25e8fbf21d674c431b (patch)
tree92b3e350fbbfbb515c812ee6cd9600620950f32c /python
parent6c09323c94e1797f718076b807a0eced97e311da (diff)
downloadslackbuilds-8b137bdcfeca52b1eda54f25e8fbf21d674c431b.tar.gz
slackbuilds-8b137bdcfeca52b1eda54f25e8fbf21d674c431b.tar.xz
python/python-libnacl: Added (Python binding for libsodium).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-libnacl/README1
-rw-r--r--python/python-libnacl/python-libnacl.SlackBuild90
-rw-r--r--python/python-libnacl/python-libnacl.info10
-rw-r--r--python/python-libnacl/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/python-libnacl/README b/python/python-libnacl/README
new file mode 100644
index 0000000000..d856a07753
--- /dev/null
+++ b/python/python-libnacl/README
@@ -0,0 +1 @@
+Python bindings for libsodium/tweetnacl based on ctypes.
diff --git a/python/python-libnacl/python-libnacl.SlackBuild b/python/python-libnacl/python-libnacl.SlackBuild
new file mode 100644
index 0000000000..0e1a5769e7
--- /dev/null
+++ b/python/python-libnacl/python-libnacl.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for python-libnacl
+
+# Copyright 2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-libnacl
+SRCNAM=libnacl
+VERSION=${VERSION:-1.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-libnacl/python-libnacl.info b/python/python-libnacl/python-libnacl.info
new file mode 100644
index 0000000000..e65f50b03e
--- /dev/null
+++ b/python/python-libnacl/python-libnacl.info
@@ -0,0 +1,10 @@
+PRGNAM="python-libnacl"
+VERSION="1.4.0"
+HOMEPAGE="https://libnacl.readthedocs.org/en/latest/"
+DOWNLOAD="https://pypi.python.org/packages/source/l/libnacl/libnacl-1.4.0.tar.gz"
+MD5SUM="fd986449d9a2bf22ed9d05989bb46fba"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools libsodium"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/python-libnacl/slack-desc b/python/python-libnacl/slack-desc
new file mode 100644
index 0000000000..8823160fbd
--- /dev/null
+++ b/python/python-libnacl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-libnacl: python-libnacl (Python binding for libsodium)
+python-libnacl:
+python-libnacl: Python bindings for libsodium/tweetnacl based on ctypes.
+python-libnacl:
+python-libnacl: Homepage: https://libnacl.readthedocs.org/en/latest/
+python-libnacl:
+python-libnacl:
+python-libnacl:
+python-libnacl:
+python-libnacl:
+python-libnacl: