summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundy@linuxleo.com>2015-01-22 06:29:21 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-01-22 06:34:20 +0700
commit9d86666900f48438411aededdaa483ee8f12c595 (patch)
treeb6cec23d5ac2f453994852b4c5e2ea04595a9335 /python
parentbf3e9d9f1f199c1fc9f8633ed4c801e001ad956f (diff)
downloadslackbuilds-9d86666900f48438411aededdaa483ee8f12c595.tar.gz
slackbuilds-9d86666900f48438411aededdaa483ee8f12c595.tar.xz
python/pytsk: Updated for version 20150111.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pytsk/pytsk.SlackBuild12
-rw-r--r--python/pytsk/pytsk.info6
2 files changed, 10 insertions, 8 deletions
diff --git a/python/pytsk/pytsk.SlackBuild b/python/pytsk/pytsk.SlackBuild
index 38ed45a3a1..4c05ed9e1b 100644
--- a/python/pytsk/pytsk.SlackBuild
+++ b/python/pytsk/pytsk.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for pytsk
-# Copyright 2014 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2014-2015 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,10 +21,10 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated v 20141220 December 2014.
+# Updated v20150111 January 2015, Barry J. Grundy.
PRGNAM=pytsk
-VERSION=20141220
+VERSION=${VERSION:-20150111}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -65,8 +65,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tgz
cd $PRGNAM
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
diff --git a/python/pytsk/pytsk.info b/python/pytsk/pytsk.info
index 8d58e411cb..1696298fce 100644
--- a/python/pytsk/pytsk.info
+++ b/python/pytsk/pytsk.info
@@ -1,8 +1,8 @@
PRGNAM="pytsk"
-VERSION="20141220"
+VERSION="20150111"
HOMEPAGE="https://github.com/py4n6/pytsk"
-DOWNLOAD="https://github.com/py4n6/pytsk/releases/download/20141220/pytsk-20141220.tgz"
-MD5SUM="bd7f48513e7c90320b0cf3bb1dc3fbc8"
+DOWNLOAD="https://github.com/py4n6/pytsk/releases/download/20150111/pytsk-20150111.tgz"
+MD5SUM="f9354f9d9335c847cc2bc8c3b5224a8d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="sleuthkit"