summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2014-03-02 09:49:28 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-03-02 09:49:28 +0700
commita60ca9808d6ff7997b52e0af0a31633e7bbf9b84 (patch)
tree9b3803c57a7ff4655d35a2375d77b98b2860a399 /python
parent2ad081bc952ab87706a2c238d0eacb56865b9ac3 (diff)
downloadslackbuilds-a60ca9808d6ff7997b52e0af0a31633e7bbf9b84.tar.gz
slackbuilds-a60ca9808d6ff7997b52e0af0a31633e7bbf9b84.tar.xz
python/cssutils: Updated for version 1.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/cssutils/cssutils.SlackBuild12
-rw-r--r--python/cssutils/cssutils.info6
2 files changed, 13 insertions, 5 deletions
diff --git a/python/cssutils/cssutils.SlackBuild b/python/cssutils/cssutils.SlackBuild
index 5ab326326c..6f87b9b307 100644
--- a/python/cssutils/cssutils.SlackBuild
+++ b/python/cssutils/cssutils.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=cssutils
-VERSION=${VERSION:-0.9.10}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -60,8 +60,16 @@ for FILE in $(find . -type f -exec grep -Pl '\r$' {} \;); do
sed -i 's/\r//g' $FILE
done
+# Don't use ez_setup. Use system setuptools or fail.
+sed -i '/ez_setup/d' setup.py
+
python setup.py install --root=$PKG
+if $(python3 -c 'import setuptools' 2>/dev/null); then
+ rm -rf build
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/cssutils/cssutils.info b/python/cssutils/cssutils.info
index c32471fc27..ce04b93138 100644
--- a/python/cssutils/cssutils.info
+++ b/python/cssutils/cssutils.info
@@ -1,8 +1,8 @@
PRGNAM="cssutils"
-VERSION="0.9.10"
+VERSION="1.0"
HOMEPAGE="https://bitbucket.org/cthedot/cssutils"
-DOWNLOAD="http://pypi.python.org/packages/source/c/cssutils/cssutils-0.9.10.zip"
-MD5SUM="81b5c0294c54479a54548769eaa236f8"
+DOWNLOAD="http://pypi.python.org/packages/source/c/cssutils/cssutils-1.0.zip"
+MD5SUM="0c0b9df329ec1461c732d0f3cba05e93"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysetuptools"