summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2015-09-17 22:37:08 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-09-17 22:37:08 +0700
commitb14979cbd611981f76cb57353f541fbe210d51fd (patch)
tree428da28806ef0bc8f373ccd98fc28a22009ad111 /python
parent68fbd7b4155fbe43f05260b5dbc566d19cddb07d (diff)
downloadslackbuilds-b14979cbd611981f76cb57353f541fbe210d51fd.tar.gz
slackbuilds-b14979cbd611981f76cb57353f541fbe210d51fd.tar.xz
python/pymysql: Updated for version 0.6.6.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pymysql/README6
-rw-r--r--python/pymysql/pymysql.SlackBuild12
-rw-r--r--python/pymysql/pymysql.info6
3 files changed, 17 insertions, 7 deletions
diff --git a/python/pymysql/README b/python/pymysql/README
index f59d6db989..f753b73b04 100644
--- a/python/pymysql/README
+++ b/python/pymysql/README
@@ -1,3 +1,9 @@
This package contains a pure-Python MySQL client library. The goal of PyMySQL is
to be a drop-in replacement for MySQLdb and work on CPython, PyPy, IronPython
and Jython.
+
+Optional dependency: python3
+
+To install python3 bindings run slackbuild with option PYTHON3=yes.
+
+ # PYTHON3=yes ./pymysql.SlackBuild
diff --git a/python/pymysql/pymysql.SlackBuild b/python/pymysql/pymysql.SlackBuild
index e497f1b928..6ed7796818 100644
--- a/python/pymysql/pymysql.SlackBuild
+++ b/python/pymysql/pymysql.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pymysql
-# Copyright 2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2014-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pymysql
-VERSION=${VERSION:-0.6.2}
+VERSION=${VERSION:-0.6.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,20 +46,24 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf PyMySQL-$PRGNAM-$VERSION
-tar xvf $CWD/PyMySQL-$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/PyMySQL-$PRGNAM-$VERSION.tar.gz 2>/dev/null || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd PyMySQL-$PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Don't install tests.
rm -rf $PRGNAM/tests
python setup.py install --root=$PKG
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/pymysql/pymysql.info b/python/pymysql/pymysql.info
index 98939a3db6..f65f65bf87 100644
--- a/python/pymysql/pymysql.info
+++ b/python/pymysql/pymysql.info
@@ -1,8 +1,8 @@
PRGNAM="pymysql"
-VERSION="0.6.2"
+VERSION="0.6.6"
HOMEPAGE="https://github.com/PyMySQL/PyMySQL"
-DOWNLOAD="https://github.com/PyMySQL/PyMySQL/archive/pymysql-0.6.2.tar.gz"
-MD5SUM="d16b0b4b1fe5a5c397525da4bc8a3e46"
+DOWNLOAD="https://github.com/PyMySQL/PyMySQL/archive/pymysql-0.6.6.tar.gz"
+MD5SUM="7cf52ba692d0929d2e98defb0cf3b506"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysetuptools"