summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Thibaut Notteboom <thibaut.notteboom@gmail.com>2015-03-15 07:59:10 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-03-15 07:59:10 +0700
commitb6c0f3a24a55533a04cc4b53bc30cf637e75918b (patch)
treeef291afc4d2e02d8e10e5835b35235ef301a2f6e /python
parentdb80bc979d149665ab99d08b249f3e3324eac80f (diff)
downloadslackbuilds-b6c0f3a24a55533a04cc4b53bc30cf637e75918b.tar.gz
slackbuilds-b6c0f3a24a55533a04cc4b53bc30cf637e75918b.tar.xz
python/python-requests: Updated for version 2.5.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-requests/README2
-rw-r--r--python/python-requests/python-requests.SlackBuild9
-rw-r--r--python/python-requests/python-requests.info6
3 files changed, 12 insertions, 5 deletions
diff --git a/python/python-requests/README b/python/python-requests/README
index 971ab87590..9cf8a1867d 100644
--- a/python/python-requests/README
+++ b/python/python-requests/README
@@ -1,2 +1,4 @@
Requests is an Apache2 Licensed HTTP library, written in Python, for
human beings.
+
+python3 is an optional dependency (autodetected).
diff --git a/python/python-requests/python-requests.SlackBuild b/python/python-requests/python-requests.SlackBuild
index f24f49b7c9..8219b638e0 100644
--- a/python/python-requests/python-requests.SlackBuild
+++ b/python/python-requests/python-requests.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-requests
-# Copyright 2013-2014 Thibaut Notteboom, Paris, FRANCE
+# Copyright 2013-2015 Thibaut Notteboom, Paris, FRANCE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-requests
-VERSION=${VERSION:-2.4.3}
+VERSION=${VERSION:-2.5.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -73,6 +73,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
HISTORY.rst LICENSE NOTICE PKG-INFO README.rst \
diff --git a/python/python-requests/python-requests.info b/python/python-requests/python-requests.info
index 1c068380c8..84f584f6b2 100644
--- a/python/python-requests/python-requests.info
+++ b/python/python-requests/python-requests.info
@@ -1,8 +1,8 @@
PRGNAM="python-requests"
-VERSION="2.4.3"
+VERSION="2.5.3"
HOMEPAGE="http://pypi.python.org/pypi/requests"
-DOWNLOAD="http://pypi.python.org/packages/source/r/requests/requests-2.4.3.tar.gz"
-MD5SUM="02214b3a179e445545de4b7a98d3dd17"
+DOWNLOAD="http://pypi.python.org/packages/source/r/requests/requests-2.5.3.tar.gz"
+MD5SUM="23bf4fcc89ea8d353eb5353bb4a475b1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""