summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Marcel Saegebarth <marc@mos6581.de>2015-02-04 20:39:09 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-05 06:31:11 +0700
commitbc2cca2be9c335a82138ce9bd3da9bd2649bba41 (patch)
treee72aa78b6a5a13ded7e96727b4023e0544192553 /python
parentebeebf2b7f91b591e7d9dda25d27b7aec37a9083 (diff)
downloadslackbuilds-bc2cca2be9c335a82138ce9bd3da9bd2649bba41.tar.gz
slackbuilds-bc2cca2be9c335a82138ce9bd3da9bd2649bba41.tar.xz
python/python-parse: Added (Python String Parser).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-parse/README2
-rw-r--r--python/python-parse/python-parse.SlackBuild89
-rw-r--r--python/python-parse/python-parse.info10
-rw-r--r--python/python-parse/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/python-parse/README b/python/python-parse/README
new file mode 100644
index 0000000000..a9974f8a74
--- /dev/null
+++ b/python/python-parse/README
@@ -0,0 +1,2 @@
+Parse strings using a specification based on the Python format()
+syntax.
diff --git a/python/python-parse/python-parse.SlackBuild b/python/python-parse/python-parse.SlackBuild
new file mode 100644
index 0000000000..6fee1fd508
--- /dev/null
+++ b/python/python-parse/python-parse.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# SlackBuild script for "python-parse".
+
+# Copyright 2014-2015 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-parse
+SRCNAM=parse
+VERSION=${VERSION:-1.6.6}
+BUILD=${BUILD:-4}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-parse/python-parse.info b/python/python-parse/python-parse.info
new file mode 100644
index 0000000000..030c7adb07
--- /dev/null
+++ b/python/python-parse/python-parse.info
@@ -0,0 +1,10 @@
+PRGNAM="python-parse"
+VERSION="1.6.6"
+HOMEPAGE="https://pypi.python.org/pypi/parse/"
+DOWNLOAD="https://pypi.python.org/packages/source/p/parse/parse-1.6.6.tar.gz"
+MD5SUM="11bc8c60a30fe52db4ac9a827653d0ca"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"
diff --git a/python/python-parse/slack-desc b/python/python-parse/slack-desc
new file mode 100644
index 0000000000..9cb670fdcf
--- /dev/null
+++ b/python/python-parse/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-parse: python-parse (Python String Parser)
+python-parse:
+python-parse: Parse strings using a specification based on the Python format()
+python-parse: syntax.
+python-parse:
+python-parse: Homepage: https://pypi.python.org/pypi/parse/
+python-parse:
+python-parse:
+python-parse:
+python-parse:
+python-parse: