summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2015-07-22 14:47:32 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-07-22 14:47:32 +0700
commitc3560b5edf4789c0a64377a3c05f8bdb19d9079b (patch)
tree798e3e7d7d15d35b7ee7f6da911e82bb96f22e53 /python
parent92a645ce0ffe020552bfa8ddb769c309b2fd65bf (diff)
downloadslackbuilds-c3560b5edf4789c0a64377a3c05f8bdb19d9079b.tar.gz
slackbuilds-c3560b5edf4789c0a64377a3c05f8bdb19d9079b.tar.xz
python/npyscreen: Added (python widget library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/npyscreen/README3
-rw-r--r--python/npyscreen/npyscreen.SlackBuild85
-rw-r--r--python/npyscreen/npyscreen.info10
-rw-r--r--python/npyscreen/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/npyscreen/README b/python/npyscreen/README
new file mode 100644
index 0000000000..a164c0743e
--- /dev/null
+++ b/python/npyscreen/README
@@ -0,0 +1,3 @@
+Npyscreen is a python widget library and application framework
+for programming terminal or console applications. It is built
+on top of ncurses, which is part of the standard library.
diff --git a/python/npyscreen/npyscreen.SlackBuild b/python/npyscreen/npyscreen.SlackBuild
new file mode 100644
index 0000000000..02a2e1417d
--- /dev/null
+++ b/python/npyscreen/npyscreen.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for npyscreen
+
+# Copyright 2015 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=npyscreen
+VERSION=${VERSION:-4.9.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO CHANGELOG LICENCE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/npyscreen/npyscreen.info b/python/npyscreen/npyscreen.info
new file mode 100644
index 0000000000..b339030492
--- /dev/null
+++ b/python/npyscreen/npyscreen.info
@@ -0,0 +1,10 @@
+PRGNAM="npyscreen"
+VERSION="4.9.1"
+HOMEPAGE="http://www.npcole.com/npyscreen/"
+DOWNLOAD="https://pypi.python.org/packages/source/n/npyscreen/npyscreen-4.9.1.tar.gz"
+MD5SUM="05088a99c76b8a924079cd139fab4aec"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/npyscreen/slack-desc b/python/npyscreen/slack-desc
new file mode 100644
index 0000000000..62d34c62e6
--- /dev/null
+++ b/python/npyscreen/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+npyscreen: npyscreen (python widget library)
+npyscreen:
+npyscreen: Npyscreen is a python widget library and application framework
+npyscreen: for programming terminal or console applications. It is built on
+npyscreen: top of ncurses, which is part of the standard library.
+npyscreen:
+npyscreen: Homepage: http://www.npcole.com/npyscreen/
+npyscreen:
+npyscreen:
+npyscreen:
+npyscreen: