summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2014-03-30 02:52:42 -0500
committer Erik Hanson <erik@slackbuilds.org>2014-04-12 13:59:48 -0500
commitd9a8bbf2e1c9302db876e15b3459b59c5f903db4 (patch)
treee65d52307fc6c52a4e0850a99b0f60f7d1320f43 /python
parent10b1a40f6a8b0b59855dc5a8692bd926c5b83e7f (diff)
downloadslackbuilds-d9a8bbf2e1c9302db876e15b3459b59c5f903db4.tar.gz
slackbuilds-d9a8bbf2e1c9302db876e15b3459b59c5f903db4.tar.xz
python/python3: Updated for version 3.4.0.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3/patches/python3.no-static-library.diff16
-rw-r--r--python/python3/patches/python3.readline.set_pre_input_hook.diff2
-rw-r--r--python/python3/patches/python3.x86_64.diff108
-rw-r--r--python/python3/python3.SlackBuild21
-rw-r--r--python/python3/python3.info10
5 files changed, 83 insertions, 74 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index 2bb1afccf3..bbc0e3a817 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,8 +1,8 @@
-diff -uar Python-3.3.5.orig/Makefile.pre.in Python-3.3.5/Makefile.pre.in
---- Python-3.3.5.orig/Makefile.pre.in 2014-03-09 10:40:23.000000000 +0200
-+++ Python-3.3.5/Makefile.pre.in 2014-03-12 22:42:27.614023691 +0200
-@@ -475,7 +475,7 @@
-
+diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
+--- Python-3.4.0.orig/Makefile.pre.in 2014-03-17 04:31:30.000000000 +0200
++++ Python-3.4.0/Makefile.pre.in 2014-03-29 12:27:38.788419450 +0200
+@@ -532,7 +532,7 @@
+ $(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
# Build the interpreter
-$(BUILDPYTHON): Modules/python.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
@@ -10,7 +10,7 @@ diff -uar Python-3.3.5.orig/Makefile.pre.in Python-3.3.5/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -500,18 +500,6 @@
+@@ -557,18 +557,6 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -29,7 +29,7 @@ diff -uar Python-3.3.5.orig/Makefile.pre.in Python-3.3.5/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -601,7 +589,7 @@
+@@ -658,7 +646,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.3.5.orig/Makefile.pre.in Python-3.3.5/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1200,18 +1188,6 @@
+@@ -1309,18 +1297,6 @@
else true; \
fi; \
done
diff --git a/python/python3/patches/python3.readline.set_pre_input_hook.diff b/python/python3/patches/python3.readline.set_pre_input_hook.diff
index 6796c6007e..b55820c489 100644
--- a/python/python3/patches/python3.readline.set_pre_input_hook.diff
+++ b/python/python3/patches/python3.readline.set_pre_input_hook.diff
@@ -1,6 +1,6 @@
--- ./Modules/readline.c.orig 2009-10-26 21:32:51.000000000 +0200
+++ ./Modules/readline.c 2010-05-30 14:07:10.000000000 +0300
-@@ -11,6 +11,9 @@
+@@ -12,6 +12,9 @@
#include <errno.h>
#include <sys/time.h>
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 5d5ce5f726..8fced1404b 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.3.3.orig/Lib/distutils/command/install.py Python-3.3.3/Lib/distutils/command/install.py
---- Python-3.3.3.orig/Lib/distutils/command/install.py 2013-11-17 09:22:30.000000000 +0200
-+++ Python-3.3.3/Lib/distutils/command/install.py 2013-12-29 13:48:10.102637141 +0200
+diff -uar Python-3.4.0.orig/Lib/distutils/command/install.py Python-3.4.0/Lib/distutils/command/install.py
+--- Python-3.4.0.orig/Lib/distutils/command/install.py 2014-03-17 04:31:29.000000000 +0200
++++ Python-3.4.0/Lib/distutils/command/install.py 2014-03-29 12:41:46.360404163 +0200
@@ -44,15 +44,15 @@
INSTALL_SCHEMES = {
@@ -21,10 +21,10 @@ diff -uar Python-3.3.3.orig/Lib/distutils/command/install.py Python-3.3.3/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.3.3.orig/Lib/distutils/sysconfig.py Python-3.3.3/Lib/distutils/sysconfig.py
---- Python-3.3.3.orig/Lib/distutils/sysconfig.py 2013-11-17 09:22:30.000000000 +0200
-+++ Python-3.3.3/Lib/distutils/sysconfig.py 2013-12-29 13:48:10.103637173 +0200
-@@ -144,7 +144,7 @@
+diff -uar Python-3.4.0.orig/Lib/distutils/sysconfig.py Python-3.4.0/Lib/distutils/sysconfig.py
+--- Python-3.4.0.orig/Lib/distutils/sysconfig.py 2014-03-17 04:31:29.000000000 +0200
++++ Python-3.4.0/Lib/distutils/sysconfig.py 2014-03-29 12:41:46.360404163 +0200
+@@ -142,7 +142,7 @@
if os.name == "posix":
libpython = os.path.join(prefix,
@@ -33,14 +33,13 @@ diff -uar Python-3.3.3.orig/Lib/distutils/sysconfig.py Python-3.3.3/Lib/distutil
if standard_lib:
return libpython
else:
-Only in Python-3.3.3/Lib/distutils: sysconfig.py.orig
-diff -uar Python-3.3.3.orig/Lib/site.py Python-3.3.3/Lib/site.py
---- Python-3.3.3.orig/Lib/site.py 2013-11-17 09:22:38.000000000 +0200
-+++ Python-3.3.3/Lib/site.py 2013-12-29 13:48:10.103637173 +0200
-@@ -303,13 +303,13 @@
- if sys.platform in ('os2emx', 'riscos'):
- sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
- elif os.sep == '/':
+diff -uar Python-3.4.0.orig/Lib/site.py Python-3.4.0/Lib/site.py
+--- Python-3.4.0.orig/Lib/site.py 2014-03-17 04:31:30.000000000 +0200
++++ Python-3.4.0/Lib/site.py 2014-03-29 12:45:39.339784221 +0200
+@@ -304,13 +304,13 @@
+ seen.add(prefix)
+
+ if os.sep == '/':
- sitepackages.append(os.path.join(prefix, "lib",
+ sitepackages.append(os.path.join(prefix, "lib64",
"python" + sys.version[:3],
@@ -53,10 +52,10 @@ diff -uar Python-3.3.3.orig/Lib/site.py Python-3.3.3/Lib/site.py
if sys.platform == "darwin":
# for framework builds *only* we add the standard Apple
# locations.
-diff -uar Python-3.3.3.orig/Lib/sysconfig.py Python-3.3.3/Lib/sysconfig.py
---- Python-3.3.3.orig/Lib/sysconfig.py 2013-11-17 09:22:39.000000000 +0200
-+++ Python-3.3.3/Lib/sysconfig.py 2013-12-29 13:48:10.103637173 +0200
-@@ -21,10 +21,10 @@
+diff -uar Python-3.4.0.orig/Lib/sysconfig.py Python-3.4.0/Lib/sysconfig.py
+--- Python-3.4.0.orig/Lib/sysconfig.py 2014-03-17 04:31:30.000000000 +0200
++++ Python-3.4.0/Lib/sysconfig.py 2014-03-29 12:41:46.361404197 +0200
+@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
'posix_prefix': {
@@ -71,7 +70,7 @@ diff -uar Python-3.3.3.orig/Lib/sysconfig.py Python-3.3.3/Lib/sysconfig.py
'include':
'{installed_base}/include/python{py_version_short}{abiflags}',
'platinclude':
-@@ -33,10 +33,10 @@
+@@ -32,10 +32,10 @@
'data': '{base}',
},
'posix_home': {
@@ -86,7 +85,7 @@ diff -uar Python-3.3.3.orig/Lib/sysconfig.py Python-3.3.3/Lib/sysconfig.py
'include': '{installed_base}/include/python',
'platinclude': '{installed_base}/include/python',
'scripts': '{base}/bin',
-@@ -81,10 +81,10 @@
+@@ -61,10 +61,10 @@
'data': '{userbase}',
},
'posix_user': {
@@ -101,10 +100,10 @@ diff -uar Python-3.3.3.orig/Lib/sysconfig.py Python-3.3.3/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.3.3.orig/Lib/venv/__init__.py Python-3.3.3/Lib/venv/__init__.py
---- Python-3.3.3.orig/Lib/venv/__init__.py 2013-11-17 09:22:53.000000000 +0200
-+++ Python-3.3.3/Lib/venv/__init__.py 2013-12-29 13:48:10.103637173 +0200
-@@ -117,7 +117,7 @@
+diff -uar Python-3.4.0.orig/Lib/venv/__init__.py Python-3.4.0/Lib/venv/__init__.py
+--- Python-3.4.0.orig/Lib/venv/__init__.py 2014-03-17 04:31:30.000000000 +0200
++++ Python-3.4.0/Lib/venv/__init__.py 2014-03-29 12:41:46.361404197 +0200
+@@ -133,7 +133,7 @@
else:
binname = 'bin'
incpath = 'include'
@@ -113,10 +112,9 @@ diff -uar Python-3.3.3.orig/Lib/venv/__init__.py Python-3.3.3/Lib/venv/__init__.
context.inc_path = path = os.path.join(env_dir, incpath)
create_if_needed(path)
create_if_needed(libpath)
-Only in Python-3.3.3/Lib/venv: __init__.py.orig
-diff -uar Python-3.3.3.orig/Makefile.pre.in Python-3.3.3/Makefile.pre.in
---- Python-3.3.3.orig/Makefile.pre.in 2013-11-17 09:22:55.000000000 +0200
-+++ Python-3.3.3/Makefile.pre.in 2013-12-29 13:48:10.104637203 +0200
+diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
+--- Python-3.4.0.orig/Makefile.pre.in 2014-03-17 04:31:30.000000000 +0200
++++ Python-3.4.0/Makefile.pre.in 2014-03-29 12:41:46.361404197 +0200
@@ -115,7 +115,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
@@ -126,11 +124,10 @@ diff -uar Python-3.3.3.orig/Makefile.pre.in Python-3.3.3/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-Only in Python-3.3.3: Makefile.pre.in.orig
-diff -uar Python-3.3.3.orig/Modules/getpath.c Python-3.3.3/Modules/getpath.c
---- Python-3.3.3.orig/Modules/getpath.c 2013-11-17 09:23:01.000000000 +0200
-+++ Python-3.3.3/Modules/getpath.c 2013-12-29 13:48:10.104637203 +0200
-@@ -122,8 +122,8 @@
+diff -uar Python-3.4.0.orig/Modules/getpath.c Python-3.4.0/Modules/getpath.c
+--- Python-3.4.0.orig/Modules/getpath.c 2014-03-17 04:31:31.000000000 +0200
++++ Python-3.4.0/Modules/getpath.c 2014-03-29 12:58:32.943849510 +0200
+@@ -118,8 +118,8 @@
#endif
#ifndef PYTHONPATH
@@ -141,16 +138,16 @@ diff -uar Python-3.3.3.orig/Modules/getpath.c Python-3.3.3/Modules/getpath.c
#endif
#ifndef LANDMARK
-@@ -135,7 +135,7 @@
- static wchar_t progpath[MAXPATHLEN+1];
- static wchar_t *module_search_path = NULL;
- static int module_search_path_malloced = 0;
--static wchar_t *lib_python = L"lib/python" VERSION;
-+static wchar_t *lib_python = L"lib64/python" VERSION;
+@@ -494,7 +494,7 @@
+ _pythonpath = _Py_char2wchar(PYTHONPATH, NULL);
+ _prefix = _Py_char2wchar(PREFIX, NULL);
+ _exec_prefix = _Py_char2wchar(EXEC_PREFIX, NULL);
+- lib_python = _Py_char2wchar("lib/python" VERSION, NULL);
++ lib_python = _Py_char2wchar("lib64/python" VERSION, NULL);
- static void
- reduce(wchar_t *dir)
-@@ -685,7 +685,7 @@
+ if (!_pythonpath || !_prefix || !_exec_prefix || !lib_python) {
+ Py_FatalError(
+@@ -683,7 +683,7 @@
}
else
wcsncpy(zip_path, _prefix, MAXPATHLEN);
@@ -168,11 +165,22 @@ diff -uar Python-3.3.3.orig/Modules/getpath.c Python-3.3.3/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-Only in Python-3.3.3/Modules: getpath.c.orig
-diff -uar Python-3.3.3.orig/setup.py Python-3.3.3/setup.py
---- Python-3.3.3.orig/setup.py 2013-11-17 09:23:09.000000000 +0200
-+++ Python-3.3.3/setup.py 2013-12-29 13:48:10.105637233 +0200
-@@ -439,7 +439,7 @@
+diff -uar Python-3.4.0.orig/configure Python-3.4.0/configure
+--- Python-3.4.0.orig/configure 2014-03-17 04:31:31.000000000 +0200
++++ Python-3.4.0/configure 2014-03-29 14:11:12.338969032 +0200
+@@ -13953,7 +13953,7 @@
+ $as_echo "$LDVERSION" >&6; }
+
+
+-LIBPL="${prefix}/lib/python${VERSION}/config-${LDVERSION}"
++LIBPL="${prefix}/lib64/python${VERSION}/config-${LDVERSION}"
+
+
+ # Check whether right shifting a negative integer extends the sign bit
+diff -uar Python-3.4.0.orig/setup.py Python-3.4.0/setup.py
+--- Python-3.4.0.orig/setup.py 2014-03-17 04:31:31.000000000 +0200
++++ Python-3.4.0/setup.py 2014-03-29 12:41:46.362404227 +0200
+@@ -445,7 +445,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
if not cross_compiling:
@@ -181,7 +189,7 @@ diff -uar Python-3.3.3.orig/setup.py Python-3.3.3/setup.py
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# only change this for cross builds for 3.3, issues on Mageia
if cross_compiling:
-@@ -712,11 +712,11 @@
+@@ -722,11 +722,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -195,7 +203,7 @@ diff -uar Python-3.3.3.orig/setup.py Python-3.3.3/setup.py
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -753,8 +753,8 @@
+@@ -763,8 +763,8 @@
if krb5_h:
ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
diff --git a/python/python3/python3.SlackBuild b/python/python3/python3.SlackBuild
index c05273cd71..09de0ae176 100644
--- a/python/python3/python3.SlackBuild
+++ b/python/python3/python3.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python3
-VERSION=${VERSION:-3.3.5}
+VERSION=${VERSION:-3.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -52,12 +52,14 @@ else
LIBDIRSUFFIX=""
fi
+PYVER=${VERSION::3}
+
set -eu
# Location for Python site-packages:
-SITEPK=$PKG/usr/lib${LIBDIRSUFFIX}/python3.3/site-packages
+SITEPK=$PKG/usr/lib${LIBDIRSUFFIX}/python${PYVER}/site-packages
# same as above without $PKG
-TOOLSDIR=/usr/lib${LIBDIRSUFFIX}/python3.3/site-packages
+TOOLSDIR=/usr/lib${LIBDIRSUFFIX}/python${PYVER}/site-packages
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -102,14 +104,13 @@ make altinstall DESTDIR=$PKG
# Create a few useful symlinks.
( cd $PKG/usr/bin
- ln -sf python3.3 python3
- ln -sf python3.3*-config python3.3-config
- ln -sf python3.3-config python3-config
- ln -sf pydoc3.3 pydoc3
- ln -sf pyvenv-3.3 pyvenv
- ln -sf idle3.3 idle3
+ ln -sf python${PYVER} python3
+ ln -sf python${PYVER}*-config python3-config
+ ln -sf pydoc${PYVER} pydoc3
+ ln -sf pyvenv-${PYVER} pyvenv
+ ln -sf idle${PYVER} idle3
cd $PKG/usr/man/man1
- ln -sf python3.3.1 python3.1
+ ln -sf python${PYVER}.1 python3.1
)
# We'll install the python-tools under site-packages:
diff --git a/python/python3/python3.info b/python/python3/python3.info
index 33779d1da4..7bcb0da0bd 100644
--- a/python/python3/python3.info
+++ b/python/python3/python3.info
@@ -1,10 +1,10 @@
PRGNAM="python3"
-VERSION="3.3.5"
+VERSION="3.4.0"
HOMEPAGE="http://python.org/"
-DOWNLOAD="http://python.org/ftp/python/3.3.5/Python-3.3.5.tar.xz \
- http://python.org/ftp/python/doc/3.3.5/python-3.3.5-docs-html.tar.bz2"
-MD5SUM="b2a4df195d934e5b229e8328ca864960 \
- 71495f2214dc43a7c24d9a562f45b5ea"
+DOWNLOAD="https://python.org/ftp/python/3.4.0/Python-3.4.0.tar.xz \
+ https://python.org/ftp/python/doc/3.4.0/python-3.4.0-docs-html.tar.bz2"
+MD5SUM="77c22725e14af3d71022cbfdebff4903 \
+ cdbef126ee7ef0908352fabc4dc5bee5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""