summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Thibaut Notteboom <thibaut.notteboom@gmail.com>2015-09-14 07:47:18 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-09-16 12:23:23 +0700
commitdd7749a2e463f6b3974eeb2cc6e619f83a96dc46 (patch)
treeaba961cff6572f828c0a4a5ba9b6ea5985de08af /python
parent11b2fb952b6ccc42fdc01b0c66c026da5e3f4942 (diff)
downloadslackbuilds-dd7749a2e463f6b3974eeb2cc6e619f83a96dc46.tar.gz
slackbuilds-dd7749a2e463f6b3974eeb2cc6e619f83a96dc46.tar.xz
python/python-requests-kerberos: Added (authentication handler).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-requests-kerberos/README3
-rw-r--r--python/python-requests-kerberos/python-requests-kerberos.SlackBuild84
-rw-r--r--python/python-requests-kerberos/python-requests-kerberos.info10
-rw-r--r--python/python-requests-kerberos/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/python-requests-kerberos/README b/python/python-requests-kerberos/README
new file mode 100644
index 0000000000..0295cb546b
--- /dev/null
+++ b/python/python-requests-kerberos/README
@@ -0,0 +1,3 @@
+Requests is an HTTP library, written in Python, for human beings.
+This library adds optional Kerberos/GSSAPI authentication support and
+supports mutual authentication.
diff --git a/python/python-requests-kerberos/python-requests-kerberos.SlackBuild b/python/python-requests-kerberos/python-requests-kerberos.SlackBuild
new file mode 100644
index 0000000000..eebf4cae2b
--- /dev/null
+++ b/python/python-requests-kerberos/python-requests-kerberos.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for python-requests-kerberos
+
+# Copyright 2015 Thibaut Notteboom, Paris, FRANCE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-requests-kerberos
+VERSION=${VERSION:-0.7.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=requests-kerberos
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS HISTORY.rst LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-requests-kerberos/python-requests-kerberos.info b/python/python-requests-kerberos/python-requests-kerberos.info
new file mode 100644
index 0000000000..9b54e8ce8a
--- /dev/null
+++ b/python/python-requests-kerberos/python-requests-kerberos.info
@@ -0,0 +1,10 @@
+PRGNAM="python-requests-kerberos"
+VERSION="0.7.0"
+HOMEPAGE="http://pypi.python.org/pypi/requests-kerberos"
+DOWNLOAD="https://pypi.python.org/packages/source/r/requests-kerberos/requests-kerberos-0.7.0.tar.gz"
+MD5SUM="d7cde195a95536c83a2ffd8a7050be4c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-kerberos python-requests"
+MAINTAINER="Thibaut Notteboom"
+EMAIL="thibaut.notteboom@gmail.com"
diff --git a/python/python-requests-kerberos/slack-desc b/python/python-requests-kerberos/slack-desc
new file mode 100644
index 0000000000..1bb50a3c0a
--- /dev/null
+++ b/python/python-requests-kerberos/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-requests-kerberos: python-requests-kerberos (A Kerberos authentication handler
+python-requests-kerberos:
+python-requests-kerberos:
+python-requests-kerberos: Requests is an HTTP library, written in Python, for human beings.
+python-requests-kerberos: This library adds optional Kerberos/GSSAPI authentication support and
+python-requests-kerberos: supports mutual authentication.
+python-requests-kerberos:
+python-requests-kerberos:
+python-requests-kerberos:
+python-requests-kerberos:
+python-requests-kerberos: