summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundy@gmail.com>2014-11-27 10:57:40 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-11-27 10:57:40 +0700
commite08fc1352e465305498b1473aadca79890e231aa (patch)
treef9db44969da4bf6053da379e562435e580094987 /python
parentba66a08018488ef661808974214267a26edb5e46 (diff)
downloadslackbuilds-e08fc1352e465305498b1473aadca79890e231aa.tar.gz
slackbuilds-e08fc1352e465305498b1473aadca79890e231aa.tar.xz
python/hachoir-core: Added (Python Library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/hachoir-core/README5
-rw-r--r--python/hachoir-core/hachoir-core.SlackBuild85
-rw-r--r--python/hachoir-core/hachoir-core.info10
-rw-r--r--python/hachoir-core/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/hachoir-core/README b/python/hachoir-core/README
new file mode 100644
index 0000000000..26904f6aa2
--- /dev/null
+++ b/python/hachoir-core/README
@@ -0,0 +1,5 @@
+hachoir-core
+
+Hachoir is a Python library used to represent of a binary file as a tree of
+Python objects. Each object has a type, a value, an address, etc. The goal is
+to be able to know the meaning of each bit in a file.
diff --git a/python/hachoir-core/hachoir-core.SlackBuild b/python/hachoir-core/hachoir-core.SlackBuild
new file mode 100644
index 0000000000..e7a8a617dd
--- /dev/null
+++ b/python/hachoir-core/hachoir-core.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for hachoir-core
+# Copyright 2014 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Initial Build - November 2014 version 1.3.3
+
+PRGNAM=hachoir-core
+VERSION=${VERSION:-1.3.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/hachoir-core/hachoir-core.info b/python/hachoir-core/hachoir-core.info
new file mode 100644
index 0000000000..afa448070f
--- /dev/null
+++ b/python/hachoir-core/hachoir-core.info
@@ -0,0 +1,10 @@
+PRGNAM="hachoir-core"
+VERSION="1.3.3"
+HOMEPAGE="https://pypi.python.org/pypi/hachoir-core"
+DOWNLOAD="https://pypi.python.org/packages/source/h/hachoir-core/hachoir-core-1.3.3.tar.gz"
+MD5SUM="b80f0257536e2b2cb23f66670c4f6f31"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/hachoir-core/slack-desc b/python/hachoir-core/slack-desc
new file mode 100644
index 0000000000..b53e162460
--- /dev/null
+++ b/python/hachoir-core/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hachoir-core: hachoir-core (Python Library)
+hachoir-core:
+hachoir-core: hachoir-core is a Python library used to represent a binary file as
+hachoir-core: a tree of python objects. Each object has a type, a value, an
+hachoir-core: address, etc.
+hachoir-core:
+hachoir-core: Homepage: https://pypi.python.org/pypi/hachoir-core
+hachoir-core:
+hachoir-core:
+hachoir-core:
+hachoir-core: