summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2014-10-16 16:33:23 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-10-16 16:33:23 +0700
commitfba9a8420c25171a26e2fe1765242b24009baf8b (patch)
treed526de0986cdf80fb32ae3ad585db9b49358d1eb /python
parent47435ee77929aaa3e7e050a813446d4a6fff06e2 (diff)
downloadslackbuilds-fba9a8420c25171a26e2fe1765242b24009baf8b.tar.gz
slackbuilds-fba9a8420c25171a26e2fe1765242b24009baf8b.tar.xz
python/numexpr: Updated for version 2.4.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/numexpr/numexpr.SlackBuild12
-rw-r--r--python/numexpr/numexpr.info8
2 files changed, 10 insertions, 10 deletions
diff --git a/python/numexpr/numexpr.SlackBuild b/python/numexpr/numexpr.SlackBuild
index 50658ec807..3a3b071cca 100644
--- a/python/numexpr/numexpr.SlackBuild
+++ b/python/numexpr/numexpr.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for numexpr
-# Copyright 2010-2013 LukenShiro, Italy
+# Copyright 2010-2014 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=numexpr
-VERSION=${VERSION:-2.2.2}
+VERSION=${VERSION:-2.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -54,7 +54,7 @@ else
LIBDIRSUFFIX=""
fi
-DOCFILES="ANNOUNCE.txt INSTALL.txt LICENSE.txt README.txt RELEASE_NOTES.txt"
+DOCFILES="ANNOUNCE.rst README.rst AUTHORS.txt INSTALL.rst RELEASE_NOTES.rst"
set -e
@@ -66,10 +66,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build install --root=$PKG
diff --git a/python/numexpr/numexpr.info b/python/numexpr/numexpr.info
index 8b910799a6..435c1044a9 100644
--- a/python/numexpr/numexpr.info
+++ b/python/numexpr/numexpr.info
@@ -1,8 +1,8 @@
PRGNAM="numexpr"
-VERSION="2.2.2"
-HOMEPAGE="http://code.google.com/p/numexpr/"
-DOWNLOAD="http://numexpr.googlecode.com/files/numexpr-2.2.2.tar.gz"
-MD5SUM="18103954044b3039c0a74a6006c8e0a7"
+VERSION="2.4"
+HOMEPAGE="https://github.com/pydata/numexpr"
+DOWNLOAD="https://pypi.python.org/packages/source/n/numexpr/numexpr-2.4.tar.gz"
+MD5SUM="df7e8d9e9dbb145b56d43c465c2bf854"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="numpy"