summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Philip Lacroix <philnx@posteo.de>2014-11-30 12:10:55 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-11-30 12:10:55 +0700
commit38a7f25704e2fc8041516fc448aa5252a29d365b (patch)
tree62452ce6da31d55d2069e48eb0bb2ce702241fdf /system
parentbcaafc8f7ddfec9831865e9e0bcd0a19bf2d30c4 (diff)
downloadslackbuilds-38a7f25704e2fc8041516fc448aa5252a29d365b.tar.gz
slackbuilds-38a7f25704e2fc8041516fc448aa5252a29d365b.tar.xz
system/glances: Updated for version 2.1.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/glances/README11
-rw-r--r--system/glances/glances.SlackBuild15
-rw-r--r--system/glances/glances.info6
3 files changed, 18 insertions, 14 deletions
diff --git a/system/glances/README b/system/glances/README
index b393b94c0b..d1ea44258b 100644
--- a/system/glances/README
+++ b/system/glances/README
@@ -11,7 +11,10 @@ This tool is written in Python and uses the psutil library to fetch the
statistical values from key elements, like CPU, load average, memory,
network, disks, file systems, processes, etc.
-Optional dependencies are Jinja2 (for HTML output), hddtemp (for HHD
-temperature monitoring support) and python3. Others not available on SBo
-are pysensors (for HW monitoring support) and batinfo (for battery
-monitoring support).
+Optional dependencies are hddtemp (for HHD temperature monitoring support)
+and python3. Others not available on SBo are bottle (for Web server mode),
+py3sensors (for HW monitoring support) and batinfo (for battery monitoring
+support).
+
+NOTE: when launching Glances in a terminal with a bright background, the
+option '--theme-white' is recommended.
diff --git a/system/glances/glances.SlackBuild b/system/glances/glances.SlackBuild
index c8ed89e5f9..e998a53d04 100644
--- a/system/glances/glances.SlackBuild
+++ b/system/glances/glances.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=glances
-VERSION=${VERSION:-1.7.7}
+VERSION=${VERSION:-2.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -51,10 +51,10 @@ tar xvf $CWD/v$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
+ -o -perm 400 \) -exec chmod 644 {} \;
PRGUSR=$PKG/usr
PRGETC=$PKG/etc/$PRGNAM
@@ -68,8 +68,9 @@ if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null \
+ || true
mv $PRGETC/$PRGNAM.conf $PRGETC/$PRGNAM.conf.new
diff --git a/system/glances/glances.info b/system/glances/glances.info
index bfe3cc9501..d9dd83b841 100644
--- a/system/glances/glances.info
+++ b/system/glances/glances.info
@@ -1,8 +1,8 @@
PRGNAM="glances"
-VERSION="1.7.7"
+VERSION="2.1.2"
HOMEPAGE="https://github.com/nicolargo/glances"
-DOWNLOAD="https://github.com/nicolargo/glances/archive/v1.7.7.tar.gz"
-MD5SUM="f8debb75cbee610b6c2323961c994fd5"
+DOWNLOAD="https://github.com/nicolargo/glances/archive/v2.1.2.tar.gz"
+MD5SUM="a666c5e2de15af8a10faa3e6e08286d9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="psutil pysetuptools"