summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/distribute/README14
-rw-r--r--python/distribute/distribute.SlackBuild67
-rw-r--r--python/distribute/distribute.info10
-rw-r--r--python/distribute/slack-desc19
4 files changed, 0 insertions, 110 deletions
diff --git a/python/distribute/README b/python/distribute/README
deleted file mode 100644
index 6ed20d720e..0000000000
--- a/python/distribute/README
+++ /dev/null
@@ -1,14 +0,0 @@
-distribute is a fork of the setuptools project.
-
-Distribute is intended to replace Setuptools as the standard method for
-working with Python module distributions.
-
-For those who may wonder why they should switch to Distribute over
-Setuptools, it's quite simple:
-
-- Distribute is a drop-in replacement for Setuptools.
-- The code is actively maintained, and has over 10 commiters.
-- Distribute offers Python 3 support!
-
-If you have pysetuptools installed, you need to remove it before installing
-this package.
diff --git a/python/distribute/distribute.SlackBuild b/python/distribute/distribute.SlackBuild
deleted file mode 100644
index efd426a0e3..0000000000
--- a/python/distribute/distribute.SlackBuild
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for distribute
-
-# Copyright 2012-2013 Audrius Kažukauskas <audrius@neutrino.lt>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=distribute
-VERSION=${VERSION:-0.6.36}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# Don't need this.
-rm -f setuptools/*.exe
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-install -m 0644 *.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/distribute/distribute.info b/python/distribute/distribute.info
deleted file mode 100644
index 937e18748b..0000000000
--- a/python/distribute/distribute.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="distribute"
-VERSION="0.6.36"
-HOMEPAGE="https://pythonhosted.org/distribute/"
-DOWNLOAD="https://pypi.python.org/packages/source/d/distribute/distribute-0.6.36.tar.gz"
-MD5SUM="a923385de72dcdca68cd4ac2b9dc1148"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Audrius Kažukauskas"
-EMAIL="audrius@neutrino.lt"
diff --git a/python/distribute/slack-desc b/python/distribute/slack-desc
deleted file mode 100644
index 3b5a6a5117..0000000000
--- a/python/distribute/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-distribute: Distribute (a fork of the Setuptools project)
-distribute:
-distribute: Distribute is intended to replace Setuptools as the standard method
-distribute: for working with Python module distributions.
-distribute:
-distribute: Homepage: https://pythonhosted.org/distribute/
-distribute:
-distribute:
-distribute:
-distribute:
-distribute: