summaryrefslogtreecommitdiffstats
path: root/system/burp/burp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/burp/burp.SlackBuild')
-rw-r--r--system/burp/burp.SlackBuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/system/burp/burp.SlackBuild b/system/burp/burp.SlackBuild
index c106433a52..e7fe1032ba 100644
--- a/system/burp/burp.SlackBuild
+++ b/system/burp/burp.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=burp
-VERSION=${VERSION:-1.3.12}
+VERSION=${VERSION:-1.3.18}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -75,7 +75,7 @@ sed -i 's/gzip/gzip -9/1' manpages/Makefile*
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
- --prefix=/usr \
+ --prefix=/ \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc/$PRGNAM \
--localstatedir=/var \
@@ -94,7 +94,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CHANGELOG CONTRIBUTORS LICENSE README TODO UPGRADING docs \
+ CHANGELOG CONTRIBUTORS DONATIONS LICENSE README TODO UPGRADING docs \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -103,9 +103,12 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
# Rename the config files
-for FILE in $(find $PKG/etc/ -type f); do
+cd $PKG
+for FILE in $(find etc -type f); do
mv $FILE $FILE.new
+ # Preserve the permissions only of executable config files
+ [ -x $FILE.new ] && echo preserve_perms $FILE.new >> $PKG/install/doinst.sh \
+ || echo config $FILE.new >> $PKG/install/doinst.sh
done
-cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}