summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author dsomero <xgizzmo@slackbuilds.org>2010-05-30 12:15:24 -0400
committer dsomero <xgizzmo@slackbuilds.org>2010-05-30 12:15:24 -0400
commitb023cfe065d471e6989ccbc7274b619d5082f517 (patch)
treea2ad90d1ca8f316e8ba78c72a32616ea96640196
parent9035ed3e3c4d9c099305611f3acc336e838103bf (diff)
downloadtemplates-b023cfe065d471e6989ccbc7274b619d5082f517.tar.gz
templates-b023cfe065d471e6989ccbc7274b619d5082f517.tar.xz
Added python example template.
-rw-r--r--python-template.SlackBuild120
1 files changed, 120 insertions, 0 deletions
diff --git a/python-template.SlackBuild b/python-template.SlackBuild
new file mode 100644
index 0000000..c60c129
--- /dev/null
+++ b/python-template.SlackBuild
@@ -0,0 +1,120 @@
+#!/bin/sh
+
+# Slackware build script for <appname>
+
+# Written by (your name) (your contact information)
+
+# (add license information here if you desire; otherwise,
+# all submissions are considered to be in the public domain)
+# Some licenses may incorporate the "Written by" information
+# above, and if so, that line can be omitted
+# We strongly suggest *not* using GPL for scripts, as it requires
+# a copy of the GPL to be distributed with it. Since the GPL
+# itself is longer than any build script will be, this just doesn't
+# make good sense...
+
+# |-----------------------------------------------------------------| #
+# REMOVE THIS ENTIRE BLOCK OF TEXT #
+#
+# This template is not meant to be a 'cut and paste' script to
+# enable any random user to make a working package. While
+# we're certainly not discouraging use of this template, if
+# you haven't manually gone through each step of the process
+# without the build script (typically as a normal user, as this
+# will reveal problems that you won't see as root), then there's
+# a good chance that something important is missing from your
+# submission.
+
+# When using this template script, please remove as many of
+# these unnecessary comments as possible. Commented code is
+# a good thing, but if it's obvious, there's no need to comment it.
+#
+# AGAIN, REMOVE THE COMMENTS IF THEY ARE NOT NEEDED - DON'T JUST
+# DELETE THIS BLOCK OF TEXT WITHOUT BOTHERING TO READ WHAT'S IN IT.
+#
+# |-----------------------------------------------------------------| #
+
+PRGNAM=appname # replace with name of program
+VERSION=${VERSION:-1.4.1} # replace with version of program
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo} # the "_SBo" is required
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+# Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo} # For consistency's sake, use this
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp} # Drop the package in /tmp
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Your application may need different configure flags;
+# these are provided as an example only.
+python setup.py install --root=$PKG
+
+# Strip binaries and libraries.
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Compress man pages
+# If the man pages are installed to /usr/share/man instead, you'll need to
+# move them manually.
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+# Copy program documentation into the package
+# The included documentation varies from one application to another, so be sure
+# to adjust your script as needed
+# Also, include the SlackBuild script in the documentation directory
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ <documentation> \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Copy the slack-desc (and a custom doinst.sh if necessary) into ./install
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+# Make the package; be sure to leave it in $OUTPUT
+# If package symlinks need to be created during install *before*
+# your custom contents of doinst.sh runs, then add the -p switch to
+# the makepkg command below -- see makepkg(8) for details
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}