summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2010-05-12 23:33:34 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 23:33:34 +0200
commit4271b44b5a41e134d5684ef1899f45e536cd3ea6 (patch)
tree16ab3655a794b76bcbe6c5c14a497fa13a5bab6b
parent4452cfd2aa787fdcd843bc7ccbeb5ad3e07b6223 (diff)
downloadslackbuilds-4271b44b5a41e134d5684ef1899f45e536cd3ea6.tar.gz
slackbuilds-4271b44b5a41e134d5684ef1899f45e536cd3ea6.tar.xz
system/fxload: Added to 12.2 repository
-rw-r--r--system/fxload/Makefile.patch11
-rw-r--r--system/fxload/README14
-rw-r--r--system/fxload/fxload.SlackBuild87
-rw-r--r--system/fxload/fxload.info8
-rw-r--r--system/fxload/slack-desc19
5 files changed, 139 insertions, 0 deletions
diff --git a/system/fxload/Makefile.patch b/system/fxload/Makefile.patch
new file mode 100644
index 0000000000..71f7e99870
--- /dev/null
+++ b/system/fxload/Makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile 2008-10-13 18:44:04.000000000 -0300
++++ Makefile.diff 2009-04-06 14:41:17.000000000 -0300
+@@ -13,7 +13,7 @@
+
+ PROG = fxload
+
+-CFLAGS = -O -Wall $(RPM_OPT_FLAGS)
++CFLAGS += -Wall $(RPM_OPT_FLAGS)
+
+ FILES_SRC_C = ezusb.c main.c
+ FILES_SRC_H = ezusb.h
diff --git a/system/fxload/README b/system/fxload/README
new file mode 100644
index 0000000000..cce7caec98
--- /dev/null
+++ b/system/fxload/README
@@ -0,0 +1,14 @@
+FXLOAD is conveniently able to download firmware into FX, FX2,
+and FX2LP EZ-USB devices, as well as the original AnchorChips EZ-USB.
+It is intended to be invoked by hotplug scripts when the unprogrammed
+device appears on the bus.
+
+Primarily as an aid for developers, this can also be used to update
+firmware on devices which boot from I2C serial EEPROMs. For that
+use, as well as downloading firmware to all other off-chip memory,
+a second stage loader must first be downloaded.
+
+The distribution includes "a3load.hex", which is a simple second stage
+loader that works with all the EZ-USB products listed above. If you
+want to write to an EEPROM, you can use the appropriate version of the
+"Vend_Ax" code provided with the Cypress developer kit.
diff --git a/system/fxload/fxload.SlackBuild b/system/fxload/fxload.SlackBuild
new file mode 100644
index 0000000000..22a085a8d0
--- /dev/null
+++ b/system/fxload/fxload.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for fxload
+
+# Copyright 2009 Andre Barboza
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Written by Andre Barboza <bmg.andre at gmail.com>
+
+PRGNAM=fxload
+VERSION=${VERSION:-2008_10_13}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+patch Makefile $CWD/Makefile.patch
+
+CFLAGS="$SLKCFLAGS" make
+make install prefix=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mv $PKG/usr/share/man $PKG/usr
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/fxload/fxload.info b/system/fxload/fxload.info
new file mode 100644
index 0000000000..9e8177b18b
--- /dev/null
+++ b/system/fxload/fxload.info
@@ -0,0 +1,8 @@
+PRGNAM="fxload"
+VERSION="2008_10_13"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+DOWNLOAD="http://downloads.sourceforge.net/linux-hotplug/fxload-2008_10_13.tar.gz"
+MD5SUM="4477a2457f064228bef4a93ba2f21692"
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
+APPROVED="rworkman"
diff --git a/system/fxload/slack-desc b/system/fxload/slack-desc
new file mode 100644
index 0000000000..99e7574faa
--- /dev/null
+++ b/system/fxload/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-------------------------------------------------------|
+fxload: fxload (FX device firmware loader)
+fxload:
+fxload: This program is conveniently able to download firmware into FX, FX2,
+fxload: and FX2LP EZ-USB devices, as well as the original AnchorChips EZ-USB.
+fxload: It is intended to be invoked by hotplug scripts when the unprogrammed
+fxload: device appears on the bus.
+fxload:
+fxload: Homepage: http://linux-hotplug.sourceforge.net
+fxload:
+fxload:
+fxload: