summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Cristiano Urban <cristiano.urban.slack@gmail.com>2016-07-25 22:58:51 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-25 22:58:51 +0700
commit3b295c04e664409e86f1fc0a7bea151a03f0c96f (patch)
tree03e226bee6339aace5f1ff9571c2971f05bd040f
parent582674928895e3e4abc12dcbe428edabb77f60db (diff)
downloadslackbuilds-3b295c04e664409e86f1fc0a7bea151a03f0c96f.tar.gz
slackbuilds-3b295c04e664409e86f1fc0a7bea151a03f0c96f.tar.xz
system/I-Nex: Added (System information tool).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/I-Nex/I-Nex.SlackBuild108
-rw-r--r--system/I-Nex/I-Nex.info10
-rw-r--r--system/I-Nex/README8
-rw-r--r--system/I-Nex/doinst.sh3
-rw-r--r--system/I-Nex/slack-desc19
5 files changed, 148 insertions, 0 deletions
diff --git a/system/I-Nex/I-Nex.SlackBuild b/system/I-Nex/I-Nex.SlackBuild
new file mode 100644
index 0000000000..7f797d17a9
--- /dev/null
+++ b/system/I-Nex/I-Nex.SlackBuild
@@ -0,0 +1,108 @@
+#!/bin/sh
+
+# Slackware build script for I-Nex
+
+# Copyright (c) 2016 Cristiano Urban, Gonars, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=I-Nex
+VERSION=${VERSION:-7.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+mv $VERSION.tar.gz $PRGNAM-$VERSION.tar.gz
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i 's|python3$|python2|' pastebinit
+sed -i -e 's|^STATIC.*|STATIC = false|' i-nex.mk
+
+cd $PRGNAM
+autoreconf --install
+
+CFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+cd ..
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man/ $PKG/usr/
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $PRGNAM/COPYING $PRGNAM/INSTALL $PRGNAM/README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/I-Nex/I-Nex.info b/system/I-Nex/I-Nex.info
new file mode 100644
index 0000000000..b2433722d5
--- /dev/null
+++ b/system/I-Nex/I-Nex.info
@@ -0,0 +1,10 @@
+PRGNAM="I-Nex"
+VERSION="7.4.0"
+HOMEPAGE="https://github.com/eloaders/I-Nex"
+DOWNLOAD="https://github.com/eloaders/I-Nex/archive/7.4.0.tar.gz"
+MD5SUM="316632d04ef4708a4e9a816ec871ddea"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="gambas3 libcpuid"
+MAINTAINER="Cristiano Urban"
+EMAIL="cristiano.urban.slack@gmail.com"
diff --git a/system/I-Nex/README b/system/I-Nex/README
new file mode 100644
index 0000000000..f28bf5ad4e
--- /dev/null
+++ b/system/I-Nex/README
@@ -0,0 +1,8 @@
+I-Nex is an application that gathers information for hardware
+components available on your system and displays it using an
+user interface similar to the popular Windows tool CPU-Z.
+
+I-Nex can display information for the following components:
+CPU, GPU, Motherboard, Sound, Hard disks, RAM, Network and USB
+as well as some system info like the hostname, Linux distribution
+and version, Xorg, GCC, GLX versions and Linux Kernel info.
diff --git a/system/I-Nex/doinst.sh b/system/I-Nex/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/system/I-Nex/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/system/I-Nex/slack-desc b/system/I-Nex/slack-desc
new file mode 100644
index 0000000000..c739be7023
--- /dev/null
+++ b/system/I-Nex/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+I-Nex: I-Nex (System information tool)
+I-Nex:
+I-Nex: I-Nex is an application that gathers information for hardware
+I-Nex: components available on your system and displays it using an
+I-Nex: user interface similar to the popular Windows tool CPU-Z.
+I-Nex:
+I-Nex: Homepage: http://i-nex.linux.pl
+I-Nex:
+I-Nex:
+I-Nex:
+I-Nex: