summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-09-25 09:51:05 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-09-25 09:51:05 +0700
commitf060fba6d066d7a789215bdef916b65fe5332ec3 (patch)
tree07ec97a1f2c45ada7b49beca074bb619a3bf5c88
parent4e1ec0dd4d353ff43a11cdb2a0bfb880f3cd4415 (diff)
downloadslackbuilds-f060fba6d066d7a789215bdef916b65fe5332ec3.tar.gz
slackbuilds-f060fba6d066d7a789215bdef916b65fe5332ec3.tar.xz
multimedia/Poor-Mans-Spotify: Removed (Project name renamed).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--multimedia/Poor-Mans-Spotify/Poor-Mans-Spotify.SlackBuild87
-rw-r--r--multimedia/Poor-Mans-Spotify/Poor-Mans-Spotify.info10
-rw-r--r--multimedia/Poor-Mans-Spotify/README3
-rw-r--r--multimedia/Poor-Mans-Spotify/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/multimedia/Poor-Mans-Spotify/Poor-Mans-Spotify.SlackBuild b/multimedia/Poor-Mans-Spotify/Poor-Mans-Spotify.SlackBuild
deleted file mode 100644
index 28cf9654b7..0000000000
--- a/multimedia/Poor-Mans-Spotify/Poor-Mans-Spotify.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Poor-Mans-Spotify
-
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=Poor-Mans-Spotify
-VERSION=${VERSION:-0.18.40}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-
-cp -a README PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/Poor-Mans-Spotify/Poor-Mans-Spotify.info b/multimedia/Poor-Mans-Spotify/Poor-Mans-Spotify.info
deleted file mode 100644
index 378afa8139..0000000000
--- a/multimedia/Poor-Mans-Spotify/Poor-Mans-Spotify.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Poor-Mans-Spotify"
-VERSION="0.18.40"
-HOMEPAGE="http://github.com/np1/pms/"
-DOWNLOAD="https://pypi.python.org/packages/source/P/Poor-Mans-Spotify/Poor-Mans-Spotify-0.18.40.tar.gz"
-MD5SUM="300ff6e7115415550d0a927febec3fb0"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/multimedia/Poor-Mans-Spotify/README b/multimedia/Poor-Mans-Spotify/README
deleted file mode 100644
index 76893c4243..0000000000
--- a/multimedia/Poor-Mans-Spotify/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Search, Stream and Download MP3.
-Poor-Mans-Spotify is run on the command line using the command:
-$ pms
diff --git a/multimedia/Poor-Mans-Spotify/slack-desc b/multimedia/Poor-Mans-Spotify/slack-desc
deleted file mode 100644
index d6df781add..0000000000
--- a/multimedia/Poor-Mans-Spotify/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Poor-Mans-Spotify: Poor-Mans-Spotify (Search, Stream and Download MP3)
-Poor-Mans-Spotify:
-Poor-Mans-Spotify: Search and stream music
-Poor-Mans-Spotify:
-Poor-Mans-Spotify: Homepage: http://github.com/np1/pms/
-Poor-Mans-Spotify:
-Poor-Mans-Spotify:
-Poor-Mans-Spotify:
-Poor-Mans-Spotify:
-Poor-Mans-Spotify:
-Poor-Mans-Spotify: