summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-09-25 02:09:36 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-09-25 07:04:49 +0700
commitf6bf963e2bebcb543805b484d901a64c304efa7e (patch)
treec8db559ae5d861aa576c7179d0bef85e0d94f8f0
parenta9543a7fca52144b430b9f29afa1d39d877fe66c (diff)
downloadslackbuilds-f6bf963e2bebcb543805b484d901a64c304efa7e.tar.gz
slackbuilds-f6bf963e2bebcb543805b484d901a64c304efa7e.tar.xz
python/rebulk: Added (Advanced searches in strings).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/rebulk/README7
-rw-r--r--python/rebulk/rebulk.SlackBuild85
-rw-r--r--python/rebulk/rebulk.info10
-rw-r--r--python/rebulk/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/python/rebulk/README b/python/rebulk/README
new file mode 100644
index 0000000000..ac9f40a630
--- /dev/null
+++ b/python/rebulk/README
@@ -0,0 +1,7 @@
+ReBulk is a python library that performs advanced searches
+in strings that would be hard to implement using re module
+or String methods only.
+
+It includes some features like Patterns, Match, Rule that
+allows developers to build a custom and complex string
+matcher using a readable and extendable API.
diff --git a/python/rebulk/rebulk.SlackBuild b/python/rebulk/rebulk.SlackBuild
new file mode 100644
index 0000000000..b4f1b55685
--- /dev/null
+++ b/python/rebulk/rebulk.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for rebulk
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=rebulk
+VERSION=${VERSION:-0.7.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/rebulk/rebulk.info b/python/rebulk/rebulk.info
new file mode 100644
index 0000000000..28941d1b8e
--- /dev/null
+++ b/python/rebulk/rebulk.info
@@ -0,0 +1,10 @@
+PRGNAM="rebulk"
+VERSION="0.7.6"
+HOMEPAGE="https://github.com/Toilal/rebulk/"
+DOWNLOAD="https://pypi.python.org/packages/1b/e6/ff6bab7e66679a01ea52b0269a354df3a8047572eac107fff70110f5d943/rebulk-0.7.6.tar.gz"
+MD5SUM="aa823265a156b8a0c7f448b5be32db1d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="six"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/rebulk/slack-desc b/python/rebulk/slack-desc
new file mode 100644
index 0000000000..dae3a249b0
--- /dev/null
+++ b/python/rebulk/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+rebulk: rebulk (Advanced searches in strings)
+rebulk:
+rebulk: ReBulk is a python library that performs advanced searches in strings
+rebulk: that would be hard to implement using re module or String methods
+rebulk: only. It includes some features like Patterns, Match, Rule that
+rebulk: allows developers to build a custom and complex string matcher using
+rebulk: a readable and extendable API.
+rebulk:
+rebulk: Homepage: https://github.com/Toilal/rebulk/
+rebulk:
+rebulk: